CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM Installation (
-   -   Compiling Problem on Debian (

besto July 17, 2008 09:47

Hi, well, i just got the Op

well, i just got the OpenFOAM 1.5 and tried to compile. To do so, i got also the ThirdPartylinuxGcc.gtgz packet (so the binaries). Anyway, i did get the .bashrc modified and ran ./Allmake.

Now after some time i found out, it didn't find the flex++. Since i didn't feel like editing the make script, i simply installed it from the debian distribution (i use debian testing = lenny:
uname -a
Linux client4 2.6.24-1-686 #1 SMP Thu May 8 02:16:39 UTC 2008 i686 GNU/Linux)
Anyway compiling does produce a lot of lines so it was hard to get the first error messages. So i did
This way only the error messages went to the screen. And here is what i got:

./Allwmake >output.txt
+ cd .
+ cd wmake/src
+ make
+ cd /home/bs/OpenFOAM/ThirdParty
+ ./Allwmake
./Allwmake: line 10: ./Allwmake: Datei oder Verzeichnis nicht gefunden (this is file not found in German)
+ cd src
+ ./Allwmake
+ cd OpenFOAM
+ wmakeLnInclude .
+ cd Pstream
+ ./Allwmake
+ wmake libso dummy
+ case "$WM_MPLIB" in
+ export WM_OPTIONS=linuxGccDPOptOPENMPI
+ set +x
+ wmake libso mpi
+ wmake libo OSspecific/Unix
+ wmake libso OpenFOAM
+ wmake libso lagrangian/basic
+ wmake libso triSurface
+ wmake libso edgeMesh
+ wmake libso meshTools
+ wmake libso finiteVolume
+ cd decompositionAgglomeration
+ ./Allwmake
+ wmake libso decompositionMethods
metisDecomp/metisDecomp.C:37:22: error: metis.h: Datei oder Verzeichnis nicht gefunden (which means file not found in German)
metisDecomp/metisDecomp.C: In member function 'Foam::label Foam::metisDecomp::decompose(const Foam::List<int>&, const Foam::List<int>&, Foam::List<int>&)':
metisDecomp/metisDecomp.C:268: error: 'METIS_WPartGraphRecursive' was not declared in this scope
metisDecomp/metisDecomp.C:285: error: 'METIS_PartGraphRecursive' was not declared in this scope
metisDecomp/metisDecomp.C:306: error: 'METIS_WPartGraphKway' was not declared in this scope
metisDecomp/metisDecomp.C:323: error: 'METIS_PartGraphKway' was not declared in this scope
make: *** [Make/linuxGccDPOpt/metisDecomp.o] Fehler 1
+ '[' -d /home/bs/OpenFOAM/OpenFOAM-1.5/lib/linuxGccDPOpt/openmpi-1.2.6 ']'
+ wmake libso parMetisDecomp
parMetisDecomp.C:41:25: error: parmetis.h: Datei oder Verzeichnis nicht gefunden

and so on.
Anybody has an idea of what's missing?

olesen July 17, 2008 10:03

Since you have the machine in
Since you have the machine in front of you, you're probably in a better position to see why it can't find the file, but maybe it's a permissions problem, since the chdir to "/home/bs/OpenFOAM/ThirdParty" was successful and the Allwmake script certainly exists in the tarball:
$ tar -tzf ThirdParty.General.gtgz | grep Allwmake

Did you unpack it in the correct directory?
Maybe you have ThirdParty/ThirdParty or something.
Or did you just unpack the binaries?

besto July 17, 2008 16:49

O.k. this doesn't work since i
O.k. this doesn't work since i used the binary package ThirdPartylinuxGcc.gtgz and there is no Allwmake inside as it is already compiled. Now this should not be a problen should it?

olesen July 18, 2008 02:44

Yes it will definitely be a pr
Yes it will definitely be a problem. As your post showed, the other libraries have no information about what can be found in these pre-compiled ThirdParty libraries.

It's really no different that trying to compile any C/C++ program without having /usr/include header files!

besto July 21, 2008 09:46

O.k. strange, but it is this w
O.k. strange, but it is this way. After installing some additional libraries it all worked fine. Thanx!

gbrother July 26, 2008 10:18

Bernhard, I'm running Debian E
Bernhard, I'm running Debian Etch and compiled the 32-bit OpenFOAM 1.5

Is there a log that is written for ./Allwmake because I, too, am having a problem installing.

I had to compile from source the qt4.3.5 libs; which failed and I had to install the x11-dev libs which allowed qt to finish. But my ./Allwmake seems to keep failing "due to errors" however I don't know where to look to see what "errors" are occurring.

Also, which additional libraries did you install to allow your version to complete without error?

Does ParaView run for you? ParaView says it cannot find my qt shared objects; which I added to my path directly and verified they do exist.

Thanks for your time!

-Gene Brotherton

besto July 31, 2008 09:35

Hi Gene, what i did, was si
Hi Gene,

what i did, was simply to write the standard output in a file:
./Allwmake > file.txt
The rest of the output are the error-messages, they can be still quite a lot. Usually the important ones are nevertheless at the top.
Now, all the libraries needed i installed from the debian package. Therefore i didn't compile qt, but i installed the qt-dev package (also for quite a lot of the other packages). This somehow worked.
For Paraview i cannot say much yet. I didn't get around to use it yet.


gbrother August 4, 2008 00:16

Thanks Bernhard! I did what y
Thanks Bernhard! I did what you suggested by piping the output to a txt file so I could see the errors better. There were a lot more packages I had to install, (flex being one of them; I have never heard of flex before this). And finally I realized I had to copy the Qt libs from the default trolltech install directory to my /usr/libs directory. It appears OF did everything it was supposed to do expect the paraview build. I had to rebuild that by following the instructions on the OF web page, then paraview compiled and functioned normally.

I am still very new to the CFD world, but i think this software will help once I get the hang of things.

Thanks again!


msrinath80 August 13, 2008 15:29

For the record, I would like t
For the record, I would like to say that I was able to build the 1.5 version without any issues on Debian (testing) :-)

All times are GMT -4. The time now is 04:23.