CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM Installation (
-   -   Paraview33 build problem (

sds August 5, 2008 09:33

Hello, I am trying to build

I am trying to build Paraview3.3 on my RHEL 5.0 machine (Qt 4.3.1). The build script runs fine, but when I try to run paraview I get the error:

"paraview: /usr/lib64/ version `GLIBCXX_3.4.9' not found ..."

I have tried adding the gcc libraries to my LD_LIBRARY_PATH, and have tried the solution suggested by Mattijs here: but have not had any luck yet.

Any help would be greatly appreciated. Thanks in advance.


mattijs August 5, 2008 14:06

This does sound exactly like t
This does sound exactly like the problem I had: the vtk .so libraries point to /usr/lib64, not to my c++ compiler.

- what is your c++ compiler (which c++)
- Check for that VTK_USE_RPATH variable (see my previous post)

sds August 5, 2008 14:57

Hi Mattijs, Thanks for your
Hi Mattijs,

Thanks for your quick response.

It looks like your previously posted solution worked for me after all. I updated my Qt to 4.3.5 and it worked while using "VTK_USE_RPATH:BOOL=OFF". While I had Qt 4.3.1 installed I was given a 'Segmentation fault' after building with the option.


All times are GMT -4. The time now is 11:17.