CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM Installation (
-   -   Error while compiling FoamX related applications (

geoffjay May 7, 2008 13:21

When I run FoamX I receive an
When I run FoamX I receive an error saying that it can't find FoamXHostBrowser, which FoamXHostBrowser confirms this so I've tried to recompile the source in the directory ~/OpenFOAM/OpenFOAM-1.4.1/applications/utilities/preProcessing/FoamX/C++ and I get the following error output:

+ case $WM_ARCH in
+ CMD='wmake libso'
+ cd FoamXServer
+ wmake libso
`/apps/OpenFOAM/OpenFOAM-1.4.1/lib/linux64GccDPOpt/' is up to date.
+ cd FoamXLib
+ wmake libso
/usr/bin/ld: cannot find -lssl
collect2: ld returned 1 exit status
make: *** [/apps/OpenFOAM/OpenFOAM-1.4.1/lib/linux64GccDPOpt/] Error 1
+ cd FoamXHostBrowser
+ wmake
g++ -m64 -Dlinux64 -DDP -Wall -Wno-strict-aliasing -Wextra -Wno-unused-parameter -Wold-style-cast -march=opteron -O3 -DNoRepository -ftemplate-depth-40 -I/apps/OpenFOAM/OpenFOAM-1.4.1/src/mico-2.3.12/platforms/linux64GccDPOpt/includ e -Wno-old-style-cast -I../FoamXLib/lnInclude -I../FoamXServer -IlnInclude -I. -I/apps/OpenFOAM/OpenFOAM-1.4.1/src/OpenFOAM/lnInclude -fPIC Make/linux64GccDPOpt/FoamXHostBrowser.o Make/linux64GccDPOpt/IHostBrowserImpl.o -L/apps/OpenFOAM/OpenFOAM-1.4.1/lib/linux64GccDPOpt \
-lFoamX -lFoamXServer -L/apps/OpenFOAM/OpenFOAM-1.4.1/src/mico-2.3.12/platforms/linux64GccDPOpt/lib -lmicocoss2.3.12 -lmico2.3.12 -lssl -lcrypto -ldl -lpthread -lOpenFOAM -liberty -ldl -lm -o /apps/OpenFOAM/OpenFOAM-1.4.1/applications/bin/linux64GccDPOpt/FoamXHostBrowser
/usr/bin/ld: cannot find -lFoamX
collect2: ld returned 1 exit status
make: *** [/apps/OpenFOAM/OpenFOAM-1.4.1/applications/bin/linux64GccDPOpt/FoamXHostBrowser ] Error 1

(... error output continues but is similar for the other applications in the directory)

My system is SuSE 10.1 x86_64, and according to foamInstallationTest everything is correct with my installation.

Does anyone know where I should look? At one point the error says "cannot find -lFoamX", does this mean another part of of my Foam installation is incomplete?

mbeaudoin May 7, 2008 17:11

Hello, > /usr/bin/ld: canno

> /usr/bin/ld: cannot find -lssl

You are missing a library called libssl.

You need this library in order to link an application based on Mico/Corba. Encryption is part of the communication layer of Corba, so you need to have the dev package for libopenssl on your system.

On my SuSE 10.3 x86_64 system, libssl.a is provided by the following RPM: libopenssl-devel-0.9.8e-45.5.


geoffjay May 7, 2008 19:43

Argh. Thanks. I didn't even se
Argh. Thanks. I didn't even see that error message. I feel a little silly now.

All times are GMT -4. The time now is 06:36.