CFD Online Discussion Forums

CFD Online Discussion Forums (https://www.cfd-online.com/Forums/)
-   OpenFOAM Installation (https://www.cfd-online.com/Forums/openfoam-installation/)
-   -   Gcc for SGI IRIX 65 (https://www.cfd-online.com/Forums/openfoam-installation/57398-gcc-sgi-irix-65-a.html)

Ali (Ali) January 13, 2005 15:58

I'm trying to find a proper g
 
I'm trying to find a proper gcc version for IRIX 6.5. I had gcc-3.3.1 that was supplied (binary files) along with foam2.2 previously. Now, when I want to use it with openFOAM, it does not recognize it. Is there anywhere in the code the gcc version has been set in the OpenFOAM code?

Or, Is there any place I can download latest version of gcc for IRIX6.5?

Henry Weller (Henry) January 13, 2005 16:01

The gcc version OpenFOAM uses
 
The gcc version OpenFOAM uses is set in OpenFOAM-1.0.2/.bashrc and OpenFOAM-1.0.2/.cshrc and you could change this to gcc-3.3.1 although I strongly recommend that you don't but instead compile gcc-3.4.3 from sources which is very easy.

Manuel Garcia (Garcia) January 14, 2005 22:05

Hi, I'm also trying to compile
 
Hi, I'm also trying to compile openFOAM in an IRIX6.5 with several processors. I tried with gcc version 3.3 but at some points I get some compiler errors like this:

<FONT FACE="courier"> ln Include/treeBoundBoxI.H: In member function `label
Foam::treeBoundBox::subOctant(const Foam::point&, const Foam::point&, bool)
const':
lnInclude/treeBoundBoxI.H:171: internal compiler error: in trunc_int_for_mode,
at explow.c:54
Please submit a full bug report, with preprocessed source if appropriate.</FONT>


Then I followed the advice and download the source of gcc-3.4.3. I am in the process of compiling/installing and I have some questions about.

Does the compiler has to be installed in the $WM_PROJECT_INST_DIR/$WM_ARCH/ or can it be somewhere else in the system? so it can be used by other users? Why is under $WM_PROJECT_INST_DIR/$WM_ARCH anyway?

Has OpenFOAM been compiled with the native SGI compiler? My experience with some other software was that the native SGI compiler produces faster binaries.

finally, I plan to run OpenFOAM using the SGI MPI library but I have not found how to specify that in the configuration.

thanks very much for your help.

Manuel

Henry Weller (Henry) January 15, 2005 05:12

> Does the compiler has to b
 
> Does the compiler has to be installed in the $WM_PROJECT_INST_DIR/$WM_ARCH/ or can it be somewhere else in the system?

It can be anywhere as long as the $PATH and $LD_LIBRARY_PATH are set to include the location.

> Why is under $WM_PROJECT_INST_DIR/$WM_ARCH anyway?

Where would you rather we put it?

> Has OpenFOAM been compiled with the native SGI compiler?

Many years ago when it was a good compiler but now it's way out of date and cannot handle the complete C++ standard and certainly cannot compile FOAM. The compilers that can are gcc, the Intel compiler, the KAI compiler and maybe the IBM compiler but it's really tricky to use and I gave up last time. Thwere may be others which I haven't tried.

> finally, I plan to run OpenFOAM using the SGI MPI library
but I have not found how to specify that in the
configuration.

That's the default setup on SGI so you shouldn't have to do anything different.

Manuel Garcia (Garcia) January 26, 2005 16:25

Hi, I am finally back to comp
 
Hi, I am finally back to compile openFOAM on the IRIX6.5 (the system was reinstalled in the computer)
I can make the binaries available for everyone, once I manage to compile the whole thing.

I download, compile and install gcc 3.4.3 under
./configure --prefix=$HOME/OpenFOAM/sgiN32/gcc-3.4.3

it compiled ok.

I have not installed paraview or java-sdk yet. Is there a pointer where I can download paraview?


I tryied to compile OpenFOAM-1.0.2 with the standar configuration

but I get this error:

gmake[1]: Entering directory `/usr/cadomin4/fluidsim/OpenFOAM/OpenFOAM-1.0.2/src/mico-2.3.11/adm
in'
c++ -I../include -O2 -Wall -c mkdepend.cc -o mkdepend.o
mkdepend.cc: In function `void mkdep(const std::string&, const svec&)':
mkdepend.cc:115: warning: 'pos2' might be used uninitialized in this function
c++ -I../include -O2 -Wall mkdepend.o -ldl -lelf -lbsd -lsocket -lnsl -lm -o mkdepend
ld32: WARNING 84 : /usr/lib32/libdl.so is not used for resolving any symbol.
ld32: WARNING 84 : /usr/lib32/libelf.a is not used for resolving any symbol.
ld32: WARNING 84 : /usr/lib32/libbsd.a is not used for resolving any symbol.
ld32: WARNING 84 : /usr/lib32/libsocket.so is not used for resolving any symbol.
ld32: WARNING 84 : /usr/lib32/libnsl.so is not used for resolving any symbol.
ld32: WARNING 84 : /usr/lib32/libm.so is not used for resolving any symbol.
ld32: WARNING 127: Two shared objects with the same soname, /usr/lib32/mips3/libm.so and /usr/li
b32/libm.so,
have been been linked. This is probably due to a missing -L specification. Ig
noring the latter.
gmake[1]: Leaving directory `/usr/cadomin4/fluidsim/OpenFOAM/OpenFOAM-1.0.2/src/mico-2.3.11/admi
n'
gmake[1]: Entering directory `/usr/cadomin4/fluidsim/OpenFOAM/OpenFOAM-1.0.2/src/mico-2.3.11/inc
lude'
gmake[1]: Nothing to be done for `adm'.
gmake[1]: Leaving directory `/usr/cadomin4/fluidsim/OpenFOAM/OpenFOAM-1.0.2/src/mico-2.3.11/incl
ude'
for i in orb ir idl auxdir coss ccm; do gmake -C $i lib || exit 1; done
gmake[1]: Entering directory `/usr/cadomin4/fluidsim/OpenFOAM/OpenFOAM-1.0.2/src/mico-2.3.11/orb
'
echo '# Module dependencies' > .depend
/usr/cadomin4/fluidsim/OpenFOAM/OpenFOAM-1.0.2/src/mico-2.3.11/./admin/mkdepend -I../include -O
2 -Wall *.cc >> .depend
/usr/cadomin4/fluidsim/OpenFOAM/OpenFOAM-1.0.2/src/mico-2.3.11/./admin/mkdepend -I../include -O
2 -Wall transport/*.cc >> .depend
/usr/cadomin4/fluidsim/OpenFOAM/OpenFOAM-1.0.2/src/mico-2.3.11/./admin/mkdepend -I../include -O
2 -Wall os-thread/*.cc >> .depend
/usr/cadomin4/fluidsim/OpenFOAM/OpenFOAM-1.0.2/src/mico-2.3.11/./admin/mkdepend -I../include -O
2 -Wall security/*.cc >> .depend
c++ -I../include -O2 -Wall -c os-unix.cc -o os-unix.o
In file included from os-unix.cc:53:
../include/mico/os-math.h: In static member function `static MICO_Double OSMath::infinity(MICO_B
oolean)':
../include/mico/os-math.h:335: error: `floor' undeclared (first use this function)
../include/mico/os-math.h:335: error: (Each undeclared identifier is reported only once for each
function it appears in.)
../include/mico/os-math.h: In static member function `static MICO_Double OSMath::nan()':
../include/mico/os-math.h:354: error: `asin' undeclared (first use this function)
../include/mico/os-math.h: In static member function `static MICO_Boolean OSMath::is_infinity(MI
CO_Double)':
../include/mico/os-math.h:366: error: `isnan' undeclared (first use this function)
../include/mico/os-math.h: In static member function `static MICO_Boolean OSMath::is_nan(MICO_Do
uble)':
../include/mico/os-math.h:375: error: `isnan' undeclared (first use this function)
../include/mico/os-math.h: In static member function `static MICO_LongDouble OSMath::infinityl(M
ICO_Boolean)':
../include/mico/os-math.h:394: error: `floor' undeclared (first use this function)
../include/mico/os-math.h: In static member function `static MICO_LongDouble OSMath::nanl()':
../include/mico/os-math.h:413: error: `asinl' undeclared (first use this function)
../include/mico/os-math.h: In static member function `static MICO_Boolean OSMath::is_nanl(MICO_L
ongDouble)':
../include/mico/os-math.h:434: error: `isnanl' undeclared (first use this function)
gmake[1]: *** [os-unix.o] Error 1
gmake[1]: Leaving directory `/usr/cadomin4/fluidsim/OpenFOAM/OpenFOAM-1.0.2/src/mico-2.3.11/orb'
gmake: *** [system] Error 1

Any help will be appreciated

Manuel

Manuel Garcia (Garcia) February 3, 2005 02:52

Hi, I keep with my intenti
 
Hi,

I keep with my intentions of compiling OpenFOAM on IRIX6.5. The idea is to have it running in the network of large computers (WestGrid Canada). I was using a different software for this project but when I knew of OpenFOAM I swap to it. I hope I made the right desition, I am quite new to OpenFOAM but it looks great so far. I know there are people interested in the binaries and I will make them available when there are ready. In the mean time I still have some compilation errors:

SOURCE_DIR=OSspecific/Unix
SOURCE=OSspecific/Unix/sigfpe.C ; g++ -mabi=n32 -mips4 -DsgiN32 -DsgiN32GccOpt -DscalarMachine -DoptSolvers -Wall -W -Wno-unused-parameter -O3 -ffast-math -fno-schedule-insns -DNoRepository -ftemplate-depth-30 -I/home/uofacvs/OpenFOAM/OpenFOAM-1.0.2/src/OpenFOAM/lnInclude -IlnInclude -I. -DWM_PROJECT_VERSION='"'1.0.2'"' -I/home/uofacvs/OpenFOAM/OpenFOAM-1.0.2/src/zlib-1.2.1 -fPIC -c $SOURCE -o Make/sgiN32GccOpt/sigfpe.o
OSspecific/Unix/sigfpe.C: In constructor `Foam::sigfpe::sigfpe()':
OSspecific/Unix/sigfpe.C:111: error: expected `)' before numeric constant
/usr/include/sigfpe.h:629: error: too few arguments to function `void handle_sigfpes(int, int, void (*)(unsigned int*, int*), int, void (*)(unsigned int**))'
OSspecific/Unix/sigfpe.C:114: error: at this point in file


It would seem that the call to handle_sigfpes is incorrect.

Any help would be highly appreciated

My last problem compiling mico-2.3.11 was solved by using gcc-3.3. It didn't like gcc-3.4.3 on SGI.

Manuel

Nils Smeds (Smeds) February 3, 2005 03:34

I would try by modifying:

 
I would try by modifying:<PRE>handle_sigfpes
(
_ON,
_EN_DIVZERO
| _EN_INVALID
| _EN_OVERFL
0,
_ABORT_ON_ERROR,
0
);</PRE>
to:<PRE>handle_sigfpes
(
_ON,
_EN_DIVZERO
| _EN_INVALID
| _EN_OVERFL <FONT COLOR="ff0000">,</FONT>
0,
_ABORT_ON_ERROR,
<FONT COLOR="ff0000">NULL</FONT>
);</PRE>

Mattijs Janssens (Mattijs) February 3, 2005 06:41

Hi Manual, Nils if you're
 
Hi Manual, Nils

if you're sure of the fix (we don't have access to an sgi) please send it to us so we can include it. Same goes ofcourse for any other fixes.

Mattijs

Nils Smeds (Smeds) February 3, 2005 11:57

I don't have a system to test
 
I don't have a system to test on either. So we will have to wait for Manuel's response.

/Nils

<BLOCKQUOTE><HR SIZE=0><!-Quote-!><FONT SIZE=1>Quote:</FONT>

if you're sure of the fix (we don't have access to an sgi) please send it to us so we can include it. Same goes of course for any other fixes.<!-/Quote-!><HR SIZE=0></BLOCKQUOTE>

Manuel Garcia (Garcia) February 3, 2005 14:30

great!. it solves the problem
 
great!. it solves the problem. I will keep compiling the rest


thanks


manuel

Manuel Garcia (Garcia) February 8, 2005 15:44

Hi there, this is a new compi
 
Hi there, this is a new compiling error that I am getting in the IRIX6.5

for some reason is not making up the command properly, it should be:
mv lex.yy.cc Make/sgiN32GccOpt/readSTLASCII.C
but it does
mv lex.yy.cc .C

see below for details. Any idea why it does not get the command properly? thank you

manuel

> wmake libso triSurface
`lnInclude/uptodate' is up to date.
`Make/sgiN32GccOpt/dependencies' is up to date.
libso
SOURCE_DIR=triSurface/interfaces/STL
SOURCE=triSurface/interfaces/STL/readSTLASCII.L ; foamFlex++ -f $SOURCE ; mv lex.yy.cc .C ; g++ -mabi=n32 -mips4 -DsgiN32 -DsgiN32GccOpt -DscalarMachine -DoptSolvers -Wall -W -Wno-unused-parameter -O3 -ffast-math -fno-schedule-insns -DNoRepository -ftemplate-depth-30 -I/home/uofacvs/OpenFOAM/OpenFOAM-1.0.2/src/OpenFOAM/lnInclude -IlnInclude -I. -DWM_PROJECT_VERSION='"'1.0.2'"' -I/home/uofacvs/OpenFOAM/OpenFOAM-1.0.2/src/meshTools/lnInclude -fPIC -c .C -o Make/sgiN32GccOpt/readSTLASCII.o
g++: .C: linker input file unused because linking not done

Henry Weller (Henry) February 8, 2005 18:02

It appears that the version o
 
It appears that the version of make you are using cannot handle $*.C. I don't remeber having this problem when I last compiled on IRIX6.5 but it maybe that I was using GNU make which we are using on most platforms due to the very variable behaviour of native make. So I suggest you try using GNU make which may already be on your system but in some contributions or gnu directory as it is supplied as part of the OS or compile it from sources which is very easy.

Manuel Garcia (Garcia) February 8, 2005 20:54

that explains why it was worki
 
that explains why it was working in one machine and not in the other. thanks that was the problem.

The next set of errors were about not finding libPstream.so. The fix we put in was definitely not the 'proper one' but it worked. We changed OpenFOAM/OpenFOAM-1.0.2/wmake/Makefile from

<FONT FACE="Courier New">
$(EXE): $(OBJECTS)
* * $(WM_SCRIPTS)/mkObjectDir $(EXE)
* * $(LINKEXE) $(OBJECTS) -L$(LIB_WM_OPTIONS_DIR) \
* * $(EXE_LIBS) $(PROJECT_LIBS) $(SYS_LIBS) $(LINK_LIBS)
$(GLIBS) -o $(EXE)
</FONT>

to

<FONT FACE="Courier New">
$(EXE): $(OBJECTS)
* * $(WM_SCRIPTS)/mkObjectDir $(EXE)
* * $(LINKEXE) $(OBJECTS) -L$(LIB_WM_OPTIONS_DIR) \
* * <FONT COLOR="ff0000">-L$(FOAM_LIBBIN)/dummy -lPstream \ </FONT>
* * $(EXE_LIBS) $(PROJECT_LIBS) $(SYS_LIBS) $(LINK_LIBS) $(GLIBS) -o $(EXE)
</FONT>

this was the error message

<FONT FACE="Courier New">
g++ -mabi=n32 -mips4 -DsgiN32 -DsgiN32GccOpt -DscalarMachine
-DoptSolvers -Wall -W -Wno-unused-parameter -O3 -ffast-math
-fno-schedule-insns -DNoRepository -ftemplate-depth-30
-I/site/home/fuj
inaga/OpenFOAM/OpenFOAM-1.0.2/src/OpenFOAM/lnInclude -IlnInclude -I.
-DWM_PROJECT_VERSION='"'1.0.2'"'
-I/site/home/fujinaga/OpenFOAM/OpenFOAM-1.0.2/src/cfdTools/
incompressible -I/site/home
/fujinaga/OpenFOAM/OpenFOAM-1.0.2/src/cfdTools/lnInclude -fPIC
-Wl,-LD_LAYOUT:lgot_buffer=100 Make/sgiN32GccOpt/potentialFoam.o
-L/site/home/fujinaga/OpenFOAM/OpenFOAM-1.0.2/lib/sgiN32GccOpt \
-lOpenFOAM -lfpe -lm -o
/site/home/fujinaga/OpenFOAM/OpenFOAM-1.0.2/applications/bin/
sgiN32GccOpt/potentialFoam
ld32: WARNING 129: Cannot find libPstream.so, which is needed for
proper transitive linking.
ld32: ERROR 33 : Unresolved text symbol "Foam::reduce(double&,
Foam::sumOp<double>)" -- 1st referenced by Make/sgiN32GccOpt/potentialFoam.o.
</FONT>

Henry Weller (Henry) February 9, 2005 04:47

This is the problem everyone
 
This is the problem everyone sees when compiling from sources, it's because library directories are made during the building process that need to be added to the LD_LIBRARY_PATH. Simply source your ~/.cshrc or ~/.bashrc file again to update the paths and run Allwmake again and it should all compile.

I have written a work-around for this problem into the build scripts of tyhe next release.

Manuel Garcia (Garcia) February 11, 2005 18:49

I finally finished compiling t
 
I finally finished compiling the whole code on the IRIX6.5. I only got a couple of warnings and the are related with not finding javac. I tried the small test from the README file and it seems to be working. I will recompil from zero next week and write a kind of report to send to the list.

I am also trying to compile paraview. I only got version 1.8.4. Is it version compatible with FOAM?


on the other hand, when I tried to run runFoamX I get this error:

<FONT FACE="Courier New">
Exception in thread "main" java.lang.NoClassDefFoundError: FoamX/App
/home/uofacvs/OpenFOAM/OpenFOAM-1.0.2/applications/utilities/preProcessing/FoamX/bin/runFoamXHB[131]:
199844 Killed</FONT>

could it be associated with the warning about bot foundinf javac at
compilation time?

<FONT FACE="Courier New">
SOURCE_DIR=FoamX SOURCE=FoamX/App.java ; mkdir -p Make/classes ; (
javac -classpath :Make/classes:. -O -d Make/classes -deprecation $SOURCE
|| ( rm -f Make/classes/FoamX/App.class ) )
/bin/sh: javac: not found
</FONT>

we have this installed in our machine:

I java2_dev 07/15/2003 Java2 v1.4.1 Development Environment
(Sun JDK v1.4.1)
I java2_eoe 12/23/2003 Java2 v1.4.1_02 Execution
Environment (Sun JRE v1.4.1_02)
I java2_plugin 07/15/2003 Java2(tm) Plug-in for Irix, v1.4.1


thank you

manuel

Manuel Garcia (Garcia) February 16, 2005 21:54

Hi, I am trying to run the
 
Hi,

I am trying to run the parallel damBreakFine tutorial in the SGI with the native MPI and I get the following error

<FONT FACE="courier">
bash-2.05b$ mpirun -np 4 interFoam . damBreakFine -parallel

/*---------------------------------------------------------------------------*\
| ========= | |
| \ / F ield | OpenFOAM: The Open Source CFD Toolbox |
| \ / O peration | Version: 1.0.2 |
| \ / A nd | Web: http://www.openfoam.org |
| \/ M anipulation | |
\*---------------------------------------------------------------------------*/


Exec : /home/uofacvs/OpenFOAM/OpenFOAM-1.0.2/applications/bin/sgiN32GccOpt/interFoam . damBreakFine -parallel
MPI: vizserver: 0x7dddffff00000d8e:
MPI: vizserver: 0x7dddffff00000d8e:
MPI: vizserver: 0x7dddffff00000d8e: --> FOAM FATAL ERROR : Not implemented
MPI: vizserver: 0x7dddffff00000d8e:
MPI: vizserver: 0x7dddffff00000d8e: Function: Pstream::init(int& argc, char**& argv)
MPI: vizserver: 0x7dddffff00000d8e: in file: Pstream.C at line: 48.
MPI: vizserver: 0x7dddffff00000d8e:
MPI: vizserver: 0x7dddffff00000d8e: FOAM aborting
MPI: vizserver: 0x7dddffff00000d8e:
MPI: could not run executable (all_signal.c:206)
</FONT>

Any idea what is happening?.
I look at the complation of interFOAM and it does not link the mpi library. Maybe libPstream
does?

thanks

Manuel

Mattijs Janssens (Mattijs) February 17, 2005 05:39

You're right, libPstream is t
 
You're right, libPstream is the only one that links/includes anything with mpi. Which version of Pstream to use is determined at load time. Through LD_LIBRARY_PATH OpenFOAM loads libPstream.so (which is a wrapper around mpi) either from .../lib/linuxOpt/dummy or .../lib/linuxOpt/lam-7.1.1

(on linux that is)

It seems you are loading the dummy one? If so check in OpenFOAM-1.0.2/.cshrc to see which $WM_MPLIB you are set up to use and check in .OpenFOAM-1.0.2/cshrc what FOAM_MPI_LIBBIN this causes.

Just set WM_MPLIB to MPI and FOAM_MPI_LIBBIN to $FOAM_LIBBIN/mpi and make sure that Pstream/Allwmake builds a .../mpi/libPstream.so
(from the Pstream/mpi sources but with the correct options for your native mpi)

Mattijs

garcia March 9, 2005 22:43

This is a summary of the sgi c
 
This is a summary of the sgi compilation of OpenFoam. Thanks very much to all that helped.

I haven't compiled paraview yet. I could not get the source of the paraview-1.8.0 version at the paraview web site. Will it work with the paraview 1.8.5 version?

I put the binaries temporarily at
http://www.cs.ualberta.ca/~mgarcia/OpenFoam/sgi-irix/

enjoy

Manuel


-----------------------------------------------
Gnu make

Install gnu make and be sure it runs by default. That is
which make
points to the gnu make

-------------------------------------------------
compile gcc

make sure that gnu make is install in the system


./configure --prefix=$HOME/OpenFOAM/sgiN32/gcc-3.4.3

make

make install

---------------------------------------
source the file
bash ( $HOME/.bashrc)

. $HOME/OpenFOAM/OpenFOAM-1.0.2/.OpenFOAM-1.0.2/bashrc

tcsh ($HOME/.cshrc)

source $HOME/OpenFOAM/OpenFOAM-1.0.2/.OpenFOAM-1.0.2/cshrc

-------------------------------------------------------------------
when compiling libOpenFOAM.so it complains

couldn't load shell: Argument list too long (bu22).
*** Error code 1 (bu21)

It could be that the length of the argument list need to be
by increased by changing the ncargs kernel parameter with the systune command, e.g.

# systune |grep ncargs
ncargs = 20480 (0x5000)
# systune ncargs 0x6000

However, in our case the argument list was big enough. The problem was only present under the bash shell. Use tcsh instead to compile this part.

--------------------------------------------------------------------
Mico: Does not compile under SGI with gcc 3.4.3

The solution we got is not standard and we should report this to the MICO developers for a proper fix. We added:

#include <math.h>
before
#include <mico/os-math.h>
in any.cc, fixed.cc, os-unix.cc, util.cc in
OpenFOAM-1.0.2/src/mico-2.3.11/orb


cd $MICO_PATH
gmake distclean
./configure --prefix=$MICO_ARCH_PATH --disable-shared --without-x
gmake
gmake install
gmake distclean

-----------------------------------------------------------------------------
OSspecific/Unix/sigfpe.C:111: error: expected `)' before numeric constant

It was indeed a bug. In OpenFOAM-1.0.2/src/OpenFOAM/OSspecific/Unix/sigfpe.C,


handle_sigfpes
(
_ON,
_EN_DIVZERO
| _EN_INVALID
| _EN_OVERFL
0,
_ABORT_ON_ERROR,
0
);

should be

handle_sigfpes
(
_ON,
_EN_DIVZERO
| _EN_INVALID
| _EN_OVERFL,
0,
_ABORT_ON_ERROR,
0
);

(comma at '| _EN_OVERFL,')
-----------------------------------------------------------------------------
ld32: WARNING 129: Cannot find libPstream.so

The fix we put in was definitely not the 'proper one' but it worked. We changed OpenFOAM/OpenFOAM-1.0.2/wmake/Makefile from

$(EXE): $(OBJECTS)
$(WM_SCRIPTS)/mkObjectDir $(EXE)
$(LINKEXE) $(OBJECTS) -L$(LIB_WM_OPTIONS_DIR) \
$(EXE_LIBS) $(PROJECT_LIBS) $(SYS_LIBS) $(LINK_LIBS)
$(GLIBS) -o $(EXE)


to


$(EXE): $(OBJECTS)
$(WM_SCRIPTS)/mkObjectDir $(EXE)
$(LINKEXE) $(OBJECTS) -L$(LIB_WM_OPTIONS_DIR) \
-L$(FOAM_LIBBIN)/dummy -lPstream \
$(EXE_LIBS) $(PROJECT_LIBS) $(SYS_LIBS) $(LINK_LIBS) $(GLIBS) -o $(EXE)

Henry Weller solution:

Henry Weller (Henry) on Wednesday, February 09, 2005 - 09:47 am: Edit Post

This is the problem everyone sees when compiling from sources, it's because library directories are made during the building process that need to be added to the LD_LIBRARY_PATH. Simply source your ~/.cshrc or ~/.bashrc file again to update the paths and run Allwmake again and it should all compile.

manuel: I haven't tried this yet.
-----------------------------------------------------------------------------

libPstream not properly linked with mpi

at file OpenFOAM-1.0.2/.bashrc line 216 include:


elif [ .$WM_MPLIB = .MPI ]; then
export FOAM_MPI_LIBBIN=$FOAM_LIBBIN/mpi


and in OpenFOAM-1.0.2/.cshrc line 230 include:


else if ($WM_MPLIB == MPI) then

setenv FOAM_MPI_LIBBIN ${FOAM_LIBBIN
/mpi
}
-----------------------------------------------------------------------------
Linking with std library
ld32: ERROR 33 : Unresolved text symbol
"std::__default_alloc_template<true,>::deallocate( void*, unsigned int)" -- 1st referenced by OpenFOAM/OpenFOAM-1.0.2/src/mico-2.3.11/platforms/sgiN32GccOpt/lib/libmicocoss2. 3.11.a(CosNaming.o).

Solution:

line 239 of OpenFOAM-1.0.2/.OpenFOAM-1.0.2/bashrc after the line


#- Clean LD_LIBRARY_PATH
export LD_LIBRARY_PATH=`$cleanProg "$LD_LIBRARY_PATH"`


add :


if [ "$machinetest"="IRIX64" ]; then
export LD_LIBRARYN32_PATH=$LD_LIBRARY_PATH
fi


However, under the tcsh shell It is not necessary to set up
the LD_LIBRARYN32_PATH. It just work without it.


-----------------------------------------------------------------------------
Java:
Ask your system manager to install the full Java set:

Java2 v1.4.1_06 Debug Binaries
Java2 v1.4.1_06 Development Environment
Java2 v1.4.1_06 Execution Environment
Java2(tm) Plug-in for Irix, v1.4.1_06

then change at OpenFOAM-1.0.2/.bashrc line 130


export JAVA_HOME=$WM_PROJECT_INST_DIR/$WM_ARCH/j2re1.4.1

by

export JAVA_HOME=/usr/java2
-----------------------------------------------------------------------------
Finally, use foamPackBin which will pack all the sgi libraries and executable files:

foamPackBin sgiN32GccOpt


-----------------------------------------------------------------------------

garcia May 25, 2005 19:22

Hi there I'm now compiling
 
Hi there

I'm now compiling version 1.1 of OpenFOAM on the SGI IRIX64 and I'm getting the following error:

Making dependency list for source file PatchTool.C
lib
SOURCE_DIR=.
SOURCE=PatchTool.C ; g++ -mabi=n32 -mips4 -DsgiN32 -Wall -W -Wno-unused-parameter -O3 -ffast-math -fno-schedule-insns
-DNoRepository -ftemplate-depth-30 -I/home/uofacvs/OpenFOAM/OpenFOAM-1.1/src/OpenFOAM/lnInclude -IlnInclude -I.
-fPIC -c $SOURCE -o Make/sgiN32GccOpt/PatchTool.o
In file included from PatchTool.C:8:
PatchTool.H:8:19: CORBA.h: No such file or directory
PatchTool.H:9:24: mico/throw.h: No such file or directory
In file included from PatchTool.C:8:
PatchTool.H:27: error: expected init-declarator before '<' token
PatchTool.H:27: error: expected `,' or `;' before '<' token
PatchTool.H:28: error: expected init-declarator before '<' token
PatchTool.H:28: error: expected `,' or `;' before '<' token
PatchTool.H:67: error: `CORBA' has not been declared
PatchTool.H:67: error: expected init-declarator before "_tc_FoamXType"
PatchTool.H:67: error: expected `,' or `;' before "_tc_FoamXType"
PatchTool.H:83: error: `CORBA' has not been declared
...

looks like the wmake is not getting the right values for mico path...

thanks

Manuel

hjasak May 26, 2005 14:34

Yup, missing mico. Have a look
 
Yup, missing mico. Have a look at

OpenFOAM-1.1/applications/utilities/mesh/manipulation/patchTool/C++/FoamXServer/ Make

file: orbOptions

It should say things like

ORB_INC = \
-I$(MICO_ARCH_PATH)/include \
$(ORB_SYS_INC)

ORB_LIBS = \
-L$(MICO_ARCH_PATH)/lib \
-lmicocoss$(MICO_VERSION) \
-lmico$(MICO_VERSION) \
$(ORB_SYS_LIB)

Check if $MICO_ARCH_PATH is set:

echo $MICO_ARCH_PATH

For me, there's an entry in the compile line saying:

-I/home/coyote/hjasak/OpenFOAM/OpenFOAM-1.1/src/mico-2.3.11/platforms/linuxDebug /include

and that's where the files come from. Have a look and see if they are present; if not, rebuild mico.

Have fun,

Hrv


All times are GMT -4. The time now is 14:06.