CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM Installation (
-   -   Paraview installation troubles (

jjhall March 4, 2008 10:45

Hello, I am new to OpenFOAM an
Hello, I am new to OpenFOAM and I am having difficulty getting paraview to work. I have managed to get the OpenFoam binaries installed by following the installation directions, but paraview does not work.

Background on my machine/OS:

> uname -a
Linux xxxxxxx 2.6.22-14-generic #1 SMP Tue Feb 12 02:46:46 UTC 2008 x86_64 GNU/Linux

OS: Ubuntu 7.10 64-bit
Processor: AMD Athlon64 3500

First, I intalled the paraview binary according to the instructions. When I ran paraview, I got:

/home/jjhall/OpenFOAM/linux64/paraview-2.4.4/lib/paraview-2.4/paraview-real: error while loading shared libraries: cannot open shared object file: No such file or directory

I tried "ldd paraview" and got => /lib/ (0x00002b4cfbaac000)
/lib64/ (0x00002b4cfb88e000)

Now, I'm not 100% clear on the meaning of this, but I thought that if ldd returned no errors or missing files, then you were OK. Anyway, I started looking for a way to fix it, so I decided to install a new version of paraview. I went to the paraview website and downloaded the newest binary (3.2.1). This runs fine, but there seems to be no reader for OpenFOAM, and I've read in other threads that paraFoam needs paraview 2.4.x to run. So, I found a post by Philippose Rajan where he gave a link to downloads of 2.4.4. I downloaded the binary paraview-2.4.4.bin.tgz and unpacked it, and the executable runs but gives an error:

ERROR: In /home/hjasak/OpenFOAM/linuxSrc/paraview-2.4.4/Utilities/VTKClientServer/vtkClien tServerInterpreter.cxx, line 886
vtkClientServerInterpreter (0x80662a8): /home/jjhall/OpenFOAM/OpenFOAM-1.4.1/lib/linux64GccDPOpt/ wrong ELF class: ELFCLASS64

ERROR: In /home/hjasak/OpenFOAM/linuxSrc/paraview-2.4.4/GUI/Client/vtkPVXMLPackageParser.c xx, line 678
vtkPVXMLPackageParser (0x899ebc8): Error loading Library component PVFoamReader

ErrorMessage end

I figured this meant that I would need to recompile, so I downloaded paraview-2.4.4.tar.gz and tried to compile with cmake. However, it asks for the location of OPENGL_INCLUDE_DIR and OPENGL_gl_LIBRARY and gives an error.

Does anybody have any suggestions for a method to get paraFoam/paraview working? I am not new to Linux, but my experience is mostly as a user, and I always seem to run into these type of problems whenever I try to install something. However, I'd really like to get OpenFOAM going.

Thanks for any help you can give.


msrinath80 March 4, 2008 16:10

You need to install tcl/tk lib
You need to install tcl/tk libs. That's all.

jjhall March 4, 2008 21:58

Thanks for the reply. I intal
Thanks for the reply. I intalled the libs via the Synaptic Package Manager in Ubuntu. This put the files and in /usr/lib64/. However, paraview still didn't work, and I realized that if I ran

> ldd /home/jjhall/OpenFOAM/linux64/paraview-2.4.4/lib/paraview-2.4/paraview-real

I got a long list of libs that weren't found, including ones that were in the same directory as paraview-real. So first I added /usr/lib64 to the environment variable LD_LIBRARY_PATH, and then I created links from to, and also for Next I edited the $WM_PROJECT_DIR/.OpenFOAM-1.4.1/apps/paraview/cshrc file so that ${ParaView_INST_DIR}/lib/paraview-2.4 was also in $LD_LIBRARY_PATH. Now when I run ldd, it finds everything, and paraview runs! paraFoam runs too!

I will need to check it further to make sure everything is working, but I think this problem is fixed.

zaleksf April 17, 2008 12:59

Thanks for your post Jeremiah.
Thanks for your post Jeremiah. I have a virtually identical set-up (machine/OS) and issues with paraview. I do have the tcl8.4 files installed, so no problem there. I am also a relative newbie to Ubuntu/Linux. Would you be able to articulate the details of how you performed your fixes? Specifically how you:

1) So first I added /usr/lib64 to the environment variable LD_LIBRARY_PATH,
2) and then I created links from to, and also for
3) Next I edited the $WM_PROJECT_DIR/.OpenFOAM-1.4.1/apps/paraview/cshrc file so that ${ParaView_INST_DIR}/lib/paraview-2.4 was also in $LD_LIBRARY_PATH.

Many thanks.

All times are GMT -4. The time now is 16:48.