CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM Installation (
-   -   LibPstreamso (

mark March 25, 2008 07:55

I've tried to install OpenFOAM
I've tried to install OpenFOAM on Redhat EL 4/5. I always get the error message: error while loading shared libraries: cannot open shared object file or directory runFoamXHB : cleanup runFoamXHB: Name server is not running

Any idea what is going on?


young March 25, 2008 08:19

maybe there is no libPstream.s
maybe there is no in the folder -/usr/lib,please check it out ;if so ,you can download this file online,"***.rpm",double-click,it will setup !

mark March 25, 2008 08:50

I installed the xorg-x11-depre
I installed the xorg-x11-deprecated-libs-6.8.2-1.EL.31.i386.rpm
It was described in " library missing" bug report within this side. After I've don this I got the following message when I try to start FoamX:
uncaught MICO exception: IDL: (0,not-completed)
~/OpenFOAM/Source_pack/OpenFOAM-1.4.1/bin/runFOAMXHB: line 145: 6517 aborted
$nsd -ORBITOPAddr $myIOP --ior $FOAMX_CONFIG/ns.ref </dev/ null

And now?

maruzews March 27, 2008 13:16

Dear OpenFOAM users and helper
Dear OpenFOAM users and helpers,

I downloaded the current release 1.4.1
I use openSUSE 10.2 (X86-64)
I downloaded all things as mentioned into wiki pages.
I compiled and some as libPstream under FOAM_LIBBIN/dummy were created.
When the compilation step went on until applications/solvers/compressible/rhoSimpleFoam, for example, it stopped. I had on Make/option the following
-L$(FOAM_LIBBIN)/dummy -lPstream -foamUser -lz \
-ltriSurface \
-lfiniteVolume \
-llagrangian \
So it built OpenFOAM/OpenFOAM-1.4.1/applications/bin/linux64GccDPOpt/rhoSimpleFoam
I ran rhoSimpleFoam
and poor myself
I received the following message :
OpenFOAM/OpenFOAM-1.4.1/applications/bin/linux64GccDPOpt/rhoSimpleFoam: error while loading shared libraries: cannot open shared object file: No such file or directory


Thanks a lot


olesen March 27, 2008 13:34

In my Make/options I have
In my Make/options I have

-I$(LIB_SRC)/finiteVolume/cfdTools \
-I$(LIB_SRC)/finiteVolume/lnInclude \
-I$(LIB_SRC)/thermophysicalModels/basic/lnInclude \

-lfiniteVolume \
-lmeshTools \
-lbasicThermophysicalModels \
-lspecie \

And it compiles (and runs) without complaints.
Check that the libPstream was actually built.
I have both
under my $FOAM_LIBBIN, but the openmpi one is the one that is referenced by

"ldd -v" should show you what is and is not being found.

All times are GMT -4. The time now is 15:42.