CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM Installation (
-   -   Gcc conflict install (

inddzen December 10, 2007 08:37

Hi all, When installing for
Hi all,

When installing for the first time OpenFoam, I choosed to use my own Gcc-4.1.2 on Fedora 8.

Everything was fine (I was able to run my applications) a part from running FoamX.
I decided then to use the gcc-4.2.1 provided with OF but I got a critical error while running foamInstallationTest :

gcc 4.2.1
WARNING Conflicting Installations
foam setting : /home/lhassa/OpenFoam/linux64/gcc-4.2.1/bin/gcc
current path : /usr/bin/gcc

Yes my $WM_64=on...
Does anyone know how to fix this problem????

philippose December 10, 2007 14:34

Hello, Good evening! Cou

Good evening!

Couple of suggestions...

Is that the only error you are getting when you run "foamInstallationTest" ? or are there any more errors before this?

If that was the only error... I know this is trivial... but I hope you have a folder called "gcc-4.2.1" in your "/home/<user>/OpenFOAM/linux64" folder, and that the "gcc" file exists in the path as shown in the output of "foamInstallationTest".

The other possibility is... you need to have added "export WM_64=on" in your ".bashrc" file BEFORE you source the OpenFOAM bashrc file.

Yet another possibility.... check to see if you have a "Path" setting in you ".bashrc" file at a point after your source the OpenFOAM bashrc file, which places "/usr/bin" in front of the OpenFOAM paths.

Hmmm... I think that about covers most of the common problems one would expect to come across for the issue you are facing :-)!

Hope this helps!



inddzen December 11, 2007 17:00

Hi, Thanks for you answer..

Thanks for you answer...

It working but the way I fixed it is really weird : I reinstalled OF and Foam is working even if it's giving the conflict message for gcc!!!!

Well, hope that it'll not cause any surprises in the future.

All times are GMT -4. The time now is 18:20.