CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM Installation (
-   -   Problems in Compiling OpenFOAM in IRIX (

lakeat June 7, 2007 21:44

Hi, I met three problems in
I met three problems in building OpenFOAM in IRIX.
1. When I try to run wcleanAll, after "Cleaning bed2 case of twoPhaseEulerFoam application", it gave a message of "..../wcleanAll[57]: /sbin/find: arg list too long" and stopped, therefore I wonder whether it is successfully and entirely wcleaned? And what can I do?
2. When I run ./Allwmake, I was told "could not find open file SubList.H for source file db/regIOobject/regIOobject.C" and then "could not find open file SubListI.H for source file db/regIOobject/regIOobject.C" and so on, yet I examined in src/OpenFOAM/lnInclude, the link of SubList.H and SubListI.H is valid, that's very strange.
Any help would be very appreciated.
my machinTest is IRIX64 (I know I have to modify wmake/rules/sgiN32Gcc4/***, but not sure how to do it faultlessly);
WM_COMPILER is Gcc4 (so far, I'm still not convinced whether my "GCC Installation" can be called successfully);
SHELL is csh (Why it is kshScript in wmake directory, not cshScript?).

Best Regards,

All times are GMT -4. The time now is 16:16.