CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM Installation (
-   -   FoamX problem with Brooksb Cygwin port (

irc May 18, 2006 18:25

I have just installed Brooks M
I have just installed Brooks Moses' cygwin port of OpenFOAM 1.3 on a WinXP P4 system (excellent work Brooks et al!). All seemed okay - ran the icoFoam tutorial, as per the installation README.

However, I hit trouble when following the first tutorial in the UserGuide, which calls on FoamX - the system complained that it couldn't find JDK. I tried downloading and installing J2SDK1.4.2_11, and set $JAVA_PATH. This then led to the following output on running FoamX:

ps: user -o unknown
ps: user -o unknown
ps: user -o unknown
ps: user -o unknown
ps: user -o unknown
Starting NameServer with inet:Dell:1234 ...
/home/Ian/OpenFOAM/OpenFOAM-1.3/bin/runFoamXHB: line 122: nsd: command not found

... and then the system hung. Am I missing something (eg nsd?) in my cygwin installation?

gschaider May 19, 2006 04:56

I havn't been reading the READ
I havn't been reading the READMEs of the Cygwin, but there are rumors that somewhere in there it says that FoamX isn't supported on Cygwin. (Petr refered me to the thread and mumbled "I think Brooks doesn't write these things for his own amusement")

irc May 19, 2006 15:47

You're absolutely right - it's
You're absolutely right - it's there in black and white: "These are not quite complete ports; we haven't yet tried to port FoamX or ParaFoam/ParaView". Apologies!

mmoyer777 February 20, 2007 19:46

Has anyone resloved the ParaFo
Has anyone resloved the ParaFoam/ParaView issue? FoamX and ParaView 2.6 seem to work fine on my cygwin install. However, the mess in the first tutorial can't be displayed in ParaView. Any suggestions?

All times are GMT -4. The time now is 20:52.