CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM Installation (
-   -   Canbt fix libelfso0 proble (

clo January 9, 2007 12:42

Hello I can't really go throug
Hello I can't really go through FoamX to work: here there is the error:

nsd: error while loading shared libraries: cannot open shared object file: No such file or directory

I know it is a known error but after trying to fix it with other posts solutions I quit beacuse nothing worked

I'm using suse 10 with OFoam 1.3; P4 1G ram
Anybody has fixed it on Suse?

thany ciao

holgerblasum January 9, 2007 13:43

Hi clo, although I am debia
Hi clo,

although I am debian myself I'd guess
does the job for you.

Download libelf-0.8.5-45.i586.rpm
then run (as root) rpm -i libelf-0.8.5-45.i586.rpm

I have checked that it contains a /usr/lib/ In case you already have that file and the problem persists, run "ldconfig" (as root). If the problem still persists, please post the error message and the output of "ls -la /usr/lib/*".

HTH, Holger

clo January 9, 2007 14:05

Hi Holger, thank you for the h
Hi Holger, thank you for the hints! unfortunatly I can't try now but I will as soon as I can!I will post the results!
thanx ciao

clo January 10, 2007 05:17

Hi Holger, actually a simple i
Hi Holger, actually a simple installation of lielf via yast solved the problem...mhm...i feel stupid but I remember that I looked inside /usr/lib and was there! That's way I tried to do links and other stuff to make it work! I any case the problem is solved and what can I say...thanx!

All times are GMT -4. The time now is 08:04.