CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM Installation (
-   -   Trouble running wmakewrong include paths (

philippose October 13, 2006 11:12

Hello, I have OpenFoam 1.3
I have OpenFoam 1.3 running on a Fedora Core 5 machine. The system works fine, with all solvers and utilities functioning perfectly.

Recently I downloaded a stripped down solver called "steadyFlow", which is basically a simplified version of "simpleFoam".

I extracted the solver directory into the OpenFoam-1.3/solvers/incompressible folder, and ran "wmake", but it aborted with a notification of missing header files "fvCFD.H", etc...

On looking deeper, I found that the Makefile in wmake sets the include directory $LIB_SRC to "$PROJECT_DIR/src".

In the "options" file in the steadyFlow solver directory (and for that matter, in all other solvers which I checked later)... has:

-I$(LIB_SRC)/cfdTools/incompressible \

But the directory "cfdTools" is not in the root directory of "$LIB_SRC", but under a subdirectory called "finiteVolume".

When I changed the path in the "options" file, I got errors when the compiler tried to include files required by "fvCFD.H"... such as fvMesh.H, etc...

Could someone give me guidelines on how I could circumvent this problem? I am not conversant with the source structure of OpenFoam, and changing paths only led to other header files not being found.

(I tried compiling some of the already existing solvers, but they all gave the same error)

Thank you!


philippose October 13, 2006 12:50

Hello again, Sorry.... I fo
Hello again,
Sorry.... I found the the solution to the problem in the OpenFoam ver. 1.3 release notes.

I had to change the "options" file because there was a reorganization of the code structure between OpenFoam 1.2 and 1.3.

Things are working now!


All times are GMT -4. The time now is 23:37.