CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM Installation (
-   -   Trouble unpacking files (

andrewlindsay October 7, 2006 18:42

Hello, To start with, I do

To start with, I do not have a really great understanding of Linux.

I have tried to follow the instructions in the read me's and FAQs, but I am having a problem with installing the software.

When I try unpacking the general tar, I get the following.

>tar -xzf ../OpenFOAM-1.3.General.gtgz

gzip: stdin: unexpected end of file
tar: Unexpected EOF in archive
tar: Unexpected EOF in archive
tar: Error is not recoverable: exiting now

I have downloaded the TAR a couple of times, and each time I get the same result.

Any assistance would be appreciated.


Andrew Lindsay

hartinger October 8, 2006 10:34

the "minus" in "tar -xzf .."
the "minus" in "tar -xzf .." is wrong
try "tar xzf OpenFOAM-1.3.General.gtgz"


msrinath80 October 9, 2006 01:57

Unpack the file from the same
Unpack the file from the same directory. The ../OpenFOAM-1.3.General.gtgz is messing stuff for you. Put OpenFOAM-1.3.General.gtgz in the directory where you want to unpack it and then do a tar -xzf OpenFOAM-1.3.General.gtgz.

I think the minus sign is not a problem.

mattijs October 9, 2006 03:52

Probably your file has been co
Probably your file has been corrupted while downloading. Is the file size correct? Check your file:

file OpenFOAM-1.3.General.gtgz

gives for me

gzip compressed data, from Unix

Then rename it so gunzip recognizes it

mv OpenFOAM-1.3.General.gtgz OpenFOAM-1.3.General.tar.gz

and run gunzip on it:

gunzip OpenFOAM-1.3.General.tar.gz

This should create a file without the .tar. Finally run 'tar' on it:

tar xf OpenFOAM-1.3.General.tar

andrewlindsay October 9, 2006 06:11

Cheers for the help. I now ha
Cheers for the help.
I now have the system up and running I think.

Now, where do I go to get help with actually setting up and running a problem?



amagda October 9, 2006 14:43

Hi, You have nice tutori

You have nice tutorials at the OpenFOAM webpage:

I wrote also one but is not so good as the first two ...


All times are GMT -4. The time now is 14:22.