CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM Installation (
-   -   Ssh problem for LAMMPI (

parallelauvi April 11, 2006 13:13

Hi, I have run the damBreakFi
I have run the damBreakFine case of the supplied tutorials but when i try to run it parallelly i get ERRORs ..
i have setup the other machine(for a 2 pc LAN) for ssh (using ssh-keygen and stuff) which requires no passwords when i login using the ssh client. i can run regular programs like "ls" like this:
"ssh foam19 ls" normally
and can't run like this:
"ssh foam19 tkill"

but when i login using ssh to foam19 i can invoke "tkill" and related LAM-MPI commands. the path for LAM-MPI is in the .bashrc file.

foam19 is the other machine.

Any help?



mattijs April 11, 2006 13:46

Not familiar with .bashrc but
Not familiar with .bashrc but maybe just 'ssh' executes different different start-up files ( ~/.bash.login etc.)

ssh starts up 'login shell' according to the man page.

If you're really stuck add a 'set -x' to your dot files and work through the mass of output.

parallelauvi April 12, 2006 01:14

okay i solved the problem by e
okay i solved the problem by editing the global
/etc/bash.bashrc file adding the
. ($HOME ... ) line to the top
now the "ssh foam19 tkill" works
and lamboot -v <machines> runs without any errors

thanks Mattijis Jenssens


parallelauvi April 12, 2006 01:28

sorry for the typo Thanks Ma
sorry for the typo
Thanks Mattijs Janssens
i was in a hurry.


All times are GMT -4. The time now is 00:17.