CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM Installation (
-   -   Installation errors (

henkw December 8, 2005 05:48

Hi, I am still getting erro

I am still getting errors with the foamInstallationTest:

gcc 3.4.3
WARNING: Conflicting installations:
foam settings: /home/OpenFOAM/OpenFOAM//gcc-4.0.1/bin/gcc
current path : /usr/local/bin/gcc

java *** not installed ***

gzip 1.3.3 /bin/gzip
tar 1.3.3 /bin/tar
icoFoam *** not installed ***

Searching the forum I believe gcc 3.4.3 should be the correct version. I tried several gcc releases, including 4.0.1, but all generate the critical error.

With respect to the paths, should it be:




I tried both, and both versions give the error but I am not sure what the correct installation tree is (on the download page it states that gcc and java need to be put in a linux subdirectory of the OpenFoam tree, but given the errors above and the fact that java is not picked up either I am confused).

Also, icoFoam is not picked up.

Help please?

Henk Witte

mattijs December 8, 2005 15:35

I have: /home/pinky2/mattij
I have:


/home/pinky2/mattijs is my home directory.

Check what the `uname -s` (and `uname -m`) in .OpenFOAM-1.2/bashrc returns - it is quite strange that your path does not include 'linux'

I have:

uname -s:

uname -m

henkw December 8, 2005 16:53

Ok, I decided to start over

I decided to start over, and to make sure that all was well I started with a fresh linux (RH 9) installation. It Works!

(why it didn't first??)


All times are GMT -4. The time now is 15:35.