CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM Installation (
-   -   Problem wih Compiling under Tru64 foamFlex (

matthias November 30, 2005 21:17

Hi, i try to compile OpenFo

i try to compile OpenFoam under Tru64 and get the following problem:

I added a decAlpha rule file into the rules directory, the one which you can get in this forum.
After modifying the cshrc and .cshrc with the OSF1 variable, i run Allwmake.

I selected the LAM as my favourite MPI.

Now after few compiler steps, i get an error like this:

SOURCE=triSurface/interfaces/STL/readSTLASCII.L ; foamFlex++ -f $SOURCE ; mv Make/decAlphaGccOpt/readSTLASCII.C ; g++ -DFOAM_EXCEPTION -DLITTLE_ENDIAN -DdecAlpha -DdecAlphaGccOpt -DscalarMachine -DoptSolvers -Wall -O2 -fno-schedule-insns -DNoRepository -ftemplate-depth-30 -I/usr/user4/foam/OpenFOAM/OpenFOAM-1.2/src/meshTools/lnInclude -I/usr/user4/foam/OpenFOAM/OpenFOAM-1.2/src/OpenFOAM/lnInclude -IlnInclude -I. -I/usr/user4/foam/OpenFOAM/OpenFOAM-1.2/src/lam-7.1.1/platforms/decAlphaGccOpt/i nclude -fPIC -c Make/decAlphaGccOpt/readSTLASCII.C -o Make/decAlphaGccOpt/readSTLASCII.o
336806:/usr/user4/foam/OpenFOAM/OpenFOAM-1.2/applications/bin/decAlphaGccOpt/foa mFlex++: /sbin/loader: Error: symbol "_ZN4Foam7Pstream8msgType_E" unresolved
336806:/usr/user4/foam/OpenFOAM/OpenFOAM-1.2/applications/bin/decAlphaGccOpt/foa mFlex++: /sbin/loader: Fatal Error: Load of "/usr/user4/foam/OpenFOAM/OpenFOAM-1.2/applications/bin/decAlphaGccOpt/foamFlex+ +" failed: Unresolved symbol name
mv: (null)
g++: Make/decAlphaGccOpt/readSTLASCII.C: No such file or directory
g++: no input files
make: *** [Make/decAlphaGccOpt/readSTLASCII.o] Error 1

The compiler goes on, but serveral errors occured during the compilation

can't locate
can't locate

and so on. Over a half of the libraries are missing after that.

Any ideas?


mattijs December 1, 2005 05:25

foamFlex never got built prope
foamFlex never got built properly. Got to $FOAM_UTIL/miscellaneous/foamFlex and type

wmake exe

and see why it does not build

matthias December 1, 2005 06:36

I solved the problem by removi
I solved the problem by removing the -lPStream option in the rule file of c++ when build foamFlex++ and then i added it again. Now it compiles without any errors.

All times are GMT -4. The time now is 17:27.