CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM Installation (
-   -   Help with new installation on AMD linux 64 bit (

mattijs September 28, 2005 11:07

- do export WM_64=1
- do

export WM_64=1

before '. .bashrc' if you want the 64bit version.

- check that you have the 64bit gcc and java and paraview etc. in the linuxAMD64 directory

- check that your PATH include these directories.

frank178 September 28, 2005 11:28

Hello Nikos, 1. "FATAL ERRO
Hello Nikos,

1. "FATAL ERROR: /home/guest/.OpenFOAM-1.1/bashrc does not appear to be sourced from:
-> change in the foamInstallationTest skript the directory path to .OpenFOAM-1.2

2. the other errors - i had to compile from source but take care to use the same java and gcc version

rapaneli September 28, 2005 12:17

hi again and thank you for you
hi again and thank you for your quick reply

dear Mattijs

{- check that you have the 64bit gcc and java and paraview etc. in the linuxAMD64 directory}

do you mean that i have to put this directories in a folder called /home/guest/OpenFOAM/linuxAMD64 and not in the /home/rapaneli/OpenFOAM/platform/ folder i have them now?

{- check that your PATH include these directories.}
i am sorry but i do not understand the meaning of you mean adding the path of this directory in /home/guest/.bashrc ?

dear Frank
1.did it it now finds only the errors
2.i have gcc-4.0.1-4.fc4.rpm installed is it the same as compiling gcc?
i did not understand what you mean by use the same version of gcc and java ....

mattijs September 28, 2005 13:48

? /home/rapaneli/OpenFOAM/plat
? /home/rapaneli/OpenFOAM/platform

You mentioned /home/guest before so I used that.

Forget what I said. Do exactly what the installation instructions say so get all the software in the correct place. Get someone with Unix experience to give you a hand.

maka September 28, 2005 15:25

Hi Nikos, what is meant by
Hi Nikos,

what is meant by plateform directory is:
"linux" for 32 bit
"linuxAMD64" for 64 bit

- make a directory named OpenFOAM in your user folder.
- make another directory inside the later and name it, in 64 bit case, linuxAMD64,
- copy the following to OpenFOAM:
Source pack OpenFOAM-1.2.General.gtgz
binary pack OpenFOAM-1.2.linuxAMD64Gcc4Opt.gtgz
- unpack with tar xzf
- copy the rest of the files to linuxAMD64
- unpack with tar xzf
- modify .bashrc
- use the following command: export WM_64="on"
- you may check you environment vars by:
- source from a 64 bit processor since processor type is automatically detected.

Good luck!
feel free to tell if you had more problems.

best regards,

rapaneli September 29, 2005 12:59

thank you all for helping me w
thank you all for helping me with the installation

I did the FOAMInstalllationTEst with no eror
i did the tutorial example from the README file
but i wonder ... where is the gui?

i do not know where to if somemody can give me a good starting point for learning CFD it would be a great help.
What i want to do is to make an exersise about the aerodynamic analysis of the front windshield of a car.
My teacher told me to use other commercial products like tecplot and gridgen but i want my paper to be open-source so i wonder if OpenFOAM is the right tool for the job.

rapaneli September 29, 2005 15:39

ok i figured that i need FoamX
ok i figured that i need FoamX coomand in order to have the GUI running but i have an error

[rapaneli@localhost ~]$ export WM_64="on"
[rapaneli@localhost ~]$ FoamX
Starting NameServer with inet:localhost.localdomain:1234 ...
Starting FoamX Host Browser with inet:localhost.localdomain:1234 ...
| ========= | |
| \ / F ield | OpenFOAM: The Open Source CFD Toolbox |
| \ / O peration | Version: 1.2 |
| \ / A nd | Web: |
| \/ M anipulation | |

Exec : FoamXHostBrowser
Date : Sep 29 2005
Time : 22:32:12
Host : localhost.localdomain
PID : 25624
Root :
Case :
Nprocs : 1
HostBrowser running.....
Using jar /home/rapaneli/OpenFOAM/OpenFOAM-1.2/applications/utilities/preProcessing/FoamX/ lib/FoamX.jar
Using jar /home/rapaneli/OpenFOAM/OpenFOAM-1.2/applications/utilities/preProcessing/FoamX/ lib/jlfgr-1_0.jar
Exception in thread "main" java.lang.UnsatisfiedLinkError: /home/rapaneli/OpenFOAM/linuxAMD64/j2sdk1.4.2_05/jre/lib/i386/ cannot open shared object file: No such file or directory
at java.lang.ClassLoader$NativeLibrary.load(Native Method)
at java.lang.ClassLoader.loadLibrary0(ClassLoader.jav a:1586)
at java.lang.ClassLoader.loadLibrary( :1503)
at java.lang.Runtime.loadLibrary0(
at java.lang.System.loadLibrary(
at Method)
at sun.awt.NativeLibLoader.loadLibraries(NativeLibLoa
at sun.awt.DebugHelper.<clinit>(
at java.awt.Component.<clinit>(
/home/rapaneli/OpenFOAM/OpenFOAM-1.2/bin/runFoamXHB: line 131: 25624 died FoamXHostBrowser -ORBNamingAddr $myIOP
runFoamXHB : cleanup
runFoamXHB: Killing name server nsd(pid 25622).
/home/rapaneli/OpenFOAM/OpenFOAM-1.2/bin/runFoamXHB: line 66: 25622 died nsd -ORBIIOPAddr $myIOP --ior $FOAMX_CONFIG/ns.ref </dev/null

rapaneli September 29, 2005 15:53

OK solved sorry for the flood
OK solved sorry for the flood ppl

for fedora core 4 users you need to install xorg-deprecated-libs, just do
yum install

i now have GUI...

All times are GMT -4. The time now is 00:18.