CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM Installation (
-   -   I can not find %24HOMEbashrc file (

ztdep July 12, 2005 03:13

according the openfoam readme
according the openfoam readme ,i will add a line at the end of $HOME/.bashrc file,but i can not find the $HOME/.bashrc file file .!
please help me

alberto July 12, 2005 04:30

What operating system are you
What operating system are you using?

P.S. Please don't split the same discussion in a lot of threads, just use the same :-)


didomenico July 12, 2005 04:42

check with echo $SHELL i
check with

echo $SHELL

if you are using a bash-like shell. If the output is
something like


then it means you are working with a bash shell but you don't have any personal setting (no ~/.bashrc).
In this case create the file

touch ~/.bashrc

and go further....

ztdep July 13, 2005 09:06

thank you very much
thank you very much

regi August 17, 2005 03:45

Hello ! Trying to install Ope
Hello !
Trying to install OpenFoam on my PC with Suse 9.3
I have similar problems, the output of
echo $SHELL is /bin/bash . Meanwhile I have .bashrc on /home/my_name .
It seems that it is not taking into account. When I run /home/my_name/.bashrc (w/ $HOME/OpenFOAM ... /bashrc) I get no error message but environmental variables are not updated. For exemple :
>$WM_PROJECT_INST_DIR/ [TAB] makes >//
Also foamInstallationtest tells me that no Environment Variables are set.
Why ? Any idea ?

eugene August 17, 2005 06:38

Try to source the OpenFoam-1.1
Try to source the OpenFoam-1.1/.OpenFoam-1.1/bashrc manually and post the output of foamInstallationTest.

regi August 18, 2005 03:38

Hi ! Thanks a lot, Manual so
Hi !
Thanks a lot,
Manual source has worked OK, also put "source" instead of "." in .bashrc.
After that I have hade some others problems that were mentioned here summarizing:
a)I've up-dated my etc/hosts to contain the last host name attributed (dynamic IP)'
b) I've changed FoamXClient.cfg variable to point to "localhost"
c) Because I already have paraview on my PC I changed paraFoam paraview line to /usr/local/paraview...
foamInstallationtest feedback was OK ! no critical or fatal error.
I've follwed-up:
blockmesh cavity has worked ok but not paraFoam...
... and that is my new problem :
regi@8R0090J:~/OpenFOAM/regi-1.1/run/tutorials/icoFoam> paraFoam . cavity
# Error or warning: There was a VTK Error in file: /home/amy/ParaViewReleaseRoot/paraview-2.2.1/GUI/Widgets/vtkKWApplication.cxx (1300)

Returned Error on line 5:
Object named: vtkTemp2, could not find requested method: GetAnimationInterface
or the method was called with incorrect arguments.
ErrorMessage end

Didn't work with paraview I have tried OpenDX (also installed at usr/local version 4.36)

regi@8R0090J:~/OpenFOAM/regi-1.1/run/tutorials/icoFoam> dxFoam . cavity
Checking path to dx ...
Can't find OpenDX Foam network:

Well I don't know if there are any incompatibilities between paraview 2.2 and 1.85, probably not, probably there are still some variables missing or not well configurated... also for dx because I cheked and /home/regi/OpenFOAM/OpenFOAM-1.1/.OpenFOAM-1.1/apps/dxFoam/networks/ directory exists.

All times are GMT -4. The time now is 12:32.