CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM Installation (
-   -   Canbt run the tutorial cavity (

fengxs May 6, 2005 17:17

Hi, I tried the tutorial, b
I tried the tutorial, but it did not work.
Any suggestion?
> blockMesh .cavity
| ========= | |
| \ / F ield | OpenFOAM: The Open Source CFD Toolbox |
| \ / O peration | Version: 1.1 |
| \ / A nd | Web: |
| \/ M anipulation | |

Exec : blockMesh .cavity
Date : May 06 2005
Time : 14:06:43
Host :
PID : 809

Usage: blockMesh <root> <case> [-blockTopology]

--> FOAM FATAL ERROR : Wrong number of arguments, expected 2 found 1

Function: argList::check() const
in file: global/argList/argList.C at line: 458.

FOAM exiting
Cannot find JDK at /global/home/xs/OpenFOAM/linux/j2sdk1.4.2_05. Please set JAVA_PATH to the
JDK installation directory.

garcia May 6, 2005 17:59

xiaosi you should cd

you should

cd $HOME/OpenFOAM/<username>-1.1/run/tutorials/icoFoam


blockMesh . cavity

notice the space between the <root> directory "." and the <case> name "cavity"

The second problem is that is not finding java to run runFoamX, You have to be sure that java is installed in your machine and JAVA_PATH set to the proper directory.

By the way which OS are you running at? (I'm also running in the westgrid).


fengxs May 7, 2005 23:24

Hi manuel, Thanks for your
Hi manuel,
Thanks for your reply.
>> cd $HOME/OpenFOAM/<username>-1.1/run/tutorials/icoFoam


blockMesh . cavity

I did run the command in that directory.
nunatak3|xiaosi|25> cd $HOME/OpenFOAM/xiaosi-1.1/run/tutorials/icoFoam
nunatak3|icoFoam|26> blockMesh .cavity

I already put the Java library into
/global/home/xiaosi/OpenFOAM/linux/j2sdk1.4.2_05. How to set the JAVA_PATH? I remembered that the Java path was set in /global/home/xiaosi/OpenFOAM/OpenFOAM-1.1/.cshrc.

The OS is RedHat 9.0 at glacier cluster.

fengxs May 8, 2005 00:24

Hi manuel, I missed the spa
Hi manuel,
I missed the space. The command is
blockMesh . cavity, but I run blockMesh .cavity.

garcia May 10, 2005 13:18

Hi Xiaosi $JAVA_HOME (not J
Hi Xiaosi

$JAVA_HOME (not JAVA_PATH ) is defined in /global/home/xiaosi/OpenFOAM/OpenFOAM-1.1/.cshrc

but the default value should work. I also have Redhat9.

what do you get with this command?

which java

All times are GMT -4. The time now is 14:55.