CFD Online Discussion Forums

CFD Online Discussion Forums (https://www.cfd-online.com/Forums/)
-   OpenFOAM Installation (https://www.cfd-online.com/Forums/openfoam-installation/)
-   -   ParaFoam didnbt work (https://www.cfd-online.com/Forums/openfoam-installation/57755-parafoam-didnbt-work.html)

Leosding (Leosding) January 14, 2005 21:34

I just compiled OpenFoam-1.0.2
 
I just compiled OpenFoam-1.0.2 in RH 8.0 without any problem.

Do the first tutorial icoFoam/cavity following README, blockMesh and icoFoam is ok, but when run paraFoam, it's malfunction. say,

[Leo@localhost icoFoam]$ paraFoam . cavity
ErrorMessage
# Error or warning: ERROR: In /home/kitware/ParaViewReleaseRoot/paraview-1.8.3/Utilities/VTKClientServer/vtkClientServerInterpreter.cxx, line 866
vtkClientServerInterpreter (0x9d4a018): Cannot find module "libPVFoamReader.so". The following paths were searched:
/home/Leo/OpenFOAM/linux/gcc-3.4.3/lib
/home/Leo/OpenFOAM/OpenFOAM-1.0.2/lib/linuxOpt
/home/Leo/OpenFOAM/OpenFOAM-1.0.2/src/lam-7.1.1/platforms/linuxOpt/lib
/home/Leo/OpenFOAM/OpenFOAM-1.0.2/lib/linuxOpt/lam-7.1.1
/home/Leo/OpenFOAM/linux/paraview-1.8.3/lib
/home/Leo/OpenFOAM/OpenFOAM-1.0.2/src/lam-7.1.1/platforms/linuxOpt/bin
/home/Leo/OpenFOAM/OpenFOAM-1.0.2/src/mico-2.3.11/platforms/linuxOpt/bin
/home/Leo/OpenFOAM/linux/j2sdk1.4.2_05/bin
/home/Leo/OpenFOAM/linux/gcc-3.4.3/bin
/usr/local/bin
/usr/bin
/bin
/usr/X11R6/bin
/home/Leo/OpenFOAM/OpenFOAM-1.0.2/wmake
/home/Leo/OpenFOAM/OpenFOAM-1.0.2/bin
/home/Leo/OpenFOAM/Leo-1.0.2/applications/bin/linuxOpt
/home/Leo/OpenFOAM/OpenFOAM-1.0.2/applications/bin/linuxOpt
/home/Leo/OpenFOAM/OpenFOAM-1.0.2/applications/utilities/preProcessing/FoamX/bin/home/Leo/OpenFOAM/linux/paraview-1.8.3/bin
/usr/lib
/usr/lib/vtk
/usr/local/lib
/usr/local/lib/vtk


ERROR: In /home/kitware/ParaViewReleaseRoot/paraview-1.8.3/GUI/Client/vtkPVXMLPackageParser.cxx, line 666
vtkPVXMLPackageParser (0xa1faf80): Error loading Library component PVFoamReader


ErrorMessage end
/home/Leo/OpenFOAM/OpenFOAM-1.0.2/bin/paraFoam: line 57: 1738 Segmentation fault paraview paraFoam.pvs


would some advice?
ps, the paraview's version is not 1.8.0, mine is 1.8.3 from paraview's site. why I have no the libPVFoamreader.so?

Henry Weller (Henry) January 16, 2005 13:29

Are you able to install and r
 
Are you able to install and run the binary release of 1.0.2 with paraview-1.8.0?

If you wish to use paraview-1.8.3 you will have to compile the reader module for which you will need to install kitware's cmake. You will also need to set the environment variables in OpenFOAM-1.0.2/.OpenFOAM-1.0.2/apps/paraview/bashrc and cshrc. Once you have done this go to OpenFOAM-1.0.2/applications/utilities/postProcessing/graphics/PVFoamReader and run the Allwmake script and if you have setup everything correctly the reader module with compile.

I should warn you that we have not tried paraview-1.8.3 and given that the details of the .xml files for the reader module are changed in nearly every release it may well not work. Also we have not tried compiling the reader module using a binary release of paraview, it may or may not work. Did you compile paraview from sources?

Jason J Beech-Brandt (Jasonb) January 17, 2005 05:06

Hi, I've done this with Pa
 
Hi,

I've done this with Paraview-1.8.3 on the Solaris platform and ran into problems as Henry has suggested you may. Everything compiled fine, including the PVFoamReader module, but upon running ParaFoam on a case I got an error, the details of which I can't remember exactly. Just so you know.

Jason

Henry Weller (Henry) January 17, 2005 05:26

I will have a go at updating
 
I will have a go at updating the reader module to work with paraview 1.8.3 for the 1.0.3 release. If someone is interested in having a go before I do the kitware people may have changed the details of the xml description of the GUI/external module in the 1.8.3 release (they have done so in nearly every previous release) which may require changes in OpenFOAM-1.0.2/applications/utilities/postProcessing/graphics/PVFoamReader/PVFoamReader/PVFoamReader.xml.in
and/or
OpenFOAM-1.0.2/applications/utilities/postProcessing/graphics/PVFoamReader/PVFoamReader/PVFoamReader.pvsm.in

Henry Weller (Henry) January 17, 2005 11:05

I have built paraview-1.8.3 a
 
I have built paraview-1.8.3 and the OpenFOAM reader module on my Linux system with only one difficulty: after building and installing paraview I had to copy *.h from Utilities/VTKClientServer of the build location to include/vtk of the installed location otherwise the reader module wouldn't compile. After that it all compiled and ran fine. We will release OpenFOAM-1.0.3 with paraview-1.8.3 unless they release a newer version before then.

Jason J Beech-Brandt (Jasonb) January 18, 2005 06:32

Hi, I must have done somet
 
Hi,

I must have done something wrong last time, as I have just built paraview-1.8.3-solaris and the reader module, and it works fine.

Jason

Norma McKee (Mckee) February 17, 2005 13:24

When trying to build the reade
 
When trying to build the reader module on linux I get the following output.

[OpenFOAM@anio-mtn-cluster PVFoamReader]$ ./Allwmake
make: Nothing to be done for `allFiles'.
make: `lnInclude/uptodate' is up to date.
make: `Make/linuxOpt/dependencies' is up to date.
libso
`/home/OpenFOAM/OpenFOAM-1.0.2/lib/linuxOpt/libvtkFoam.so' is up to date.
-- Check for working C compiler: gcc -- works
-- Check for working CXX compiler: c++ -- works
ParaView must be built with BUILD_SHARED_LIBS ON.
-- Configuring done
make: *** No targets specified and no makefile found. Stop.

any ideas?

Thanks

Mattijs Janssens (Mattijs) February 17, 2005 14:13

Hello, I assume it is not
 
Hello,

I assume it is not possible to use our precompiled paraview-1.8.0 and libvtkFoam.so?

The message you get is from cmake going through PVFoamReader/CMakeLists.txt and means exactly what it says: you need to configure any paraview you use ($ParaView_DIR) to have shared libraries enabled.

Paraview comes with its own instructions on how to do this. Sorry, I haven't done it recently so cannot tell you.

Mattijs

Norma McKee (Mckee) February 17, 2005 14:29

When I try to use paraview-1.
 
When I try to use paraview-1.8.0 I get several messages as:
/paraview: /home/OpenFOAM/linux/gcc-3.4.3/lib/libstdc++.so.6: no version information available (required by ./paraview)
/paraview: /home/OpenFOAM/linux/gcc-3.4.3/lib/libstdc++.so.6: no version information available (required by ./paraview)

Which seems to indicate that the package needs to built with the correct libs.. Would you agree?Since I do not have the source for 1.8.0 I can't do that.

Getting everything to run on our platform has been a very long process. It seems I get one thing fixed and then we find another version/installation problem that must be corrected. Is this typical?

Mattijs Janssens (Mattijs) February 17, 2005 15:09

The warning messages I think
 
The warning messages I think relate to the gcc version the os libs were built with. Have never had problems because of them.

I cannot comment on the ease of the installation process. Seems to work for my Suse9.1 box straight from the downloaded packs.

If you cannot get paraFoam to work you can run paraview stand-alone and use the converter foamToVTK to create files for it.

Mattijs

Hrvoje Jasak (Hjasak) February 17, 2005 15:09

You'll get used to the build
 
You'll get used to the build - once you get it right it's always the same old story. BTW, you are trying to compile a pretty tricky 350 thousand lines of foam (approximately) + a bunch of utilities of high complexity in C++. Just try to think how long it took us to write the damn thing in the first place! :-)


The error in this case was when you tried to configure paraview using cmake -i:

Would you like to see advanced options? [No]:
Please wait while cmake processes CMakeLists.txt files....
Variable Name: BUILD_SHARED_LIBS
Description: Build VTK with shared libraries.
Current Value: OFF
New Value (Enter to keep current value): ON

Good luck,

Hrv

Eugene de Villiers (Eugene) February 17, 2005 17:44

Just curious, what version of
 
Just curious, what version of linux requires that you recompile the entire OpenFOAM source instead of using the existing binaries?


All times are GMT -4. The time now is 17:01.