CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM Installation (
-   -   paraview error (

mevsfedora April 4, 2009 09:16

paraview error
Hello to everyone.

First of all, I am new to Linux. I use Fedora 10 and wanted to start working with OpenFOAM.
I tried to install it and after two days, I cannot help myself and I hope that somebody of this Community can help me.

I downloaded the OpenFOAM packages from the Website and did everything, how it is explained in the README.
The foamInstallationTest brought only 1 fatal error (no connection to rsh, or ssh), but I already read on some sites, that this is not critical for an stand alone system.

So my Problem now is: If I want to us paraview, i got an error message. I tried this, like in the README:
cd $HOME/OpenFOAM/$USER-$WM_PROJECT_VERSION/run/tutorials/icoFoam/cavity

then I get the message:
/home/Maddin/OpenFOAM/OpenFOAM-1.5/bin/paraFoam: line 100: paraview: command not found

line 100 is the following:
paraview --data=$caseFile

I really don't know what to do.

Thanks for any Help


mevsfedora April 4, 2009 17:36


After I tried nearly everything I read in this Forum and on other sites, I found out, that I can install ParaView via System->Administration->add software.
Now ParaView works and I can start it. The only Problem now is, that I can't open the cavitiy example file (and also the file I wanted to work with), because he can't find the right reader.

So I will search for an solution.

Thanks for everybody who read this and wasted some seconds for me :)

If anybody knows an simple soultion for my problem now, I would be thankful for an answer.

Good Night

lin April 5, 2009 09:44

Installing paraview from system repository like you,the simple solution is to use "foamToVTK". Paraview could open vtk files.

mevsfedora April 6, 2009 05:30

Thanks for the help. foamToVTK works perfect. :)

All times are GMT -4. The time now is 13:24.