CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM Installation (
-   -   Critical Error wxecuting foamInstallationTest (

ziooscuro April 22, 2009 05:03

Critical Error wxecuting foamInstallationTest
I try to install openFOAM 1.5-dev. If i execute icoFoam, it works properly, but when i try to make the installation test i receive this error:

WARNING: gcc version does not match gcc supplied with this release of OpenFOAM
Supplied version: 4.3.1
User version : ../configure
Minimum required: 4.2.0

gcc ...figure
WARNING: Conflicting installations:
OpenFOAM settings : /nfs/home/bruno/OpenFOAM/ThirdParty/gcc-4.3.1/platforms/linux64/bin/gcc
current path : /usr/bin/gcc

gzip 1.3.12 /usr/bin/gzip
tar 1.19 /bin/tar
icoFoam 1.5-dev ...nFOAM-1.5-dev/applications/bin/linux64GccDPOpt/icoFoam

Actually there's already an installed version (1.5) on the server and i guess that this could be the "Conflicting installations"..... but how can i fix the critical error?
Thanks in advance

StructureITA April 25, 2009 13:32

I have almost the same error. Does someone have the solution, please? I'm searching in the whole forum, but I am not able to find an answer.

StructureITA April 25, 2009 14:06

I tried this way: I opened (conteined within OpenFOAM/OpenFOAM-1.5.x/etc) and I changed the line "compilerInstall" from OpenFOAM to System. In this way my "critical error" disappeared.

ral007 May 2, 2009 17:24

inconsistent path definition
I have modified the to System to compile the code with Gcc version 4.3.3 in Ubuntu 9.0.4 distribution, and the baseline installation was deemed to be ok by foamInstallationTest. However, when checking for the icoFoam executable path, there was one inconsistent path definition with FOAM_APPBIN and FOAM_USER_APPBIN. I have not figured out how to fix the problem yet.

WARNING: Conflicting installations:
OpenFOAM settings : /home/rlee/OpenFOAM/OpenFOAM-1.5/applications/bin/linuxGccSPOpt/icoFoam
current path : /home/rlee/OpenFOAM/rlee-1.5/applications/bin/linuxGccSPOpt/icoFoam

Does anyone know how to fix this ?

All times are GMT -4. The time now is 09:52.