CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM Installation (
-   -   OpenFOAM-dev Live USB CD, SLAX based (

hellorishi May 12, 2009 16:33

OpenFOAM-dev Live USB CD, SLAX based

I found an interesting link to a Live CD or DVD or USB installation of OpenFOAM based on SLAX.

However I could not find a link to download it. It seems to be a recent version 2009-05-09.
This may sound dumb. Can anybody help me: how to download it?

Thanks to Hakan & Henrik for developing and releasing OpenFOAM-Live !


hani May 13, 2009 03:25

Hi Rishi,

Please be patient. We are about to release it after some more testing. The link you found was due to preparations for the release.

I think that you will enjoy it.


henrik May 14, 2009 04:46

Dear All,

there are issues with deleting and updating large files on Sourceforge. A beta-version of SLAX Distro enhanced with OpenFOAM modules which we prepared for the upcoming OpenFOAM Workshop in Montreal can be found here: (822MB) (562MB)

The distribution boots from USB/DVD/CD and may be extended by adding modules from or other sources.

Have fun and let us know if works (or not).


--- Instructions for a bootable USB-Stick ---

cd /media/disk
tar xfz OpenFOAM_SLAX.tgz
cd boot
./ (bootinst.bat in Windows)

--- Instructions for a bootable CD/DVD ---

Make an iso out of the tgz by executing

tar xfz OpenFOAM_SLAX.tgz
cd slax (slax/make_iso.bat in Windows)

and burn the result.

--- Content ---

24M OpenFOAM-1.5-dev.General_r1238.lzm
33M OpenFOAM-1.5-dev.linuxGccDPOpt_r1238.lzm
262M OpenFOAM-1.5-dev.linuxGccDPDebug_r1238.lzm (only full release)
380K PyFoam-0.5.2.lzm
83M ThirdParty.General_2009-05-09.lzm
68M ThirdParty.linux_2009-05-09.lzm

15M blender-2.47.lzm
6.8M engrid.lzm
6.2M ghostscript-8.61.lzm
588K gnuplot-4.2.4.lzm
1.5M grace-5.1.21-i486.lzm
904K gsl-1.8.lzm
6.4M imagemagick-6.4.8-3.lzm
4.6M mplayer-1.0.lzm
42M tetex-3.0-5.lzm

19M emacs-cvs-23.lzm
1.3M geany.lzm
96K leafpad-0.8.16-i486-1as.lzm
6.8M vim-7.1.lzm

and many more.

hani May 14, 2009 15:44


The full tgz version and an iso for burning a CD/DVD is now also available at OpenFOAM-extend:
Click on Download
Click Release OpenFOAM_SLAX and download the tgz or iso.
Find information by clicking on the 'notes' icon

Get back to us with feedback!


hellorishi May 15, 2009 05:49

Hello Håkan and Henrik,

Thanks for the wonderful distribution!
I can finally use paraFoam !
I will try the other TGZ (only if this stupid IE downloads it successfully).

I downloaded the ISO and burned it. It works perfect! SLAX distribution is also good & seems like a lightweight, useable distribution. I guess it will solve a lot of beginner installation problems. As a beginner I spend weeks on installing OpenFOAM. This will help more people to get onboard easily. I know a few people who gave up the idea of using OpenFOAM because of complicated installation...

-please include the md5 sum on the webpage. So that people like who must use stupid IE can know if its correctly downloaded using (

-including shortcut to the OF Userguide & Programmer guide on the desktop might help beginners.(not necessary).
-for complete linux beginnners some sort of "linux for dummies" or linux "cheat-sheet"
( might be helpful.

Thanks and regards,

henrik May 15, 2009 06:56

Dear Rishi,

thanks for your very positive feedback and useful suggestions. I've put them on the TODO list - with cheat-sheet right on the top ;-)

Once a new user is happy/familiar with OpenFOAM on SLAX. He may choose to do a proper installation using what's on the Stick/CD/DVD. Simply log in as root (password toor) and copy /OpenFOAM into /mnt/sdaX/home/user. But be careful! Then, boot into normal Linux, change the ownership of the files and follow the normal installation procedures. The full source comes with the distro. However, there may be trouble with the binaries - We did not investigate this route.

The md5sums for the current version are:

b78fe1ab22127a62f60f0cce8db624f4 OpenFOAM_SLAX.iso
a644a0ef376ed691f617cb29fe8c4bda OpenFOAM_SLAX_noDebug.iso
3b256c3cb998956b3606ebf321d66e71 OpenFOAM_SLAX.tgz
ebbc653e6b30672a4d696ba94b57b4fb OpenFOAM_SLAX_noDebug.tgz

Just for future reference: These numbers apply to the current release and will obviously change in future. We will find a better way for their distribution when the dust settles.

Regards, Henrik

hellorishi May 15, 2009 13:15

Hello Håkan and Henrik,

I played with the liveCD and then installed it on a HDD using the instructions given on ( I tried your way first,however I could not succeed). Now after HDD installation its running pretty well. I am able to save data on HDD.

Some more comments:
-pyFoam is working partly. Imp scripts like, etc which are useful for running a case are fine.
- pyFoamDisplayBlockMesh gave error: " No Module named VTK"

-some files which even beginners might edit have root as owner.
e.g. simpleFoam/pitzDailExpInlet/system/decompose
(considering most laptops are now dual core....)
other files in case/system folder also have root as owner...

-USB mounting is an issue.
Error is "feature available only with HAL"
No auto-mount for USB key with liveCD or by right click method.
I could do it by mount using Terminal. (This issue remains same even after HDD install)

-Networking is an issue. Maybe some module related to network should be included. I got a lot of "LISA" notifications. (I can finally access the network, but beginners...)

- "Wish"
This is too much to ask, but I would "wish" to see KILE (LaTeX gui in KDE) in the distribution. I agree not even many experienced linux users use it, forget beginners...

Wish you a nice weekend,

PS: Is there a wiki for this? I would like to contribute to a wiki, however I dont want to duplicate, if one already exists...

hani May 16, 2009 13:40


We chose to have the full OpenFOAM installation as root, so that you don't mess up the installation, including the tutorials. I always advice people never to do any modifications in the installed tutorials, but rather make your own copy of the tutorials and modify those instead. Then you know that the files in the installation are untouched. Same with source files - if you are skilled enough to modify these, you are skilled enough to do it as an add-on library in your working directory. Again, then you know that the files in the installation are untouched. Only people who *really* know what they are doing should modify the installed files, and then it would be with the purpose of committing to OpenFOAM-extend.


henrik May 17, 2009 11:04

Dear Rishi,

thanks for your comments and suggestions.

Please keep in mind, how this project came about. We wanted an easy to use vehicle to deliver training and workshop material for the upcoming event in Montreal. So the spec was:

- Runs on as many computers as possible
- Usable as data-drive from Windows & Mac, hence FAT32

It is not meant to be a production system.

@pyFoam: We saw problems with pyFoam which were related to paraview, GL and graphics cards. Looking at the many threads in the forum concerning paraFOAM, I must say that I am surprised that "this" paraFoam runs on so many machines.

Please keep in mind that pyFoam is not subject of that many trainings. Therefore, fixing such problems is not high on our agenda. Nevertheless, thank for reporting the problem, we will have a look, but please let us know how we can fix it when you find out.

@root ownership: I agree with Hakan. It's a feature, not a bug.

@USB mounting: I have the same problems, both as slax and root. It would be nice to have easy access to a second USB stick! I don't know what the issue is, but it may well be that we simply need to pull in another module. Please consult the SLAX forum for hints and let us know.

@Networking: I got wired LAN including NFS (note the nfs modules) to run on my laptop which made my life a lot easier.

I could not get WLAN to work which I think is interesting - but not essential - for the kind of use we envisaged. Again, there may be a module out there.

@Kile: There is a kile module on, go a grab it.

Now that we decided to release it into the wild, it's also nice that the absolute Rookie can get his hand on a decent installation of FOAM. In fact, all you need to know is how to download one file from the internet, burn a CD and to reboot your computer. I agree we should improve the guidance when an uninitiated user finds himself left on the "blank" desktop. On my list, I have: Links to the manuals, Linux-cheat-sheet, working locate-command - Anything else?


hani May 17, 2009 15:16


Just some additional comments:
pyFoamDisplayBlockMesh requires VTK, which must be installed as a separate module, so if you make or find such a module, all should be fine.

USB mounting: At least you can reach the same USB that you are running the SLAX distro from (if you are running it from USB), see /mnt/live/mnt

Rookie guidance: This is something for the OpenFOAM Teaching Working Group to work on. Link to manuals should be enough for now, but there is a need for more documentation and written tutorials. People are working on it.


hellorishi May 18, 2009 07:22

Hi Henrik,

Thanks for guiding me to KILE module.

I could manage to partially solve the USB mount by using the module Kursader.
Krusader-> Tool-> Mountman. This avoids the mount from terminal as root.

There is a long thread about USB mount. I tried changing /etc/group and "hald --retain-privileges".
It was not much help.

Krusader is ok I guess...


gschaider May 18, 2009 10:15

For the general public:


Originally Posted by henrik (Post 216407)
@pyFoam: We saw problems with pyFoam which were related to paraview, GL and graphics cards. Looking at the many threads in the forum concerning paraFOAM, I must say that I am surprised that "this" paraFoam runs on so many machines.

Please keep in mind that pyFoam is not subject of that many trainings. Therefore, fixing such problems is not high on our agenda. Nevertheless, thank for reporting the problem, we will have a look, but please let us know how we can fix it when you find out.

Henrik asked me about the VTK problem and whether it would be possible to use the VTK from paraView. The short answer is: not with the current version. The "standard" for GUIs in Python is still using Tkinter which is AFAIK a wrapper for Tcl/Tk. As it seemed to introduced the least overhead at the time I used it when writing the BlockMesh-Viewer. Seems like the VTK that comes with Paraview hasn't got Tk enabled. Don't think it is sensible to recompie paraview just for one Python-Skript.

With "normal" distributions I'd recommend the vtk that comes for the system (most distros nowadys have it in the standard-repo). For distros like SLAX where space is an issue the best alternative is the simpleViewer bei Gavin Tabor (http://openfoam-extend.svn.sourcefor.../simpleViewer/) that offers similar functionality. The Fox-Toolkit for the GUI that is needed for that should have a lower footprint


smart May 20, 2009 15:40

Cannot boot from USB device
Hi, I will be at Montreal for the OpenFOAM workshop in June. I tried to see if slax boot with my usb storage device but I cannot do it since during the bootable process, the following message occured:

Fatal Error: slax directory cannot be found...

My computer is a dell inspiron E1505 and my usb device a Verbatim (1Go).

In addition, I am running ubuntu 9.04 and windows xp in dual boot. I tried to install OpenFOAM 1.5 without success since some error occured. Firstly,

sylvain@Sylvain:~/OpenFOAM/OpenFOAM-1.5/bin$ ./foamSystemCheck

Checking basic system...
Shell: /bin/bash
Host: Sylvain
OS: Linux version 2.6.28-11-generic
User: sylvain

System check: PASS
Continue OpenFOAM installation.

So I tried the following installation test in "read me file":

sylvain@Sylvain:~/OpenFOAM/OpenFOAM-1.5/bin$ foamInstallationTest
Executing /home/sylvain/OpenFOAM/OpenFOAM-1.5/bin/foamInstallationTest:

Checking basic setup...
Shell: bash
Host: Sylvain
OS: Linux version 2.6.28-11-generic

Checking main OpenFOAM env variables...
Environment_variable Set_to_file_or_directory Valid Crit
$WM_PROJECT_INST_DIR /home/sylvain/OpenFOAM yes yes
$WM_PROJECT_USER_DIR /home/sylvain/OpenFOAM/sylvain-1.5 yes no
$WM_THIRD_PARTY_DIR /home/sylvain/OpenFOAM/ThirdParty yes yes

Checking the OpenFOAM env variables set on the PATH...
Environment_variable Set_to_file_or_directory Valid Path Crit
$WM_PROJECT_DIR /home/sylvain/OpenFOAM/OpenFOAM-1.5 yes yes yes

$FOAM_APPBIN ...M-1.5/applications/bin/linuxGccDPOpt yes yes yes
$FOAM_USER_APPBIN ...n-1.5/applications/bin/linuxGccDPOpt yes yes no
$WM_DIR .../sylvain/OpenFOAM/OpenFOAM-1.5/wmake yes yes yes

Checking the OpenFOAM env variables set on the LD_LIBRARY_PATH...
Environment_variable Set_to_file_or_directory Valid Path Crit
$FOAM_LIBBIN ...nFOAM/OpenFOAM-1.5/lib/linuxGccDPOpt yes yes yes
$FOAM_USER_LIBBIN ...enFOAM/sylvain-1.5/lib/linuxGccDPOpt yes yes no
$MPI_ARCH_PATH ...penmpi-1.2.6/platforms/linuxGccDPOpt yes yes yes

Third party software
Software Version Location
gcc 4.3.1 .../OpenFOAM/ThirdParty/gcc-4.3.1/platforms/linux/bin/gcc
gzip 1.3.12 /bin/gzip
tar 1.20 /bin/tar
icoFoam 1.5 ...AM/OpenFOAM-1.5/applications/bin/linuxGccDPOpt/icoFoam

Checking networking...
Action Result Crit
Pinging_Sylvain Successful yes
Pinging_localHost Successful yes
Test_rsh: Unsuccessful_connection_refused* yes
Test_ssh: Unsuccessful_connection_refused* yes
FATAL ERROR: No remote shell available.
OpenFOAM 1.5 enviroment requires either ssh and/or rsh.
Contact your system administrator.


The system test has evoked 1 fatal error(s).

Critical systems ok.

Review the output for warning messages and consult
the installation guide for trouble shooting.


If you have any idea since I would like to have a OpenFOAM installation previously to the workshop.

Thank you very much to give me some comments about that.

henrik May 20, 2009 16:34

@ Fatal Error: slax directory cannot be found...

The stick's filesystem may be corrupt. Try a fresh (formatted) stick, copy the files and make it bootable.

@your installation problem:

a) It's off-topic here. There are many thread that deal with this sort of stuff.
b) The fatal error is on ssh. You don't need that until you go for parallel. So take what you have for a spin and see how it goes.


maruthamuthu_venkatraman July 3, 2009 06:41

OpenFoam Installation with SLAX
I copied OpenFoam_ SLAX version files from sourceforge and extracted them in USB stick.

I clicked the bat file in Boot directory in Windows. Then when i mount the USB ( Flashing mode)

Message as below:
" I got Error in Operating system "

Iam new to both OpenFoam and Linux. If anybody can show me how to install the same it would be greatful. May be the link exists somewhere, but i couldnt find them.


hellorishi July 3, 2009 06:50

Did you format the USB stick before copying?
I had no problems with a formatted USB stick.

maruthamuthu_venkatraman July 4, 2009 06:33

Hi Rishi,
Thanks for your reply. It needs FAT32 format before copying the OpenFoam_SLAX on USB. The problem is solved...

I ran Cavity, Just cool!paraFoam also started working....

Thanks to those great minds developed for OPENFOAM_SLAX.

Best Regards,

henrik July 5, 2009 13:00

Dear Muthu,

thanks for you feedback. It's nice to hear that you find it both working and useful.

Just some background information on FAT32: SLAX works with FAT32 by mapping a Linux file system on top of it. Of course, this will not nearly be as stable as a proper Linux file system, but you can use the stick as a mass storage device under Windows/Mac which was essential for distributing the Workshop material.

We saw a couple of corrupted USB keys, sometimes it was possible to fix them,

sometimes the stick only came back to life after reformatting. So be careful.

Another option for those who want a take-with-you OpenFOAM pendrive: Format the stick with a Linux file system (ext3), copy the directories and make the stick bootable using Have a look here.

Have fun,


tomislav_maric August 1, 2009 10:31

use SLAX live DVD to run in parallel on a LAN
Thank you both Dr. Henrik Rusche and Professor Håkan Nilsson for the very cool live SLAX distro. :D

I want burn a bunch of live DVDs and run multiphase simulations for my semester project on a [depart]mental LAN that's not used over the summer (I'm a final year graduate student with keys to the computer lab :D).

Now, this is what I've figured out so far, for to run OpenFOAM simulations on a LAN via Open MPI:

1) change the hostnames for --hostfile option of the mpirun command
2) make sure the nodes recognise each other's new hostnames
- in /etc/hosts - enter IP addresses and hostnames
3) start sshd on all the hosts, with no password access
- I've found instructions here:

I've skipped other network configuration because I'm using a router that
sets the IP addresses of the nodes.

That's it: I have a network of workstations running SLAX live and I can do simulations in parallel.

Unfortunately for me, things got complicated. Here are my questions:

Question 1
In order for Open MPI to run on all the nodes, pathnames to binaries must be the same. On Open MPI web site, it is explained how these conditions are met in the simplest way with NFS. Is NFS needed in case of LiveDVD? I'm asking because the pathnames already are identical, as well as uid, guid, etc for obvious reasons.

Question 2
In order to set ssh to work without a permission, I've followed the above mentioned link, but the problem came when I had to copy .ssh directory to a node. I can't use scp as suggested in the tutorial, because sshd isn't running on other node. What is the easiest way to set up ssh without passwords?

Is the idea to use the SLAX live DVD to run simulations on LAN a sound one? If so, I would greatly appreciate advice in that direction. If I manage to get it up an running, I promise I will write a tutorial on the Wiki pages. :D

I'm not new to FOAM or Linux, but I'm new to networking, so I apologize for any misdirected (or stupid) questions. :D

tomislav_maric August 1, 2009 15:24

hello, it's me again. :confused:

I've managed to make the ssh work without a password. I can use scp now and login with ssh without a problem.

What bothers me now is that I get bash: orte: command not found error when I run mpi -H mario -np 2 interFoam -parallel .

I've googled my eyes out :eek:, but all I can find are instructions to have my LD_LIBRARY_PATH and PATH both on master and slave set correctly and to take a look at bash_profile for an if comman that returns the shell if it's started in non interactive mode, before setting the env. variables.

my LD_LIBRARY and PATH are set correctly on both computers, commands which orted and which mpirun point to right places on both computers and there's no if command in the bash_profile.

It seems I'm one step away from burning 10 dvds and having my own Network Of Workstations to play with, so: PLEASE HELP ME. :D

All times are GMT -4. The time now is 23:13.