CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM Installation (
-   -   Problems compiling OF solvers (

madad2005 June 29, 2009 06:49

Problems compiling OF solvers
Dear All,

I've been attempting to compile v1.5 from source on suse 11.1 using the system compiler, but I have been having a strange issue. I managed to compile the /src directory fine with no errors. However, I'm now trying to compile the applications/solvers directory and every one gives me the same error (see below). It claims it can't find any of the shared libraries, although I am sure they are being linked in (and they do exist in /home/adriano/OpenFOAM/OpenFOAM-1.5/lib/linux64GccDPOpt )

Any ideas?

linnemann June 29, 2009 08:21


try gcc -print-search-dirs

If the path you mentioned isn't in that list it cannot find the libraries.

you have remembered to change the bashrc and accordingly to be able to use the system compiler?

if all other fails add this to your .bashrc.


If this doesn't work I'm out of ideas


madad2005 June 29, 2009 08:58

linneman, that has solved the problem. I didn't realise there were special settings when using the system compiler, but adding it to LD_LIBRARY_PATH has worked a treat.

Thank you for your help! :-)

All times are GMT -4. The time now is 03:15.