CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM Installation (
-   -   Install of OpenFOAM 1.6 Error 1 Error 2 & run tutorial (

potac August 26, 2009 08:32

Install of OpenFOAM 1.6 Error 1 Error 2 & run tutorial
New in OpenFOAM and want to learn it but even if it seems I compiled OF 1.6 on my openSuse 11.1 KDE 4.3 Qt 4.5 from source successfully I am not able to reach the same result using git repo following the wiki guidelines. The ThirdParty sw compilation was fine but the OF ends up after several minutes saying this etc.:
/usr/lib64/gcc/x86_64-suse-linux/4.3/../../../../x86_64-suse-linux/bin/ld: cannot find -liberty
collect2: ld returned 1 exit status
make[2]: *** [/home/potac/OpenFOAM/OpenFOAM-1.6.x/applications/bin/linux64GccDPOpt/dnsFoam] Error 1
make[1]: *** [dnsFoam] Error 2
make[1]: Target `application' not remade because of errors.
make: *** [DNS] Error 2

I think the problem is related to this -liberty. But I cannot find any hint.

Using the source compiled OF, I have tried to run tutorial from user guide but when trying running blockMesh for case of Cavity it says:
cannot open file
file: /home/potac/OpenFOAM/OpenFOAM-1.6/tutorials/incompressible/icoFoam/cavity/constant/polyMesh/system/controlDict at line 0.
From function regIOobject::readStream()
in file db/regIOobject/regIOobjectRead.C at line 62

Does it mean that even source compilation failed, or what else I am missing?
Thanks a lot!

gwierink August 27, 2009 02:30

Dear Jan,

It seems that part of the code did not compile. This can happen in a part of Allwmake in the OpenFOAM-<version>/src/ (have a look in the Allwmake script). The OpenFOAM Wiki suggests on that problem (see bottom section on "/usr/bin/ld: cannot find -lfiniteVolume") to compile a second time and that then the necessary parts are compiled. Also, have a look at Albert Passalacqua's blog, he has a lot of good tips on how to get OpenFOAM to work on OpenSUSE.

Hope this is a start,



potac August 27, 2009 06:15

Thanks Gjilsbert. That blog helped me a lot.
During the compilation process there appeared several warnings about unused variables. I just guess it has had no effect.
Now I can explore OF.

gwierink August 27, 2009 09:04

You're welcome, Jan. I also had some "unused variable ..." errors and everything works fine :).

All times are GMT -4. The time now is 14:27.