CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM Installation (
-   -   Problems installin OpenFoam-1.5-dev in Ubuntu 8 (

tmata2002 September 18, 2009 15:16

Problems installin OpenFoam-1.5-dev in Ubuntu 8
Hi Foamers,

I am trying to install OpenFoam-1.5-dev in Ubuntu 8. I have downloaded the developer version from the svn repository, using the comand svn checkout <path of the version>. After that I downloaded the Third Party version from the OpenCFD website.

I have decompressed both packages with no problems. I also made the changes in the .bashrc file file, after some errors were reported by the foamInstalationCheck utility.

Then, I tried to compile with no sucess. After analysing the errors, I identified some problems that terminate the compilation.

1- It looks like that flex is needed in order to perform the compilation. Am I right? I remenber when I compiled version 1.5 I did not need it, but, of course, versions are different. The error message that I got that made me think that is the following

SOURCE=triSurface/interfaces/STL/readSTLASCII.L ; flex --c++ -f $SOURCE ; mv Make/linuxGccDPOpt/readSTLASCII.C ; g++ -m32 -Dlinux -DDP -DFOAM_DEV_REVISION_NUMBER=1433 -Wall -Wno-strict-aliasing -Wextra -Wno-unused-parameter -Wold-style-cast -O3 -DNoRepository -ftemplate-depth-40 -I/home/titio/OpenFOAM/ThirdParty/zlib-1.2.3 -IlnInclude -I. -I/home/titio/OpenFOAM/OpenFOAM-1.5-dev/src/OpenFOAM/lnInclude -I/home/titio/OpenFOAM/OpenFOAM-1.5-dev/src/OSspecific/Unix/lnInclude -fPIC -pthread -c Make/linuxGccDPOpt/readSTLASCII.C -o Make/linuxGccDPOpt/readSTLASCII.o
/bin/sh: flex: not found.

Besides flew, what other software I need that is not included in the Third Party Software?

2 - I noticed that many of compilation commands failed because libraries, like for example, could not be found. I think this problem is due to the flex problem. A typical error of this kind is

+ wmake libso meshTools
/usr/bin/ld: cannot find -ltriSurface
collect2: ld returned 1 exit status
make: *** [/home/titio/OpenFOAM/OpenFOAM-1.5-dev/lib/linuxGccDPOpt/] Error 1

Can anyone help me out here. I am reading other posts concerning but I can not figure out what is going on.

Good weekend to all and thanks in advance,

Teresa Mata

gwierink September 19, 2009 03:49

Hi Teresa,

1. The actual compilation of OpenFOAM needs some extra packages. Just look for and install the packages with "sudo apt-get" or Synaptic packege manager:
  • flex and flex++ (just grab anything with "flex")
  • binutils
  • zlibs (at least in Fedora, not sure about Ubuntu)
2. Problems with ld not finding things seem to be solved when compiling a second time, as the OpenFOAM Wiki suggests. I suggest to install the missing libraries above and then go through the install script line by line to find the problem (open the Allwmake script to find what it does).

Hope this is of any help. Just post following errors (if you get any :)).



titio September 23, 2009 10:50

Everything o.k

Everything compiled O.K, after four hours in my PC. Thanks,

Teresa Mata

All times are GMT -4. The time now is 05:04.