CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM Installation (
-   -   Paraview crash after opening OF case (

gfilip September 23, 2009 15:27

Paraview crash after opening OF case

I just installed OF1.6.x using Mads' script (, followed by paraview installation using the makeParaView script inside the ThirdParty folder. The installation seems to be successful as paraview runs fine until I attempt to use paraFoam to open a OF case, such as /run/cavity.

When I run paraFoam, a dialog pops up asking to select a reader for "cavity.OpenFOAM" as one could not be found. I select "OpenFOAM files" from the list of readers, and paraview crashes. Here is the terminal output:


greg@greg-laptop:~/OpenFOAM/greg-1.6.x/run/cavity$ paraFoam
created temporary 'cavity.OpenFOAM'
Read float past end of buffer
Read float past end of buffer
Read float past end of buffer
Read float past end of buffer
terminate called after throwing an instance of 'std::length_error'
  what():  basic_string::_S_create

Any ideas as to what might be wrong?



gfilip September 23, 2009 17:11

I found the solution to my problem.


cd $FOAM_UTILITIES/postProcessing/graphics/PV3FoamReader

Thanks to


rassilon October 5, 2009 23:43


Originally Posted by gfilip (Post 230357)
I found the solution to my problem.


cd $FOAM_UTILITIES/postProcessing/graphics/PV3FoamReader

Thanks to


Hmmm. I am getting this exact same problem on my new install - I have tried building the PV3 module a couple of times, but Paraview still hangs with the error message you describe.

Is there anything else that I need to do to to get Paraview to utilise the reader?


gfilip October 6, 2009 08:44

Unfortunately I do not know what could be the causing the problem for you.

From what I have been reading, paraview seems very sensitive to the version of Qt you have installed. I also found this information which basically reiterates my solution but goes into a little more depth.


If you have problems with paraFoam and the dev version you might have to recompile paraFoam (see If paraFoam loads, but doesn't know which reader to use to display your OpenFoam results, recompiling the PV3FoamReader should suffice.
To do so, first make sure the environment variable $ParaView_INST_DIR contains the correct path (in my version of OF-1.5-dev there was a typo, a wrong "-"). If not, correct it in ~/OpenFOAM/OpenFOAM-1.5-dev/etc/apps/paraview3/bashrc and re-source ~/.bashrc. Then proceed with ./Allwclean and ./Allwmake in ~/OpenFOAM/OpenFOAM-1.5-dev/applications/utilities/postProcessing/graphics/PV3FoamReader.


Hope that helps, and good luck.


nisha October 14, 2009 14:46

Paraview crash-- reader not found
this post might help you for the solving paraview crash, or reader not found error.
The problem lies with the Qt Assistant...!! as openFOAM insists to use correct version.

Although you may be thinking that you have installed Qt4 latest version
and its libraries from synaptic manager, or elsewhere, do a check this way:

nisha@newton:~$ qmake --version

it gave me this:

Qmake version: 1.07a (Qt 3.3.8b)
Qmake is free software from Trolltech ASA.

As you can see, my Qt is 3.3.8b.
but paraview requires Qt-4.3.5 ..!!! :confused:

Solution to the problem is to install Qt-4.3.5 and make paraview find it..
Follow the steps as below: ;)


Download qt-x11-opensource-src-4.3.5.tar.gz (approx. 40MB)
and unpack it in your /tmp folder. There now should be a folder called /tmp/qt-x11-opensource-src-4.3.5 on your system

Go to that folder
cd /tmp/qt-x11-opensource-src-4.3.5

set the path you want to install Qt-4.3.5 in, e.g.
./configure -prefix ~/OpenFOAM/ThirdParty/Qt-4.3.5

you may have to accept the GNU-license. Now compile (takes some time...)

and install
make install

add the following lines to your ~/OpenFOAM/OpenFOAM-1.5/etc/bashrc at the very end

# set QT related variables
export PATH=$QT/bin:$PATH

Now paraFoam should run smoothly...

If not, maybe you have to recompile the PV3FoamReader as

rm -rf paraview-3.6.1/platforms

hope this helps....!!!!!!

seems compiling makeParaView is returning error..!
"command not found"

:-( someone help me..!

All times are GMT -4. The time now is 04:22.