CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM Installation (
-   -   compiling the Pv3FoamReader (

luke86 September 25, 2009 00:09

compiling the Pv3FoamReader
Hi i am attempting to install OpenFOAM on ubuntu 9.04 but this has proven quite difficult considering my limited skills in using linux. following the readme file i have managed to install OpenFOAM correctly however when i attempt paraFoam it comes up with an an error saying paraview not found,
following the readme file again i attempted to compile paraview from sources, when that didnt work i downloaded and installed qt-x11-opensource-src-4.3.5 in the third party directory as the readme file has told me to do and then compiled paraview using:
makeParaView -qmake <path_to_qmake>

this has appeared to of worked however when i try and recompile the Pv3FoamReader i get:
Qt QTGUI library not found.
CMake Error: The following variables are used in this project, but they are set to NOTFOUND.
Please set them or make sure they are set and tested correctly in the CMake files:
used as include directory in directory /home/luke/OpenFOAM/OpenFOAM-1.6/applications/utilities/postProcessing/graphics/PV3FoamReader/PV3FoamReader

-- Configuring incomplete, errors occurred!
+ make
make: *** No targets specified and no makefile found. Stop

in addition if i try and use the foamToVTK comand and then open using paraview it still comes up with paraview not found.

any help would be most appreciated keeping in mind that i am new to linux.

nimbus1947 September 27, 2009 10:49

ive installed the binary of the openfoam in linux and it works pretty well.Follow the link which ive posted...
but i haven't compiled from the source as you tried.
Any way wishes....

gwierink September 28, 2009 02:23

Hi Luke,

You seem to be missing some OpenGL (and possibly mesa) libraries (libqt4-opengl and libqt4-opengl-dev and those kind of things). Just install the whole bunch that is listed in this post. Hope it helps.



luke86 September 28, 2009 04:57

just for anyone who might be experiencing the same problem as me i fixed it by downloading and installing paraview by using the command:
sudo apt-get install paraview

it then downloaded and installed all the missing libraries as well as installing paraview and now paraview and the paraFoam command works fine

a ridiculously easy solution considering the time i spent trying to correct the problem, thanks for the point in the right direction gwierink

All times are GMT -4. The time now is 04:21.