CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM Installation (
-   -   foamInstallationTest Environment not configured (

mahzironrazak September 25, 2009 10:51

foamInstallationTest Environment not configured
Hi all

I am trying to install OpenFOAM on my Opensuse 10.3 32 bit. The problem is that when i run the foamInstallationtest, it always says environment variable not configured. I dont know why. I did everything according to the installation procedure.

1) Extract everything in the $Home/OpenFOAM/OpenFOAM-1.5/ directory
2) Edit the bashrc file by adding . $Home/OpenFOAM/OpenFOAM-1.5/etc/bashrc at
the end of the file using Kate
3) source the bashrc by typing . $HOME/.bashrc in the terminal (close and open the
4) Run the foamInstallationTest
This i got fatal error because environment variable not configured.

I read all the posts but still cannot figure out why the variable wont configure. I tested on 3 different pcs running suse10.3 and 11 and still no go. I put the dot and space before the $HOME/OpenFOAM... I also tried different version of Openfoam (1.6 and 1.4) still get the same result.

Help Pleaseeeeeeeeeeeeeeee


scottneh September 25, 2009 19:37

I just resolved this issue.

In the terminal execute:

nano ~/.bashrc

this depends on the editor you use, mine is nano.

then in the editor enter:

export FOAM_INST_DIR=path/to/OpenFOAM
[ -f $foamDotFile ] && . $foamDotFile

Make sure you replace "/path/to" with the correct path to your OpenFOAM directory. Save and close the file

then execute:

source ~/.bashrc

that got my installation working.

akidess September 26, 2009 12:55

Scott, that is pretty much equivalent to what he is already doing. However, Mahziron, are you using OpenFOAM 1.5 or 1.6? I'm assuming you are entering a wrong path to the OpenFOAM bashrc. A problem might be that you have to extract the archives in $HOME/OpenFOAM/ and NOT $HOME/OpenFOAM/OpenFOAM.1.X/.

You could use the OpenFOAM cookbook script ( if you are ok with it redownloading the code.

mahzironrazak September 29, 2009 12:53

thanks scott & akidess

I am using 1.6 version. Anyway, i changed to Ubuntu and managed to install it using the cookbook script link provided by akidess. It took a few hours of compiling though 5 to be exact using my old notebook.

All times are GMT -4. The time now is 21:58.