CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM Installation (
-   -   OpenFOAM-dev Live USB DVD, based on kubuntu (

henrik May 23, 2010 05:58

OpenFOAM-dev Live USB DVD, based on kubuntu

the USB-Stick-Team (Oliver Borm, Bernhard Gschaider, Henrik Rusche) proudly presents the release candiate of this year's OpenFOAM Workshop-USB-Stick. It is a continuation is last year's effort discussed in

We tried to build on that experience and the helpful comments - thank you!

The image is based on Kubuntu 10.04 and currently includes OpenFOAM 1.5-dev r1726 (including PyFoam, cgnstools, funkySetFields, groovyBC and simpleFunctionObjects), paraview with Takuya's OpenFOAM reader, enGrid, Open CASCADE, calculix, netgen, blender, freecad, octave, yacas. The full manifest can be found in


How do I get my fingers dirty?

There are several ways!

1) Use usb-creator-* to extract the iso onto the stick. Note that you can use other software (such as unetboot), but not all of them create the persistant storage file. Then change the boot order and reboot the machine.

2) Unpack the tgz (contains a 256 Mb persistant storage file) onto the stick and run either boot/ or boot/bootinst.bat - Just like we did with SLAX. Then change the boot order and reboot the machine.

3) Boot the iso within a VirtualBox or similar software - no persistant storage, but you should be able to mount shares and disks that you connect to the VirtualBox. Don't think anybody has tried this, yet :).

4) Make a stick using options 1 or 2 and boot it within a VirtualBox. More detailed instructions can be found here

Where do I get the iso or tgz?


OpenFOAM_kubuntu.iso (md5sum: 0ae471daf7f748f3cde7b1937ac86465)


OpenFOAM_kubuntu.tgz (md5sum: 6f8df60add546c0d390d24fc14290d7f)


A few things you should know

  • most of OF lives in in /usr/lib/OpenFOAM-1.5-dev
  • docs are in /usr/share/doc/openfoam-1.5-dev
  • tutorials are in /usr/share/doc/openfoam-1.5-dev/examples

How to test?

Please test your favorite application, not just the cavity - We have done that :). Most of the non-OpenFOAM packages have not even been started so please give them a spin.

How is it done?

The compilation is based on the Ubuntu packages which may be downloaded individually from

Best Regards,


heavy_user May 31, 2010 12:46

Hi Henrik,

where can I get the "OpenFOAM 1.5-dev r1726" version and what other files do i need to download and compile for a fully operational version?

thx & regards!

henrik May 31, 2010 16:04

Dear Heavy User,

1. You need usb-creator-* or similar to make a bootable USB stick out of the iso.


2. You need nothing to make a bootable stick out og the tgz.


3. You need your favourite burning to tool to make a CD out of the iso.

For 1 and 2, please follow the instructions written down here:


heavy_user June 1, 2010 08:05

Hi Henrik,

thanks for your quick reply!

Unfortunately I have a notebook with only one usb-port.
So I want to install the exact same version of OF on the suse 11.1 on that notebook.
(and NOT boot from usb-device)

I mounted the image and could not find the OF-source files.
So how can I install the exact same version of OF from the stick on a my notebook ?

thx & regards

henrik June 1, 2010 08:19

Dear Heavy User,

the easiest solution to your problem is to install (k)ubuntu on your second laptop and add the openfoam packages and their dependencies

For OpenSuse, you need to compile from source, which can be checked out from sourceforge:


svn co -r 1726
Sorry, no rpm-packages, yet.


heavy_user June 1, 2010 09:26

Hi Henrik,

thx again!

I downloaded it. Is it 64-Bit or 32-Bit?

So I assume i can just download the Thirdparty-package ( eg. here: ) and /Allwmake it?
Does the Thirdparty-package have to be 64-bit or 32-Bit ?


Hasselhoff June 2, 2010 04:27

Open Cascade
..not relevant..

heavy_user June 2, 2010 08:08

Hi There,

i tried to compile the OF-1.5-dev i downloaded from the link above..
It is not working... I messed around with the but I just cant make it fly.

Has anyone compiled this version from source yet?


francesco June 30, 2010 03:30


I tried the USB stick distributed at the workshop (thank you very much, very good job) in a VirtualBox and everything was fine. Then I tried to redo the job with the tgz file from SourceFourge and it indicates "Boot error" when I try to launch it. Everything was done on the computer of one of my colleague and it works fine when he tried to directly boot on the stick.

It would be fine too if I could directly boot on it but unfortunately, I am on a Mac. Is there any difference between the version distributed at the workshop and the one on SourceForge? Can anyone understand what's happening here?

Thank you for your help.

Francesco Contino

cgoniva July 7, 2010 08:31

Dear all!

I tried to use your kubuntu *.iso to set up a desktop pc.

The installation worked fine, but now I 'm facing troubles when trying to install other software.
It complains about the permissions in the /tmp/ directory???

Thank you in advance for your help!

cgoniva July 8, 2010 08:48

Problem solved...

it was related to Salome's Install script.


semo July 10, 2010 19:34

installation of openfoam on kubuntu

I downloaded openfoam_kubuntu.iso burned it to a DVD and installed it. It went pretty smooth but I cant find openfoam. Isnt it preinstalled? I can see and run all other programs like Paraview, Engrid, Octave etc.

If someone can explain me how to make it work or install it I will be grateful. Thanks in advance.


hani July 11, 2010 13:14

Hi Semo,

If you learn to use the environment variables you don't need to know where it is installed.

to see where it is installed.

You should be able to run everything as it is. Everything should be set up for you.


semo July 11, 2010 14:09

starting openfoam
Hello Hakan,

Thank you for your reply. You are right i don't need to know where it is installed. I just want to know how to see the interface of openfoam. I am sorry if this sounds stupid :)

Thanks ...

hani July 11, 2010 16:36

Hi Semo,

It sounds like your question was not at all about the Kubuntu distro....

There is no graphical interface to OpenFOAM, which means that you have to learn something before using it. Please have a look at the user guide, which will give you the very basics.

Good luck!

henrik July 13, 2010 06:04

Dear All,

the tgz and iso changed a few times. You can find the current SHA1 and MD5SUM in the "release notes" attached to the file.


phongstar July 22, 2010 19:30

install OpenFOAM_Kubuntu 5th Workshop
Dear All
I downloaded OpenFOAM_kubuntu.iso and burn to DVD.

I installed OpenFOAM_kubuntu to my computer. I ran the cavity in my computer. when i ran icoFOAM i didn't see any folder ( 0.1, 0.2, 0.3, 0.4, 0.5 folder). I couldn't show any picture in paraview.

But when i ran directly OpenFOAM_kubuntu on DVD, i could create 5 folder ( 0.1, 0.2, 0.3, 0.4, 0.5 folder) anh i could show any picture in cavity case.


I ran IcoFoam, it show:
phong@phong-dell:~/OpenFOAM/phong-1.5-dev/run/tutorials/incompressible/icoFoam/cavity$ icoFoam
| ========= | |
| \\ / F ield | OpenFOAM: The Open Source CFD Toolbox |
| \\ / O peration | Version: 1.5-dev |
| \\ / A nd | Revision: exported |
| \\/ M anipulation | Web: |
Exec : icoFoam
Date : Jul 22 2010
Time : 15:15:33
Host : phong-dell
PID : 2092
Case : /home/phong/OpenFOAM/phong-1.5-dev/run/tutorials/incompressible/icoFoam/cavity
nProcs : 1

// * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * //
Create time

Create mesh for time = 0

Reading transportProperties

Reading field p

Reading field U

Reading/calculating face flux field phi

Starting time loop

Time = 0.005

Courant Number mean: 0 max: 0 velocity magnitude: 0

Attempt to return dictionary entry as a primitive

file: /home/phong/OpenFOAM/phong-1.5-dev/run/tutorials/incompressible/icoFoam/cavity/system/fvSolution::U from line 30 to line 33.

From function ITstream& primitiveEntry::stream() const
in file db/dictionary/dictionaryEntry/dictionaryEntry.C at line 83.

FOAM aborting


Please help me!

Thankyou very much

phongstar July 26, 2010 01:56

Please help me!
anybody hear my help? please help me!
I need to solve this problem and learn how to use it fluent.
I loss too much the time to install linux and OpenFOAM. Now I install Kubuntu-OpenFOAM , i had new problem.

I wait your good new.

Thank you very much!
Best regards.


wyldckat July 26, 2010 19:27

Greetings to all,

I'm posting just to let you know that I've already answered Phong about the issue with KUbuntu + OpenFOAM-dev here:

Best regards,

PS: the Live KUbuntu + OpenFOAM-dev DVD looks very nice :)

phongstar July 29, 2010 02:02

Thank you very much, Bruno
i had check it, i continue to study it.

Best regards

All times are GMT -4. The time now is 03:17.