CFD Online Discussion Forums

CFD Online Discussion Forums (https://www.cfd-online.com/Forums/)
-   OpenFOAM Installation (https://www.cfd-online.com/Forums/openfoam-installation/)
-   -   Trying to install OpenFOAM (https://www.cfd-online.com/Forums/openfoam-installation/76823-trying-install-openfoam.html)

tmbroe01 June 6, 2010 01:01

Trying to install OpenFOAM
 
I was hoping someone here could help me with a problem I'm having getting OpenFOAM to work. I'm fairly new to Linux, so it may be a simple problem, but I can't figure it out. I think I have everything downloaded and compiled that I need. I tried the example in the readme and the blockMesh and icoFoam commands worked, but when I tried paraFoam I get the following error:

/home/Tim/OpenFOAM/ThirdParty-1.6/paraview-3.6.1/platforms/linuxGcc/bin/paraview-real: error while loading shared libraries: libQtAssistantClient.so.4: cannot open shared object file: No such file or directory

I've completed the steps for compiling paraview, so I'm kind of confused as to what my problem is. I was able to locate the file in question (libQtAssistantClient.so.4) in my /usr/local/Trolltech/Qt-4.3.5/lib but when I try searching for it using find or which nothing comes up...:confused:

Any help would be greatly appreciated!

Oh, I'm also running Fedora 13 on my computer.

wyldckat June 6, 2010 06:07

Greetings tmbroe01 and welcome to the forum!

The library libQtAssistantClient.so.4 is part of Qt's development tools. If you built and installed Qt 4.3.5 by yourself, instead of using the makeQt script available in the ThridParty folder, then there should be an option for also building the tools.

Personally I always use the makeQt script, because it was configured by OpenCFD to work with OpenFOAM's ParaView 3.6.1.

If you want detailed instructions on a way to use the script and build ParaView with it, here is a thread dedicated to it: New user needs help
Takes a little while to go through the whole thread, but at least it already has solutions to some possible obstacles you might come across ;)

Best regards,
Bruno

edit: the forum hasn't accepted properly my response... lets try bumping it back into place...

wyldckat June 6, 2010 08:31

edit: bump successful :) it was just a quote of my previous post...

tmbroe01 June 6, 2010 21:58

Hey, thanks a lot wyldcat. I had to modify the settings.sh file with the changes you posted in that thread. Worked like a charm after that. :)


All times are GMT -4. The time now is 14:24.