CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM Installation (
-   -   icoFoam: command not found (

nakor June 29, 2010 12:58

icoFoam: command not found
I have a problem with my installation of openFoam.
I follow the instructions from

So in the part User configuration, I open the .bashrc file by using

gedit ~/bashrc
And I put "/opt/openfoam170/etc/bashrc " at the bottom of the file (which is empty, is that all right ?). And I save the file.

But when I try

icoFoam -help
I have the following error message, "icoFoam: command not found".

Do you know what the problem is ? I am quite sure that the path to my OpenFOAM directory is right, but, I am not sure that I am using the right bashrc file..


wyldckat June 29, 2010 13:30

Greetings nakor and welcome to the forum!

OK, you missed two dots in the setup process:
  1. .bashrc has a dot before it:

    gedit ~/.bashrc
  2. Sourcing OpenFOAM's bashrc file also needs a dot, but with a space between the path and the dot:

    . /opt/openfoam170/etc/bashrc
Now open a new terminal and voilá, you are ready to foam! :)

Best regards,

nakor June 29, 2010 13:37

oh my bad. everything is working with both dot.
Thanks for your help.

SilentRunner July 1, 2010 17:13

icoFoam: command not found - continued
I'm also having the same problem. However, I've followed the instructions to the letter (including dots etc), but I still get "Command not found".
I'm not only new to OpenFoam but also Ubuntu (both just installed) so you can't be more newbee than me!
I've got through the installation and editted the bashrc file. I notice that this file was not empty when I opened it (from home/nigel).

Any step-by-step "idiots guide" would be extremely helpful.:confused:

gwierink July 2, 2010 03:57

Hi Nigel,

~/.bashrc is supposed to have some stuff in it, so that's ok. Did you add the correct line in ~/.basrc? (with a dot and a space as well)


. $HOME/OpenFOAM/OpenFOAM-1.6/etc/bashrc
(or 1.7 or whatever version you use of course ...)

SilentRunner July 2, 2010 17:19

icoFoam: command not found - continued
Thanks for your help. Yes I added in each of the following separately and tested them separately (with dots/spaces):

. $HOME/OpenFOAM/OpenFOAM-1.7/etc/bashrc
. $HOME/OpenFOAM/OpenFOAM-170/etc/bashrc
. $HOME/OpenFOAM/OpenFOAM-1.70/etc/bashrc
. $HOME/OpenFOAM/OpenFOAM170/etc/bashrc
. /opt/openfoam170/etc/bashrc

but still the same problem of "command not found" when typing "icoFOAM - help"
(I've installed version 1.70).
I must be doing something seriously daft, but as I say I'm new to Ubuntu and OpenFoam...
Any other pointers or ABC guide would be great!

wyldckat July 2, 2010 19:15

Greetings Nigel,

Uhm... but it doesn't get any simpler than following the official installation instructions:

And another thing: it's icoFoam, not icoFOAM!! In Linux letter case in files and folders is almost as important as your own life :p Remember that:

With great power comes great responsibility.
And for many people, Linux is waaaay more powerful than Windows - although in essence, digitally it's possible to do anything... that isn't physical!

Working with Linux teaches you a valuable lesson: be very cautious with what you type, because one wrong letter case, one wrong digit or one dot in the wrong place, and PUFF... you will just get a GIGO (Garbage In - Garbage Out) ;) And the same goes for CFD :cool:

So, my advice is to follow the instructions again and very closely! You will need to learn to be very focused when using OpenFOAM. It will mostly be text based control and editing; only post processing will likely be graphical via ParaView.
That's one of the reasons (at least I think it is) why OpenCFD lays out a tutorial explaining how to use it, and doesn't simply post a install script and tell people to "click here to install" ;) And this Ubuntu packaging system is already a big step in the right direction for new users, because with OpenFOAM 1.6 it wasn't this easy!!

Best regards and good luck!

SilentRunner July 3, 2010 10:09

icoFoam: command not found
DOH! :eek:
It had installed fine, but as you say I tried "icoFOAM -help" whereas it should have been "icoFoam -help". It confused me though because the software is called "OpenFOAM"...

Thanks for your advice. Now down to the tutorial...:D

colinB August 27, 2010 05:48

Hi all,
I just also tried to install OF but for some reason i got stuck.
Installation went alright so far but when it comes to the configuration there seams to be something wrong.
May be I should mention first ( I don't know how important that is ) that OF is not installed in my Home-folder but in a folder that is superior to Home called opt.

So I'm now in this superior folder typing


colin@colin:/$gedit ~/.bashrc
getting a non OF file without the typical header of OF
and the last lines are:

if [ -f /etc/bash_completion ] && ! shopt -oq posix; then
    . /etc/bash_completion

after that I'm typing the required line:

. /opt/openfoam171/etc/bashrc
I now save and exit gedit
and type the line:

. ~/.bashrc
no failure message or so on then I'm opening an other terminal getting an initial failure message:


bash: opt/openfoam171/etc/bashrc: No such file or directory
and consequently icoFoam -help results in a command not found

an other thing to mention when I open the terminal I'm in the directory


which is root/home/colin not like openfoam which is

I hope you can help me

gwierink August 27, 2010 06:56

Hi Colin,

Are you sure you wrote ". /opt/openfoam171/etc/bashrc" correctly, because the bash error says it can't find "opt/openfoam171/etc/bashrc" instead of that it can't find "/opt/openfoam171/etc/bashrc"?

colinB August 27, 2010 07:20

yep my fault it was exactly what you mention!
I need to learn to read more closely!
sry for the inconveniences

inf.vish January 21, 2014 05:19

Still Getting the samething icoFoam: command not found
followed all the ways mentioned in '' and also tried all the possible ways online including CFD online threads, but still getting the samething icoFoam: command not found

wyldckat January 21, 2014 16:26

Greetings Vishal,

OK, not much to work with, so I'll ask several questions, in an attempt to help diagnose the problem:
  1. Which Ubuntu version are you using?
  2. And which architecture? You can see which one it is by running:

    uname -m
  3. What does this command give you:

    cat /etc/apt/sources.list.d/openfoam.list
  4. Does this command give you any error messages:

    sudo apt-get update
  5. Did this command give you any error messages:

    sudo apt-get install openfoam222
  6. What does this command give you:

    ls -l /opt/openfoam222/etc/bashrc
  7. What do these two commands give you:

    source /opt/openfoam222/etc/bashrc
    echo $WM_PROJECT_DIR

Best regards,

inf.vish January 22, 2014 01:30

Dear Bruno,

first of all Thanks for your quick response
now the answers are as follows
1) ububtu version :: 12.04 LTS
2) Architecture :: x86_64
3) system response for the command:: << cat /etc/apt/sources.list.d/openfoam.list >>

deb precise main

4) no error message for the command :: << sudo apt-get update >>
but ya, the following message appears in last three lines

W: Duplicate sources.list entry precise/main amd64 Packages (/var/lib/apt/lists/www.openfoam.org_download_ubuntu_dists_precise_mai n_binary-amd64_Packages)
W: Duplicate sources.list entry precise/main i386 Packages (/var/lib/apt/lists/www.openfoam.org_download_ubuntu_dists_precise_mai n_binary-i386_Packages)
W: You may want to run apt-get update to correct these problems

5) no error message for the command << sudo apt-get install openfoam222 >>
but i guess you may like to see the system response, <here it is shown>

Reading package lists... Done
Building dependency tree
Reading state information... Done
openfoam222 is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 207 not upgraded.

6) response for the command << ls -l /opt/openfoam222/etc/bashrc >>

-rw-r--r-- 1 root root 7322 Jan 22 10:11 /opt/openfoam222/etc/bashrc

7) the response for the commands << source /opt/openfoam222/etc/bashrc
echo $WM_PROJECT_DIR >> is as follows


waiting again for your quick response
Thanks Again Bruno !!!!

wyldckat January 22, 2014 19:30

Hi Vishal,


Originally Posted by inf.vish (Post 471155)
7) the response for the commands << source /opt/openfoam222/etc/bashrc
echo $WM_PROJECT_DIR >> is as follows


OK, this last one tells the crucial piece of information. It seems that you already have at least one another version of OpenFOAM installed in your system, but is installed somewhere inside the folder " /home/eatin/OpenFOAM/".

If you need more than one version, please check these instructions: - namely section 2.2

If you only need one version, edit the file "~/.bashrc" and remove any references to the other OpenFOAM versions, or at least comment them out. Then start a new terminal and then do again step #7 from my previous post.

Best regards,

PS: In my signature, there is this link: Posting code and output with [CODE] - it explains how to post code, so that you wouldn't need to use the "<<>>" for isolating the code in question. ;)

inf.vish January 23, 2014 02:20

Hi Bruno,

eatin@EAT-Standalone:~$ echo $WM_PROJECT_DIR

after following the instructions given in the link, this is the response I got from system

thanks and regards,

inf.vish January 23, 2014 04:10

4 Attachment(s)
Hi Bruno,

Last date of project is very early, hence I tried to remove all the files manually and again freshly installed OF-2.2.2, but this time am facing the problem with paraview. ( Apply button is not working )

I have reinstalled paraview thrice but still the same issue. screenshots are attached for your convinience.

Bruno, I am afraid if my boss will kick my ass. :D
Awaiting a quick help from your side.

Thanks and Regards,

wyldckat January 23, 2014 18:43

Hi Vishal,

OpenFOAM and Linux is all about the details. If you fail to see one very small detail, whatever it is, it will not give you the correct results. ;)

What I meant was for you to run the two command lines again, not just the last one:

source /opt/openfoam222/etc/bashrc

As for the images, it looks like you're trying to use OpenFOAM as "root". Please, do not use OpenFOAM in root mode. Run this command to exit from root mode:

To know if you are in "root" mode, run:

It should tell you your user name; but if it says "root", then you're in root mode.

Running gedit from the command line, sometimes does not work as good in Ubuntu as it did a few years ago. Use instead this command:

gnome-text-editor ~/.bashrc
And make sure you are not in root mode.

Best regards,

inf.vish January 24, 2014 00:25

3 Attachment(s)
Hi Bruno,

OF-221 was installed in root mode by ex-employee. i am new in the office and since first day OF was not working fine. hence, after trying all the ways i reinstalled it in root mode:). now atleast i am able to see some GUI:D.

With all due respect I would like to tell you that i have followed all the instruction given by you and got the following ((images are attached)). I am also attaching the screenShot of 'bashrc' file.

Thanks and Regards,

wyldckat January 24, 2014 19:01

Hi Vishal,

OK, from the looks of it, I think that if you start a new terminal now, OpenFOAM 2.2.2 should work as intended. Try running:

icoFoam -help
If it tells you about the options for using icoFoam, then you should now be able to follow the OpenFOAM User Guide without any problems:

As for what you are seeing at the end of the file "~/.bashrc", you can find a somewhat detailed explanation here:

Best regards,

All times are GMT -4. The time now is 21:24.