CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM Installation (
-   -   OF 1.7.0/CentOS/paraFoam installation problems (

bhh July 9, 2010 04:14

OF 1.7.0/CentOS/paraFoam installation problems

Following the successfull installation of OF1.7.0 on my 32 bit CentOS linux computer I have now moved over to install paraFoam. The following error comes at the very end after the command ./makeParaView:
Linking CXX executable ../../../../bin/GraphicsCxxTests
../../../../bin/ undefined reference to `QPainter::drawImage(QPointF const&, QImage const&)'
../../../../bin/ undefined reference to `QTextDocument::setDocumentMargin(double)'
collect2: ld returned 1 exit status
make[2]: *** [bin/GraphicsCxxTests] Error 1
make[1]: *** [VTK/Graphics/Testing/Cxx/CMakeFiles/GraphicsCxxTests.dir/all] Error 2
make: *** [all] Error 2
Installation complete for paraview-3.8.0
Set environment variables:

export ParaView_DIR=/home/user/OpenFOAM/ThirdParty-1.7.0/platforms/linuxGcc/paraview-3.8.0
export PATH=$ParaView_DIR/bin:$PATH
export PV_PLUGIN_PATH=$FOAM_LIBBIN/paraview-3.8


Anybody out there that migth help me?


wyldckat July 9, 2010 08:07

Greetings Bjorn,

I've seen people post about this issue for a while now with ParaView 3.8.0. I've had it with ParaView 3.6.1 in Ubuntu, but right now I don't remember what exact packages were missing nor do I have the time to build ParaView :(

So, please run it again like so:

./makeParaView > buildParaView.log 2>&1
Then compress it:

tar -cjf buildParaView.tar.bz2 buildParaView.log
Then please post the file buildParaView.tar.bz2 or a link to it...
  • the first errors are indicative of what went wrong;
  • the final errors only are indicative that something went wrong;
  • And near the beginning, there might be clues as to what's missing! :D

Best regards,

bhh July 9, 2010 09:00

1 Attachment(s)
Hi Bruno,
Attached is the file you requested. Can you find out what is wrong?

wyldckat July 9, 2010 10:45

Hi Bjorn,

I had hopes that the whole log would give some light on the problem... but ironically it still points out to the same error :(

OK, I haven't tried this yet, but based on my experience, these are some of possible solutions:
  • Install Qt 4.6.x (doesn't matter which one, as long it's 4.6).
  • Install cmake 2.6.4, if you are using 2.8.0.
Other than this, I can only infer new possible solutions based on the results of these tests!

Additionally, there is one thread that can help you build ParaView 3.8.0, by basing yourself on the instructions for ParaView 3.6.1 + Qt 4.3.5. The thread is this one: New user needs help

Another possibility, in case you don't to waste more time trying to build ParaView 3.8.0, is to download the pre-built official version from! There was a recent thread where I talked about this too:

Best regards,

tcarrigan July 9, 2010 19:30

I had similar problems with OpenFOAM 1.6 in CentOS 5.4. I never did resolve the issue, so I just downloaded and installed ParaView separately and used foamToVTK to convert the foam files to vtk format for ParaView and was able to postprocess the solutions just fine.

The only real difference is you can't just type 'paraFoam' and load your solutions directly into ParaView in the foam format, you have to do one more step and convert the files to vtk format then launch ParaView.

One of the reasons I like this setup is that once you install OpenFOAM and the other utilities, you don't really need to use ParaView, you can use whatever postprocessing tool you choose.

seraphlz July 13, 2010 04:42

Hi Bjorn,

I have installed the OF1.7.0 on RHEL 5.5 x86_64 system. According to the official description of source pack installation, "the ParaView-3.8.0 version supplied in ThirdParty requires cmake-2.6.4 or higher and Qt-4.5 or higher". So I downloaded and installed the cmake-2.8.2 and qt-4.6.0 from source code pack, and added the path to .bashrc as following:

export PATH=$HOME/OpenFOAM/Qt-4.6/bin:$PATH
export PATH=$HOME/OpenFOAM/cmake-2.8.2/bin:PATH

Then type ". $HOME/.bashrc" in the current terminal window. After this step, I followed exactly the step as the official description "Compiling Paraview 3.8.0 and the PV3FoamReader module":

cd $FOAM_UTILITIES/postProcessing/graphics/PV3FoamReader

Finally, I get it!

Please note that it is critical to add the path of Qt lib to the LD_LIBRARY_PATH!

Good luck!


PS. I followed the steps as using qt-everywhere-opensource-src-4.6.0.tar.gz when installing Qt-4.6, and configured Qt for installation in the $HOME/OpenFOAM/Qt-4.6 directory by using the -prefix option.

bhh July 14, 2010 05:45

Dear Zeng,

I have tried your scheme but got stuck after submitting ./configure to start installing qt:

Basic XLib functionality test failed!
You might need to modify the include and library search paths by editing
QMAKE_INCDIR_X11 and QMAKE_LIBDIR_X11 in /home/user/OpenFOAM/qt-everywhere-opensource-src-4.6.0/mkspecs/linux-g++-64.

Any idea what went wrong?


All times are GMT -4. The time now is 14:54.