CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM Installation (
-   -   Problem with paraFoam installation (

raagh77 July 13, 2010 01:50

Problem with paraFoam installation
Hi All,

I followed the instructions given in the site
to install OF 1.7 and paraFoam 3.8

when I did
<li class="itemize">cd $WM_THIRD_PARTY_DIR <li class="itemize">./Allclean
I had problems related to gmake and it was fixed by creating a symbolic link
$sudo ln -s /usr/bin/make /usr/bin/gmake
and now I did ./Allclean and the final few lines are pasted here
Done make
Installing ParaView to /opt/OpenFOAM/ThirdParty-1.7.0/platforms/linuxGcc/paraview-3.8.0
make: *** No rule to make target `install'. Stop.
Installation complete for paraview-3.8.0
Set environment variables:

export ParaView_DIR=/opt/OpenFOAM/ThirdParty-1.7.0/platforms/linuxGcc/paraview-3.8.0
export PATH=$ParaView_DIR/bin:$PATH
export PV_PLUGIN_PATH=$FOAM_LIBBIN/paraview-3.8


Now when run any solver and open paraFoam I get the following error message
created temporary 'bubbleColumn.OpenFOAM'
/opt/OpenFOAM/OpenFOAM-1.7.0/bin/paraFoam: 135: paraview: not found

and when I do which paraFoam
output points to

I am not able to fix this error.
Looking forward to seek help from you.


CAVT July 28, 2010 05:17

Usually the directory /opt and whatever is inside can be modified only as a root user. What you did seems to be that you tried installing Paraview in /opt being the normal user rather than root, Before running makeParaView become root by using "su" or "sudo" (depending on which Linux you use).
Your system thinks ParaView is installed because a path has been exported, but that path is surely empty.

raagh77 July 28, 2010 06:05

Hi Thanks for your reply..

I am the super user of the computer and I am using Ubuntu 10.04

I did sudo ./makeParaFoam
and I got the following
./makeParaView: 40: wmakeCheckPwd: not found
Error: Current directory is not $WM_THIRD_PARTY_DIR
The environment variables are inconsistent with the installation.
Check the OpenFOAM entries in your dot-files and source them.

When I did pwd output is
and when I did echo $WM_THIRD_PARTY_DIR
it points to

both being the same!

Is there any other issues related to Thirdparty PATH settings ?


wyldckat July 28, 2010 17:27

Greetings Raghu,

Originally Posted by raagh77 (Post 269119)
./makeParaView: 40: wmakeCheckPwd: not found

There are two possibilities for this to have happened:
  1. for some reason wmakeCheckPwd isn't executable. Try running:

    which wmakeCheckPwd
    If it doesn't find anything, then try checking if /opt/OpenFOAM-1.7.0/wmake/wmakeCheckPwd is executable.
  2. I've got a feeling that you only set the variable WM_THIRD_PARTY_DIR by hand. You should, while in super user/root mode, source OpenFOAM's bashrc file, like so:

    . /opt/OpenFOAM-1.7.0/etc/bashrc
    Notice the dot and space before /opt!
    Then, without leaving the super user mode, you can try running ./makeParaView in the folder /opt/ThirdParty-1.7.0.
Best regards,

raagh77 July 29, 2010 00:00

Hi Bruno,
after executing which wmakeCheckPwd it points to the following directory

Here is the part of my ~/.bashrc file

#OpenFOAM-1.7 path
. /opt/OpenFOAM/OpenFOAM-1.7.0/etc/bashrc
export FOAM_USER_APP="$WM_PROJECT_USER_DIR/applications"
export FOAM_USER_SOL="$FOAM_USER_APP/solvers"
#paraFoam 3.8 path begin
export ParaView_DIR=/opt/OpenFOAM/ThirdParty-1.7.0/platforms/linuxGcc/paraview-3.8.
export PATH=$ParaView_DIR/bin:$PATH
export PV_PLUGIN_PATH=$FOAM_LIBBIN/paraview-3.8
#paraFoam path ends
export PATH="$HOME/bin:$PATH"
export INCLUDE_PATH="$INCLUDE_PATH:/usr/include:/usr/include/c++/4.2/backward/"

Is there any changes to be made in the .bashrc file for the paraFoam path?

After these changes in the .bashrc file running ./makeParaView gives the same error message as described in my previous post. :(

wyldckat July 30, 2010 09:12

Hi Raghu,

You don't need to add these lines into ~/.bashrc:

#paraFoam 3.8 path begin
export ParaView_DIR=/opt/OpenFOAM/ThirdParty-1.7.0/platforms/linuxGcc/paraview-3.8.
export PATH=$ParaView_DIR/bin:$PATH
export PV_PLUGIN_PATH=$FOAM_LIBBIN/paraview-3.8

They are added automatically by OpenFOAM's bashrc, by sourcing the script etc/apps/paraview3/bashrc.

OK, now we need to make sure of one thing: when you say "~/.bashrc", is it "/root/.bashrc"?
The thing is this: you are trying to install OpenFOAM in /opt, which usually requires that you do all building steps in root mode. And by simply saying "~/.bashrc", it feels that you are doing half of the job in root, and the other half in normal user.

So, after you've removed those lines for ParaView, that I wrote at the start of this post, and after starting a new terminal in root mode, run this:

echo $ParaView_DIR
If it echoes the same path you had before, than the environment should be properly defined!

Now, going back to your first post: it seems that makeParaView has worked once before, but it failed to build ParaView, probably due to some missing packages. So, next you run makeParaView, do it like this:

./makeParaView > buildPV.log 2>&1
This will output all of the messages into the file buildPV.log. Check what it says after makeParaView is finished, and if it still indicates that it failed to build, then compress it and post it here!

tar -czf buildPV.tar.gz buildPV.log
Best regards,

raagh77 August 7, 2010 06:48

1 Attachment(s)
Hi Bruno

Sorry past few days I was bit away from OpenFOAM.
This weekend I got some time to explore

as you said I removed those lines in the ~/.bashrc file (i.e. /home/.bashrc).

I have attached the log file (buildPV.tar.gz) here.
Pls go through when you are free

Awaiting to ear from you.


wyldckat August 7, 2010 16:39

Hi Raghu,

Originally Posted by raagh77 (Post 270648)
I have attached the log file (buildPV.tar.gz) here.
Pls go through when you are free

My focus seems to be have been a bit off that day... I should have pointed you to the following post: - starting from post #4
There you will find what packages you need to install in Ubuntu 10.04.

Basically, from the log you posted, you are missing the Qt4 development artillery and the GLU tools. So, as I said, in that post you will find the command that will install all of the necessary packages!

Good luck!

raagh77 August 16, 2010 00:51

Solved !
Hi Bruno!

Thanks for your suggestions.
Installing the missing packages I was able to sovle the problem.

Thank you very much


All times are GMT -4. The time now is 10:07.