CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM Installation (
-   -   ParaView 3.8.0 problem on debian (

Unseen August 16, 2010 08:19

ParaView 3.8.0 problem on debian
Hello, I am trying to get ParaView 3.8.0 to compile on a debian squeeze x64 machine. OpenFoam 1.7.x compiled just fine, only Paraview produces some errors.

I use ICC 11.1.072 64bit, gcc 4.4.4, g++4.4.4, QT 4.6.3-1

There are two errors during compilation:

the first one is this:


[ 13%] Building CXX object VTK/Common/CMakeFiles/vtkCommon.dir/vtkArrayRange.cxx.o
[ 13%] Building CXX object VTK/Common/CMakeFiles/vtkCommon.dir/vtkArraySort.cxx.o
[ 13%] Building C object Utilities/hdf5/CMakeFiles/vtkhdf5.dir/H5Pdcpl.o
[ 13%] Building CXX object VTK/Common/CMakeFiles/vtkCommon.dir/vtkArrayWeights.cxx.o
[ 13%] Building C object Utilities/hdf5/CMakeFiles/vtkhdf5.dir/H5Tcommit.o
[ 13%] Building CXX object VTK/Common/CMakeFiles/vtkCommon.dir/vtkCommonInstantiator.cxx.o
[ 13%] Building C object Utilities/hdf5/CMakeFiles/vtkhdf5.dir/H5FDmpi.o
[ 13%] Building C object Utilities/hdf5/CMakeFiles/vtkhdf5.dir/H5HLdbg.o
[ 13%] Building C object Utilities/hdf5/CMakeFiles/vtkhdf5.dir/H5Pdxpl.o
[ 13%] [ 13%] Building C object Utilities/hdf5/CMakeFiles/vtkhdf5.dir/H5Tcompound.o
Building C object Utilities/hdf5/CMakeFiles/vtkhdf5.dir/H5Tinit.o
Linking C shared library ../../bin/
[ 13%] Built target vtkhdf5
Linking CXX shared library ../../bin/
[ 13%] Built target vtkCommon
make: *** [all] Error 2
Command exited with non-zero status 2
1137.95user 94.98system 2:53.98elapsed 708%CPU (0avgtext+0avgdata 1246384maxresident)k
0inputs+222464outputs (0major+15645727minor)pagefaults 0swaps
    Done make
    Installing ParaView to /home/unseen/OpenFOAM/ThirdParty-1.7.x/platforms/linux64Icc/paraview-3.8.0
[  0%] Built target vtksys
[  1%] Built target vtkzlib
[  1%] Built target vtkjpeg
[  1%] Built target vtkpng
[  1%] Built target vtkmkg3states
[  1%] Built target vtktiff
[  1%] Built target vtkexpat
[  1%] Built target vtkfreetype
[  2%] Built target vtklibxml2
[  2%] Built target vtkDICOMParser
[  2%] Built target ProcessShader-real
Scanning dependencies of target ProcessShader
[  2%] Building C object VTK/Utilities/MaterialLibrary/CMakeFiles/ProcessShader.dir/ProcessShader-forward.c.o
Linking C executable ../../../bin/ProcessShader
[  2%] Built target ProcessShader
Scanning dependencies of target vtkMaterialLibraryConfiguredFiles
[  2%] Generating vtkGLSLShaderLibrary.h
-- Generate module: TestAppVarFrag
-- Generate module: TestVertex
-- Generate module: TestVtkPropertyFrag

it continues from this starting at 0% again until it reaches the documentation:


[100%] Building CXX object Plugins/AnalyzeNIfTIReaderWriter/CMakeFiles/NIfTIWriter.dir/NIfTIWriterInit.cxx.o
[100%] Building CXX object Plugins/AnalyzeNIfTIReaderWriter/CMakeFiles/NIfTIWriter.dir/vtkSMNIfTIWriterInstantiator.cxx.o
[100%] Building CXX object Plugins/AnalyzeNIfTIReaderWriter/CMakeFiles/NIfTIWriter.dir/NIfTIWriter_Plugin.cxx.o
[100%] Building CXX object Plugins/AnalyzeNIfTIReaderWriter/CMakeFiles/NIfTIWriter.dir/moc_NIfTIWriter_Plugin.cxx.o
Linking CXX shared library ../../bin/
[100%] Built target NIfTIWriter
[100%] Built target GenerateParaViewQHP
[100%] Compiling Qt help project paraview.qhp
/bin/sh: QT_HELP_GENERATOR-NOTFOUND: not found
make[2]: *** [Documentation/paraview.qch] Error 127
make[1]: *** [Documentation/CMakeFiles/ParaViewOnlineHelp.dir/all] Error 2
make: *** [all] Error 2
    Installation complete for paraview-3.8.0
    Set environment variables:

        export ParaView_DIR=/home/unseen/OpenFOAM/ThirdParty-1.7.x/platforms/linux64Icc/paraview-3.8.0
        export PATH=$ParaView_DIR/bin:$PATH
        export PV_PLUGIN_PATH=$FOAM_LIBBIN/paraview-3.8


I can't find what I am doing wrong. I used to compile OF1.6.x and Paraview 3.6.1 on debian lenny and it always worked. Here I did it exactly the same way, installed the same packages etc... Maybe I need some additional package now, which I didn't need with the older versions?

Any help would be greatly appreciated, thanks :)

wyldckat August 16, 2010 08:39

Greetings Unseen,

OK, as for the last error, it's because Qt is split into multiple packages. So, nowadays, by what I've seen from multiple Linux Distros, Qt is split in:
- libqt4
- qt4-dev
- qt4-doc
- Qt4WebKit
And there should be others too, but for dedicated Qt library functionalities, like SQL and such...

Since Ubuntu derives from Debian, you can check what packages are needed in Ubuntu 10.04 and compare with the ones in Debian: Building OpenFOAM1.7.0 from source - starting from post #4

As for the first error, the text you posted is insufficient for inferring what the problem really is :( My guess is that you still have some packages missing, or that there was an error during the unpacking stage of ThirdParty-1.7.0.gtgz. Hopefully, the link I posted above will guide you to which packages are missing.

And next time you try to build ParaView, follow these steps:

Originally Posted by wyldckat (Post 269526)
So, next you run makeParaView, do it like this:

./makeParaView > buildPV.log 2>&1
This will output all of the messages into the file buildPV.log. Check what it says after makeParaView is finished, and if it still indicates that it failed to build, then compress it and post it here!

tar -czf buildPV.tar.gz  buildPV.log

Best regards,

Unseen August 16, 2010 09:01

1 Attachment(s)
Thanks for the reply.

I installed the packages from the thread you mentioned before I made the initial post, and the errors happened nevertheless. I had most of them already since I knew I need them from my previous experience with the older debian and OF.

I figured the missing qt package is this one, but I had it installed all the time:

I checked synaptics and the other QT packages you mentioned are installed.

The ThirdParty-1.7 compiled without errors.

I'll post the log once the compilation is done.

wyldckat August 16, 2010 09:44

Hi Unseen,

Debian Lenny (and Squeeze) seems to keep qmake on a separate package: qt4-qmake.
Without it, the contents of the package qt4-dev-tools isn't visible to makeParaView nor cmake. For example, the last error you had was because this file wasn't visible:

Originally Posted by

Best regards,

Unseen August 16, 2010 10:26

Thank you for that piece of information, i think that did the trick :)

qmake was installed, but apparently some required packages from the qt4-dev-tools were missing, and reinstalling that fixed the first error (I wonder how it didn't install right the first time ...).

It's still compiling, and I will report back if it worked completely without errors.

edit: it did work, thank you :)

All times are GMT -4. The time now is 13:32.