CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM Installation (
-   -   OpenFOAM-1.7 bugs-Try to remove it (

watashiwa August 17, 2010 22:20

OpenFOAM-1.7 bugs-Try to remove it

I'm a Ubuntu noobie and newbie. My OpenFOAM-1.7 (Ubuntu 10.04) seems to gone crazy, I couldn't press Apply button in the paraView. It happened few days back and my research is halted at the moment.

Should I completely remove OpenFOAM? or there is better way to solve it.

I would rather remove it and install fresh 1. And how to do I remove the OpenFOAM? What are command to type in ?

PLease help me. THAnk you

wyldckat August 18, 2010 06:37

Greetings watashiwa,


Originally Posted by watashiwa (Post 271804)
My OpenFOAM-1.7 (Ubuntu 10.04) seems to gone crazy, I couldn't press Apply button in the paraView.

OK, lets go through this step by step:
  1. Is the problem associated directly to OpenFOAM, or is it just ParaView that isn't working properly?
  2. Please specify what you mean by «I couldn't press Apply button». Is the button disabled? Is it enabled, but when you press it, it doesn't do anything? Does any error message appear when starting ParaView or during execution of ParaView?
  3. Have you updated your Ubuntu installation?
I believe the only thing you might have to remove is ParaView. But only if we get to the conclusion that it really doesn't work.

There is also another thing you can try: using the built-in plugin for reading OpenFOAM cases. For that, do the following steps:
  1. Run:

    gksu gedit /opt/openfoam170/bin/paraFoam
  2. Replace every entry ".OpenFOAM" with ".foam".
  3. Now save and close the file.
Now try running paraFoam again and see if it jams up again or not.

So, the more information you can provide, the better... otherwise we are only going to be able to attempt to predict the reasons...

Best regards,

watashiwa August 18, 2010 08:56

1 Attachment(s)
Hi Bruno,

As you can see from the screenshot, the "Apply" button is unable to click. I have changed all of the .OpenFOAM ( there are only 2) to .foam based on to command you given me. Usually, when you get into paraView, you can click "Apply" button whenever you want to change something. I have no idea this things happen all of sudden.

Result -> Problem remain the same.

wyldckat August 18, 2010 09:13

Hi watashiwa,

Try removing this file: $HOME/.config/ParaView/ParaView3.8.0.ini

ParaView 3.6.1 had some quirks and 3.8.0 has a few more. Possibly something got stuck in the configuration file.

If this starts happening too often, then you better use the "big guns" and use a fix that also works for rescaling problems that might occur sooner or later: paraview 3.8 auto rescale doesn't work #6

Best regards,

watashiwa August 18, 2010 09:40

Hi wyldckat,

It works now. Thank you so much.

Yeah, it doesn't seems as good as before.
DO you know any link where I can read on completely remove the OpenFoam as you have posted before.

Thank you so much.

wyldckat August 18, 2010 09:51

I'm glad it worked! The problem you have experienced isn't OpenFOAM's fault, it's ParaView's fault...

Anyway, the installation/removal in Ubuntu is pretty straight forward, once the repository address has been added:
  • To install:

    sudo apt-get install openfoam170 paraviewopenfoam380
  • To uninstall:

    sudo apt-get remove openfoam170 paraviewopenfoam380
  • To uninstall everything that is visible about these packages (i.e., configuration files):

    sudo apt-get purge openfoam170 paraviewopenfoam380
Or start Synaptic from the menu "System->Administration->Synaptic Package Manager", search for "openfoam" or "paraview", and remove/install using the mouse.

Don't forget to remove the line you added to the end of "~/.bashrc":

gedit ~/.bashrc
If you want to install from source in Ubuntu 10.04, here is a thread with the lists of packages usually needed: Building OpenFOAM1.7.0 from source post #4 and onward

Best regards,

shravan471 November 12, 2014 17:46

How to uninstall just the paraview? can I get any code to UNINSTALL just the PARAVIEW

wyldckat November 16, 2014 17:49

Greetings shravan and welcome to the forum!


Originally Posted by shravan471 (Post 518841)
How to uninstall just the paraview? can I get any code to UNINSTALL just the PARAVIEW

Without knowing how you installed it in the first place, it's a bit complicated to be able to give you the correct answer.

For example, using the previous post as an example, if you had used this command to install ParaView:

sudo apt-get install openfoam170 paraviewopenfoam380
You could simply use this one to remove only ParaView:

sudo apt-get remove paraviewopenfoam380
Best regards,

shravan471 November 17, 2014 18:47

Hi I am new to this OpenFoam, I have installed openfoam from this link .. I did not install paraview separately.. now my paraview is not working in the openfoam, So how can i reinstall my paraview?

I have ubuntu 12.10 package in my system

wyldckat November 18, 2014 17:40

Quick answer - try running these commands:

sudo apt-get purge paraviewopenfoam410

sudo apt-get install paraviewopenfoam410

All times are GMT -4. The time now is 12:01.