CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM Installation (
-   -   make: Target `application' not remade because of errors. (

maysmech August 25, 2010 14:15

make: Target `application' not remade because of errors.
1 Attachment(s)
Dear Foamers,
i tried to install Of1.7.0 on Ubuntu 10.04.

after typing ./Allwmake and after more than 3 hours this message is appeared:

make: Target `application' not remade because of errors.
but by typing foamInstallationTest no error is detected. what is the problem?

make.log file is attached.

Thanks in advance

wyldckat August 25, 2010 16:16

Greetings Maysam,

The problem is related to a missing X11 header file, which leads to only foamToTecplot360 not being built.

A list of packages for Ubuntu 10.04 and OpenFOAM 1.7 is available here:
If you use the command line given at that post, and then run Allwmake again, you should no longer have any problems :)

Now, I will answer to your other thread shortly...

Best regards,

maysmech August 25, 2010 17:32

foamToTecplot360 problem is solved by your guides.
Thank you very much

Sale November 4, 2010 07:02

1 Attachment(s)
Dear Bruno,
I am new to linux and I am trying to install OpenFOAM1.7.1 on RedHat 5.5.

With the foamInstallationTest no error is detected, but when I execute ./Allwmake , I have this error:

make: Target `application' not remade because of errors.
I attached also the make.log file.

Can you help me, please?

Thanks in advance

wyldckat November 4, 2010 19:31

Greetings Sale,

Mmm, this is a bit odd... OK, there are three possibilities that I can image about this problem:
  1. Links were unpacked from the OpenFOAM 1.7.1 source package. Try running this:

    rm -rf src/OpenFOAM/lnInclude

    And run Allwmake again.
  2. Which gcc version are you using?

    gcc --version
    Is it at least 4.3.1?
  3. If neither of the above are the problem, then one or more files weren't properly unpacked. It happens once in a while, although it shouldn't happen at all.
    If this is the case, try this:

    rm -rf OpenFOAM-1.7.1/src/OpenFOAM
    tar -xzf OpenFOAM-1.7.1.gtgz OpenFOAM-1.7.1/src/OpenFOAM

    If I'm not mistaken, these commands will remove the current OpenFOAM library and unpack the original one from the downloaded package. You can run Allwmake once again.
By the way, have you tried CentFOAM?

Best regards,

Sale November 5, 2010 10:39

Dear Bruno,

thank you for your reply, but no of your suggestions worked. However I tried CentFOAM and it works!:)

Now I am trying to instal ParaView, so I downloaded qt-x11-opensource-src-4.3.5.tar.bz2 , I unpacked it with:

tar -xjf qt-x11-opensource-src-4.3.5.tar.bz2

then I run:

but the answer is:
bash: ./makeQt: No such file or directory

What's the problem?

Thanks in advance!

wyldckat November 5, 2010 11:05

Hi Sale,

If CentFOAM is working, then you should also be able to install ParaView that comes with it as well!

Best regards,

kathrin_kissling November 5, 2010 11:29

Hi Sale,

have a look at

Maybe you need the Path to Qt4.3.5 by


(this was somewhere on the forum as well but I cannot remember where, sorry)

For me it worked perfectly...

Hope this helps


Sale November 5, 2010 12:24

if I follow OpenFoam example:

mkdir -p $FOAM_RUN
cd $FOAM_RUN/tutorials/incompressible/icoFoam/cavity

everything looks ok, but then, with paraFoam, the result is:
/home/openfoam/OpenFOAM/OpenFOAM-1.7.0/bin/paraFoam: line 132: paraview: command not found

I supposed Paraview is not installed. What do I have to do?

what do you mean with:

Maybe you need the Path to Qt4.3.5 by
PATH=...whereeverItIs/Qt4.3.5/bin:$Paraview3.3 ?

Should I add this path to the bashrc file that is in /etc?

Thank you both for the quick answer.


Sale November 5, 2010 12:30


qmake --version

gives me

bash: qmake: command not found

wyldckat November 6, 2010 06:19

Hi Sale,

How exactly did you install CentFOAM? If you used the install script:

Originally Posted by
I've made a bash script which makes installation much easier
The usage is


./centFOAMInstall yum|OF17|paraview|Netgen|Engrid|Gmsh|all|help
The options are pretty much self explaining except "all" which installs OpenFOAM, Paraview, Netgen, Engrid and gmsh. The script will prompt the user for installation directory and check whether this is writable.

Then it should have been as easy as running:

./centFOAMInstall paraview
Best regards,

All times are GMT -4. The time now is 19:48.