CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM Installation (
-   -   Paraview 3.8 on Ubuntu 10.10 (qt 4.7) (

lindner September 20, 2010 04:05

Paraview 3.8 on Ubuntu 10.10 (qt 4.7)
Hi, i compiled OpenFoam sucessfully on ubuntu 10.10, but paraview is not building.
The error is easy to understand


CMake Warning at CMakeLists.txt:105 (MESSAGE):
  Warning: You are using Qt 4.7.0.  Officially supported version is Qt 4.6

CMake Error: The following variables are used in this project, but they are set to NOTFOUND.
Please set them or make sure they are set and tested correctly in the CMake files:
  used as include directory in directory /home/lindner/OpenFOAM/ThirdParty-1.7.x/paraview-3.8.0/Qt/ApplicationComponents

make: *** No targets specified and no makefile found.  Stop.
Command exited with non-zero status 2
0.00user 0.00system 0:00.00elapsed 0%CPU (0avgtext+0avgdata 4400maxresident)k
0inputs+0outputs (0major+328minor)pagefaults 0swaps
make: *** No rule to make target `install'.  Stop.

Is there a fix to this or i have to downgrade my qt to 4.6?


lindner September 20, 2010 04:28

Another question,
Will the paraview installed via apt-get have the same features as the one compiled from ThirdParty?

I installed and it seems to be working fine, but i don't know if i will find some problems in the future.


akidess September 20, 2010 07:09

Old paraview versions used to lack an OpenFoam plugin to view results without converting them to VTK. Paraview 3.8 now has a native OpenFoam reader, so I don't think it will have any negative side effect using the repository version.

lindner September 20, 2010 08:07

Yes, the overall behavior of OpenFoam seems ok like you said.
The only problem now is with the particles. While opening the VTK files the only option is Legacy VTK files, and it gives me the following error:


ERROR: In /build/buildd/paraview-3.8.1/Servers/ServerManager/vtkSMWriterFactory.cxx, line 337
vtkSMWriterFactory (0xf74580): No matching writer found.

Failed to create writer for:  "/home/lindner/OpenFOAM/lindner-1.7.x/run/Annex20/particulas/VTK/lagrangian/kinematicCloud/kinematicCloud_..vtk"

And i got the VTK files using the FoamToVTK. So there is something im missing from the paraview compiled for openfoam.

wyldckat September 25, 2010 15:18

Greetings to all!

Guilherme, what Anton meant is to use the internal reader to open OpenFOAM cases. Namely:

Originally Posted by
Open the file "$HOME/OpenFOAM/OpenFOAM-1.7.0/bin/paraFoam" in your favorite simple text editor and replace every entry ".OpenFOAM" with ".foam". Now save and close the file.

Then run paraFoam in your case folder and voilá, you should now have full post-processing capabilities, straight from the case files and without having to run foamToVTK before opening ParaView.

Best regards,

anon_i October 11, 2010 03:25

Hi Lindner, Hi all,

I am having the same problem that you stated in your first post (but with an Arch Linux distribution, cmake 2.8.2, qt 4.7.0). Has anyone found a solution to it yet?

Best regards,

PS: Officially supported is qt 4.6 - is there any, like 'compatibility option' for compiling?

anon_i October 11, 2010 08:32

Ok, solved for me. Workaround was:

- downgrade to qt-4.6.3
- compile & install
- upgrade to qt-4.7 again.


alvin11 October 11, 2010 23:28

maybe you should install the libqt-devel plugin

when I am installing the ParaView 3.8, I have a similar problem,

so I install the libqtwebkit-devel, its done

simulant007 October 19, 2011 07:28

Paraview 3.8 on Fedora 15 Qt 4.7
Had the problem with NOTFOUND QT_QTASSISTANTCLIENT_INCLUDE_DIR (ADVANCED) on Fedora 15. Installing qt-webkit, qt-assistant, qt-assistant-adp and qt-assistant-adp-devel has solved the problem for me
Additionally I had to run:
sed -i -e 's=ptrdiff_t=std::ptrdiff_t=' paraview-3.8.0/VTK/Utilities/vtkmetaio/metaUtils.cxx
to get Paraview compiled
and had linked /usr/bin/qmake-qt4 to /usr/bin/qmake

Thanks to the input from this forum

wchao.csu June 16, 2012 22:10


Originally Posted by grandtheft (Post 278676)
Ok, solved for me. Workaround was:

- downgrade to qt-4.6.3
- compile & install
- upgrade to qt-4.7 again.


Hi there,

Can you show me more details about how to downgrade to qt-4.6.3. I am quite new to Linux(ubuntu). I met the same problem. Thank you in advance.

anon_i June 17, 2012 06:28


well, the process would be to uninstall the installed version using


sudo apt-get remove [installed version package name]
if you don't know the exact package name, find it by doing


dpkg --get-selections | grep libqt
Then, find the required package on a trusted source on the internet, e.g. sa a .deb-package on the ubunto websites and install it using


dpkg -i [package.deb]
Then compile openfoam stuff.

Afterwards, remove the older package that was required to compile openfoam


dpkg -r [package]
and re-install the version from the ubunto repositories


sudo apt-get install [package name from the beginning / recent version from repos]
That'd be it. Problems are
a) this is a workaround, not a solution
b) it would be better to fix the package requirement in the openfoam/parafoam sources
c) my post from above, and the incident when it worked is now over half a year ago. Maybe the sources on are updated and you don't even need that fix anymore. So watch out for changes.

I don't know if it is relevant here, but when building openfoam on OpenSuSE recently (openfoam provides precompiled rpm packages for OpenSuSE 12.1 btw.), I found this website very helpful:

I hope this helps,

PS: Before typing all the commands I posted above, I recommend you try to find out what they really do, especially if you want to get to know the debian package manager apt better. You can either browse the web for that or use "man [command]" to display the manual page for the given command.

All times are GMT -4. The time now is 05:43.