CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM Installation (
-   -   errors during compilation and installation of OpenFOAM-1.7.x on Ubuntu 10.04 (

ftec November 11, 2010 08:05

errors during compilation and installation of OpenFOAM-1.7.x on Ubuntu 10.04
4 Attachment(s)
Hey guys,

I'm new to this forum, and i hope, this is the right place, to ask you for some help concerning the compilation and installation process of OpenFOAM-1.7.x on ubuntu 10.04 LTS.

I compiled OpenFOAM and paraFOAM step by step and running

showed one critical error, which said, that the path to "icoFoam" did not exist.

So after searching the forums here, i installed additional packages found here posted by wyldckat and run ./Allwmake in the app-directory again.

This time, it showed the eror:


make: Target `application' not remade because of errors.
and quit the compilation of application directory.

So i tried to follow instructions found in several forums (i.e. here:, but none seems to work.
By the way, my gcc version is over 4.3.1.

After this, i went back to run foamInstallationtest (see attachments), and this time it showed no critical errors.

So i tried to use the commands as "simpleFoam, blockMesh, paraFoam".
The only one, that was recognized by the terminal, was the command paraFoam, the others were ignored (by using tab).
Nevertheless, paraFoam is not found and cannot open, allthough it was compiled correctly i think, and i also updated my . ~/.bashrc file.
(Also you might see attachments for this.)

My questions:

It seems, that my application directory is still not compiled correctly?

Maybe I should remove the whole compiled OpenFoam folder and restart the whole process. But, how do I do that, since terminal does not want to give me permission to delete it (will it work properly by usind root rights with sudo -s?)

Is it possible, that - as i previously read somewhere in this forum - the source code thit not unpack correctly before starting the compilation? So, maybe the whole source directory is not working properly?

Do you have any other ideas, what I could do?

Additional packages previously installed were also:


binutils binutils-dev bison bisonc++ build-essential cmake cmake-curses-gui flex gcc git-core libibverbs-dev libqt4-dev qt4-dev-tools libreadline5-dev mpi-default-dev python-dev subversion wget zlib1g-dev
I did compile paraview 3.8.0 using mpi support.

I added the first log files of ./Allwmake of source and application directories in attachments too.

Please help me :)

kind regards


wyldckat November 11, 2010 12:52

Greetings Florian and welcome to the forum!

Well, I'm a bit confused by your post and attachments. They seem to contradict each other in some points... because icoFoam does seem to have built properly and to be accessible... And the log files you attached do not give any error indication.

So, lets go by parts:
  • Please run again Allwmake, but like this:

    ./Allwmake > make.log 2>&1

    This way you'll make a full log of the whole build process, including error messages.
  • As for ParaView: how exactly did you build it? Did you use makeParaView that is in the ThirdParty folder? And how do you know that you built it with success?
Best regards,

ftec November 11, 2010 15:41

1 Attachment(s)
Dear Bruno,

Thank you alot for the fast answering!:)
You already helped me alot!

I am sorry for the confusing post!

  • I did run the script you postet, and attached the log file that has been created.
Please look for the file, its seems, that there is no error this time.

I did check simple operations as


They worked all fine on some random case, i had created some other day.

I attached the log file anyways.

  • paraview:
It seems, that paraview has not been created properly indeed. I just thought, that it had been, because it gave me no error message, when i run

./makeParaView -mpi

But, Terminal still keeps telling me the following:


root@futech-laptop:~/floFOAM/pitzDaily_mittel# paraFoam
created temporary 'pitzDaily_mittel.OpenFOAM'
/home/futech/OpenFOAM/OpenFOAM-1.7.x/bin/paraFoam: 142: paraview: not found

So, it has not been created properly? At the moment, i run the following script


./makeParaView -mpi > logparaview &
and if it continues not working, I will post it to this thread.

Kind Regards


wyldckat November 11, 2010 18:52

Hi Florian,

OK, the latest log doesn't present any noticeable errors, so all seems to be ok.

As for ParaView, I should have explained something: the "2>&1" is a stream redirection (if I'm not mistaken on the terminology), which redirects the stderr output to the standard output stdout. In other words, redirects the stream 2 (error outputs) to the stream 1 (standard output). This is indicated after the redirection into make.log.
As I've shown before:

./Allwmake > make.log 2>&1
means that it redirects 1 to make.log and 2 to 1, therefore all standard output goes to make.log.

Sooo, my long explanation was just to say this - run makeParaView like this:

./makeParaView -mpi > buildPV.log 2>&1
The name buildPV.log is just a personal force of habit, so you can name it whatever you want ;)

As for errors, the usual tell tale expression is "Error ", including the space, when something goes wrong during the build of OpenFOAM or ParaView.

Good luck! Best regards,

ftec November 11, 2010 19:07

1 Attachment(s)
Hi Bruno,

Thank you again for the answer and the explanation!:)

Now I compiled paraview 3.8.0 succesfully, or so it says in the logfile I attached. Unfortunately, at the time I did not redirect the error messages to this log as you recommended in your last post.


When I open paraview by the command paraFoam, paraview cannot show the case, it does not load it, it even tells me, that there is nor reader, and i should select one.

I know, this is a common bug, but I did not find any way in this forum to solve this problem that I can reproduce with success...

What I did after compiling paraview 3.8.0:

I compiled and installed pvFoamReader by using the following code:


mkdir ~/OpenFOAM/pvFoamReader
cd ~/OpenFOAM/pvFoamReader
svn co
mv vtkPOpenFOAMReader source
ccmake source

# I let the programm ccmake find the right path automatically by typing 'c' and 'c'
# again, then 'g' to exit and save.
# By doing so, the programm searched for some paths, which seemed to be
# correct, and so I did not care any further.

make install

After the installation was complete, I changed the value of paraviewPath in the file /OpenFOAM/pvFoamReader/source/pvFoam

and in the ~/.bashrc, I simply added:


alias pvFoam=’$HOME/OpenFOAM/pvFoamReader/source/pvFoam -case $PWD’
Nevertheless, Terminal always tells me now:


futech@futech-laptop:~$ bash
bash: alias: -case: not found
bash: alias: /home/futech’: not found

I am pretty sure, that I named the right paths, so could there be any other reason for bash and paraFoam not working as they should?

Should I compile paraview 3.8.0 again by creating a logfile as you recommended, or do you see my fault by any chance?

I hope, I am not too annoying, and thank you again for the help!



wyldckat November 11, 2010 20:17

Hi Florian,

Wow, you're over-complicating it! ;)

OK, you already know that there are 2 available readers, right? The one from Takuya (that I believe you got from the SVN) and the one from OpenCFD that comes with OpenFOAM. So, in that order, I'll explain:
  1. That reader you are trying to build, is already built within ParaView, starting the version 3.8.0! The correct file extension for using that reader is ".foam". To use it by default in paraFoam, follow the instructions in the point 7 in this blog post of mine: Using the official pre-built ParaView 3.8.0 version with OpenFOAM...
  2. The official reader that comes with OpenFOAM can be built by following the instructions near the end of the page from where you followed the initial instructions:

    Originally Posted by
    The PV3blockMeshReader and the PV3FoamReader ParaView plugins are compiled as usual for OpenFOAM utilities:

    cd $FOAM_UTILITIES/postProcessing/graphics/PV3FoamReader

    Ah, almost forgot: this plugin uses the file extension ".OpenFOAM".
So there you go, the two versions of plugins are explained :D

Best regards,

ftec February 23, 2011 04:55

Hey Bruno,

I forgot to post a million thanks to you for your kind help.

After all i managed to install everything properly. It was a big mistake of mine too to install the first parts of OpenFoam Utilies as ROOT.

I added to your reputation!

Kind regards,


wyldckat February 23, 2011 07:07

Hi Florian,

You are most welcome and I'm glad I was able to help :)
And thanks for the rep points :)

Best regards,

All times are GMT -4. The time now is 19:25.