CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM Installation (
-   -   problem with User configuration (

vetnav December 11, 2010 14:47

problem with User configuration

I have installed OpenFOAM Ubuntu/Debian package on my Ubuntu linux (version 10.04). I installed it by logging in to root then I switched to a user (arunaveen) which I created by using the command "useradd". I followed the steps given in OpenFOAM website to configure the user by adding . /opt/openfoam171/etc/bashrc and saved the file. After this when I type . ~/.bashrc in the terminal I get the following output
/hom/arunaveen/.bashrc: 13: shopt: not found
/hom/arunaveen/.bashrc: 21: shopt: not found
/hom/arunaveen/.bashrc: 52: shopt: not found
/etc/bash_completion: 33: [[: not found
/etc/bash_completion: 39: [[: not found
/etc/bash_completion: 52: Bad substitution
\[\e]0;\u@\h: \w\a\]\u@\h:\w$

If I type icoFoam -help, I get
-sh: icoFoam: not found.

When I switched back into root and tried to do the same with bashrc file everything worked fine and I could see the usage message after typing "icoFoam -help"

I don't want to run the code as a root, I want to work with OpenFOAM in my user account, so could anyone please tell me what should I do.


vetnav December 11, 2010 15:37

found it
I just changed the shell type from /bin/sh to /bin/bash and I can see the usage message now in my user account also.

However, I am interested in knowing why just changing from /sh to /bash solved this problem. So please explain me.


All times are GMT -4. The time now is 01:59.