CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM Installation (
-   -   Paraview not found (

fusij January 1, 2011 20:22

Paraview not found

I have compiled OF1.5-dev and setup Paraview according to the instructions given as below (PhD course - Chalmers). When I want to run it and type paraFoam I get the following message: /OpenFOAM/OpenFOAM-1.5-dev/bin/paraFoam: 105: paraview: not found. Does someone have a solution for this problem?


Originally it would now have been time for compiling Paraview and the PV3FoamReader module, but there seems to be some problem with this, that has been discussed in the forum. For compiling Paraview, one should use the buildParaView3.3-cvs script, but there are some pieces missing. Instead we will use the pre-compiled Paraview 3.8.0, which includes a new nice reader for OpenFOAM (the instructions for this has been taken from rm -rf $ParaView_DIR
mkdir -p $ParaView_DIR
cd $ParaView_DIR
For i?86 (check if the command “uname –m” returns i686):
tar xzf ParaView-3.8.0-Linux-i686.tar.gz
mv ParaView-3.8.0-Linux-i686/* .
rmdir ParaView-3.8.0-Linux-i686
For x86_64 (check if the command “uname –m” returns x86_64):
tar xzf ParaView-3.8.0-Linux-x86_64.tar.gz
mv ParaView-3.8.0-Linux-x86_64/* .
rmdir ParaView-3.8.0-Linux-x86_64
Now open the file $HOME/OpenFOAM/OpenFOAM-1.5-dev/bin/paraFoam and change
Two additional hints from the same page:
* If your Linux installation isn't English, then you better follow these instructions: In the same paraFoam file, add the following after the first block of comments:
export LC_ALL=C
* If you are having problems with rescaling data in Paraview, you might have tripped on a now known bug in ParaView 3.8.0. To get past this, read this post (and its thread): paraview 3.8 auto rescale doesn't work #6
Time to test. In a new terminal window, type:
mkdir -p $FOAM_RUN
cp -r $FOAM_TUTORIALS/icoFoam/cavity $FOAM_RUN
cd $FOAM_RUN/cavity

wyldckat January 1, 2011 21:36

Greetings Vigfús,

OK, with the OpenFOAM's 1.5-dev environment up and running, what does this command output:

echo $ParaView_DIR
If it outputs something, then what do these output:

ls $ParaView_DIR
du -sh $ParaView_DIR

From these two lines you should get the idea of what's inside the targeted ParaView folder and how much space is being occupied by it. If it's something less than 10-30MB, then you skipped one or two steps of the tutorial.

There is also another possibility for installing ParaView for usgin with OpenFOAM, depending on which Linux Distribution and version you are using. For example, if you are using Ubuntu 10.10, you can install ParaView 3.8.1 that is available from Ubuntu's repositories:

sudo apt-get install paraview
Best regards,

PS: Wow, this is so cool :) A blog post of mine is being referenced at Chalmers, Dept of Thermo and Fluid Dynamics :D

fusij January 1, 2011 21:44

Problem is solved. The precompiled ParaView3.8 directory created was named ParaView3.3-cvs. But since ParaView_INST_DIR=$WM_THIRD_PARTY_DIR/ParaView-$ParaView_VERSION
or more specifically ParaView-3.3-cvs had nothing in it unless the linux64Gcc directory, I just moved the files under that directory in ParaView3.3-cvs to the ParaView-3.3-cvs directory. And now it works. I am not sure why there are two folders, but I followed the tutorial step by step.

Thank you Bruno for your quick answer.

All times are GMT -4. The time now is 22:47.