CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM Installation (
-   -   Problem running wmake on simpleFoam (

Greg Givogue March 1, 2011 12:50

Problem running wmake on simpleFoam
Hi Everyone!

I've corrected the KOmegaSST.C bug in 1.7.1 but am unable to recompile simpleFoam using wmake.

First I run 'touch simpleFoam.C' then...

greggivogue@ubuntu:/opt/openfoam171/applications/solvers/incompressible/simpleFoam$ wclean
greggivogue@ubuntu:/opt/openfoam171/applications/solvers/incompressible/simpleFoam$ wmake
mkdir: cannot create directory `linux64GccDPOpt': Permission denied
/bin/sh: cannot create linux64GccDPOpt/options: Directory nonexistent
make: *** [linux64GccDPOpt/options] Error 2
/opt/openfoam171/wmake/MakefileFiles:39: linux64GccDPOpt/options: No such file or directory
make: *** No rule to make target `linux64GccDPOpt/options'. Stop.
wmake error: file 'Make/linux64GccDPOpt/objectFiles' could not be created

Can someone please chime in and help me with this likely bonehead problem! I'm really stuck here. It looks like it has to do with permissions but I'm not really sure how to fix this... Thanks!

Greg Givogue March 1, 2011 13:42

Problem solved but changing permissions.

iampolaris April 23, 2011 03:59

a similar question?

Originally Posted by Greg Givogue (Post 297512)
Problem solved but changing permissions.

Hi, Greg.
I have encountered a similar problem like you, can you tell me how to change the permission and solve it?

wyldckat April 23, 2011 10:10

Greetings to both!

@iampolaris: Although I'm against modifying permissions on root folders, here is what you can do:

sudo chmod -R o+w /opt/openfoam171
This will give all users, who aren't part of the root group, write permissions to OpenFOAM's folder.

This is very dangerous, since this way anyone can damage your OpenFOAM installation. It would be advisable that after you do the tweaks you want to do, you reverse the permissions by running:

sudo chmod -R o-w /opt/openfoam171
Best regards,

Greg Givogue April 23, 2011 20:40

This is basically what I did. Good luck

All times are GMT -4. The time now is 13:30.