CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM Installation (
-   -   Installation of OpenFOAM 1.7.x on openSUSE 11.4 (

alberto March 10, 2011 04:54

Installation of OpenFOAM 1.7.x on openSUSE 11.4
OpenSUSE 11.4 is being released in these hours, and some OpenFOAM user might be curious to try it (it looks like a very promising release to me).

The installation of OpenFOAM 1.7.x is straightforward, however, paraview 3.8.0 cannot be easily compiled. I put together a few steps to be able to install ParaView 3.10.0

You will notice the steps to install paraview are clearly a temporary hack, however they did the job on openSUSE 11.4 - 64 bit.

lakeat March 10, 2011 11:40

Yeah, 11.4 is out now!

alberto March 10, 2011 15:39

Yes, and it is working well too at least here during a couple of days of testing (KDE installation).

lakeat March 11, 2011 14:24

I have installed opensuse 11.4, gnome, gnome3 and then 1.6-ext.

When installing the paraview 3.10.0, during it was still compiling the paraview, because this takes quite a long time, so I went to modify "cmake_install.cmake" file immediately.
Comment out the line witt ParaViewLibraryDepends.cmake as you have said, don't know why.

And it works now.

One smal note, the video card must be firstly installed, or paraview might not behave very correctly when trying to save the screenshot.

openfoam_user May 6, 2011 04:05


Wednesday we have installed openSUSE 11.4 (KDE installation).

I have experienced a strange thing.

If I don't comment the following 3 lines of my .cshrc file I am no more able to log in !

#setenv FOAM_INST_DIR /shared/OpenFOAM
#setenv foamDotFile $FOAM_INST_DIR/OpenFOAM-1.7.x/etc/cshrc
#if ( -f $foamDotFile ) source $foamDotFile

Has someone encountered such a problem or can give me advices to solve it ?

Until openSUSE 11.3 it was OK and openFOAM 1.7.x was running fine.!

Best regards,


openfoam_user May 6, 2011 04:56

Hi again,

Now I can log in without commenting the 3 lines of my .cshrc file.
But I have to comment the following line
set foamInstall = $HOME/$WM_PROJECT

which is located in the following file

Why ?



wyldckat May 6, 2011 15:09

Greetings Stephane,

Disclaimer: I'm not a korn shell user, so I haven't fully tested some of these commands. I'm basing myself on my experiences with bash shell.

It seems you've already done a lot of "isolate and conquer" on your shell, but have you checked if the OpenFOAM environment is activated automatically by the common profile?

In other words, I suggest doing the following steps:
  1. Create an alias for the initialization of the OpenFOAM environment; more specifically, in the file "$HOME/.cshrc" change this:

    source /shared/OpenFOAM/OpenFOAM-1.7.x/etc/cshrc
    (I oversimplified the three lines you had) Change it to this:

    alias of17x_shared='source /shared/OpenFOAM/OpenFOAM-1.7.x/etc/cshrc'
    Or in your more complex case:

    alias of17x_shared='setenv FOAM_INST_DIR /shared/OpenFOAM ; setenv foamDotFile $FOAM_INST_DIR/OpenFOAM-1.7.x/etc/cshrc ; if ( -f $foamDotFile ) source $foamDotFile'
  2. Start a new terminal.
  3. Now, check if there is an OpenFOAM environment already activated or not:

    echo $FOAM_INST_DIR
    If nothing is outputted, skip to the next point. If something is outputted, then somewhere else the environment is already being defined! So, you'll have to do some more isolate and conquer, probably on the common "profile" file.
  4. Now, when all has been cleared up, run this on your new login/shell:

    Now, it either doesn't work, or somehow logs you out or something like that... or it works and you're free to go on working with OpenFOAM :)
Either way, using alias commands gives you more control over what you want to be really activated when you want to activate it, instead of being automatic when you log in or start a new terminal!

Further than this, I would have to test my theories and do some more debugging in a korn shell... which I would very much rather not try, since my past experiences with it have been sort-of traumatic :rolleyes:

Best regards,

openfoam_user May 10, 2011 04:23

Dear Bruno,

I have redone a complete installation of OpenFOAM (OpenFOAM-1.7.x and ThirdParty-1.7.x) with openSUSE 11.4.
I have followed the steps described by Alberto:

Now it works in parallel.

Thanks Bruno and Alberto.
Best regards,


All times are GMT -4. The time now is 09:09.