CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM Installation (
-   -   OpenFOAM-1.6-ext Compilation Error (

taner May 6, 2011 08:09

OpenFOAM-1.6-ext Compilation Error
Dear all,

I've just installed OpenFOAM-1.6-ext on Ubuntu Maverick in order to test GGI for a case. I've modified the .bashrc file like:

#. /opt/openfoam171/etc/bashrc
. /usr/lib/OpenFOAM-1.6-ext/etc/bashrc

The SimpleFOAM solver is working, since the binary is available.
Trying to compile the MRFSimpleFoam solver, I got the following error:

SOURCE=MRFSimpleFoam.C ; g++ -m64 -Dlinux64 -DWM_DP -Wall -Wno-strict-aliasing -Wextra -Wno-unused-parameter -Wold-style-cast -Wnon-virtual-dtor -O3 -DNoRepository -ftemplate-depth-40 -I/usr/lib/OpenFOAM-1.6-ext/src/finiteVolume/lnInclude -I/usr/lib/OpenFOAM-1.6-ext/src/turbulenceModels -I/usr/lib/OpenFOAM-1.6-ext/src/transportModels -IlnInclude -I. -I/usr/lib/OpenFOAM-1.6-ext/src/OpenFOAM/lnInclude -I/usr/lib/OpenFOAM-1.6-ext/src/OSspecific/POSIX/lnInclude -fPIC -c $SOURCE -o Make/linux64GccDPOpt/MRFSimpleFoam.o
MRFSimpleFoam.C:34: fatal error: fvCFD.H: No such file or directory
compilation terminated.
make: *** [Make/linux64GccDPOpt/MRFSimpleFoam.o] Error 1

Does anybody have an idea what the problem is?
Why fvCFD.H cannot be found?
Something to do with environmental variables?

Thanks in advance.


lrunber May 6, 2011 09:22

Hi Taner,
You should also install the:
package, which contains the source files.

taner May 6, 2011 10:21

Hi lrunber,

perfect! Installing openfoam-1.6-ext-dev solved the problem.

Thanks a lot.


lrunber May 6, 2011 10:37

happy to have been able to help :)

nadine April 2, 2012 12:36

I am having the same error, but I am using Fedora 15. and I installed a fedora package from the OpenFoam site, so am I missing some libraries or something?

my exact error is : "C:33:19: fatal error: fvCFD.H: No such file or directory"
Thanks for your help,

wyldckat April 3, 2012 06:01

Greetings Nadine,

I'm sorry to say that your post isn't making much sense :( Because:
  1. You've posted on a thread for 1.6-ext, which is a variant of OpenFOAM, i.e., it is not the official version.
  2. You're talking about installing a "fedora package", which should imply that you don't need to compiled anything:
  3. The error you're getting implies that you are trying to compile OpenFOAM on Fedora!
  4. How exactly did you get that error?
My guess is that you are following the wrong instructions... you're probably looking for either one of these instructions:
Best regards,

nadine April 3, 2012 10:28

Hello Bruno,
Thank you for answering me in such a short time. I think I installed Openfoam correctly, so my problem isn't an installation problem.
I was trying some features of Openfoam, so I create a new simple solver, and according to the instructions I have to compile it in order to use it, and that's how I got this error saying that fvCFD.H doesn't exsist while it does!!! and my solver can't be compiled!
for informations: my solver call this finite volume libary.
Thanks again for your help :)
Best regards,

wyldckat April 3, 2012 21:04

Hi Nadine,

Without you describing what specific steps you are taking to create said new solver... I'm going to suggest that you follow this tutorial instead:

If you still have problems with this one, then it would also be useful to know if your Fedora 15 installation has been done with i686 or x86_64:

uname -m
Best regards,

nadine April 4, 2012 09:51

Hello Bruno,
I am really grateful for your continuous help!
Actually what I call a new solver was really similar to the example that you sent me but with other instructions. So by following the Wiki instructions I didn't get any error, than I tried their way for adding my solver and it worked! Now I am not getting any error any more, but I tried to find what was missing in the first method but I didn't succeed :(

Anyway to answer your question I installed OpenFoam-2.1.0 for 64 bits!

Thanks again for your Help!
Best regards,

All times are GMT -4. The time now is 07:34.