CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM Installation (
-   -   OpenFOAM-2.0.x and MVAPICH2 (

kpsl August 9, 2011 11:03

OpenFOAM-2.0.x and MVAPICH2
Dear Foamers,

I've been trying to install OF-2.0.x on a cluster running MVAPICH2.

Somehow, the install script is unable to properly locate or use the pre-installed MPI.

I get errors such as


ptscotchDecomp.C(125): catastrophic error: cannot open source file "mpi.h"
despite having set


#- MPI implementation:
#              | GAMMA | MPI | QSMPI

in the bashrc file and having added

case "$WM_MPLIB" in
export MPI_HOME=/sw/comm/mvapich2/1.5.0-gcc
_foamAddPath $MPI_ARCH_PATH/bin
_foamAddLib $MPI_ARCH_PATH/lib


I have also checked to see that the file mpi.h actually exists

ls $MPI_ARCH_PATH/include
mpi_base.mod      mpicxx.h  mpi.h    mpiof.h  mpi_sizeofs.mod  opa_primitives.h  opa_util.h
mpi_constants.mod  mpif.h    mpi.mod  mpio.h  opa_config.h    opa_queue.h      primitives

and also opened it in an editor just to be sure.

I have also tried calling my MPI implementation MPI-MVAPICH2 since I have heard that some scripts check for the presence of MPI in the name. If I do this I get the same errors about not being able to find mpi.h, however, I get these much sooner when building PStream and scotch rather early on. I have also tried both gcc and Icc with similar results.

I don't quite understand why the install script cannot find the neccessary files. Does anybody have any ideas?

wyldckat August 9, 2011 12:03

Greetings Kris,

I think you only missed one detail: in the folder wmake/rules/General you will also need a file named mplibMVAPICH2. Check the other "mplib*" files there for additional references, since you might need more than simply (the -lmpi entry) with MVAPICH2.

Best regards and good luck!

kpsl August 10, 2011 04:16

That was it!!! Three cheers for Bruno :)

wyldckat August 10, 2011 10:15

Awww, you're making me blush :) I'm glad it's working :D

Some other people haven't had such an easy success with SGI MPI :(

kpsl August 12, 2011 13:45

I did have some minor trouble with ptscotchDecomp failing to compile, but I don't plan on using it so I'm not that bothered ;)

scotth2o August 16, 2012 13:04

I just went through this exercise for a new install of OF 2.1.x and I can confirm that the “Allwmake” script in pstream does look for a “*MPI*” string in the $WM_MPLIB variable. Also my attempt to use the mplibMPICH file as a template for MVAPICH didn’t work and I had to use the link/include flags returned by mpicc -cc= -compile-info & mpicc -cc= -link-info . This might be a system specific thing. Regardless, the information provided above was very useful.

All times are GMT -4. The time now is 12:03.