CFD Online Discussion Forums

CFD Online Discussion Forums (https://www.cfd-online.com/Forums/)
-   OpenFOAM Installation (https://www.cfd-online.com/Forums/openfoam-installation/)
-   -   OF 1.6-ext and metisDecomp Problem (https://www.cfd-online.com/Forums/openfoam-installation/91842-1-6-ext-metisdecomp-problem.html)

blaise August 24, 2011 08:50

OF 1.6-ext and metisDecomp Problem
 
Hi all,

I have a problem with the installation of OF 1.6-ext. I read many pages on the forum but could not find a suitable solution, so I need to ask for help.

I cannot compile OF 1.6-ext to the end, because there is some error with the compilation of the metisDecomposition library. Here the beginning of the trouble:

----------------- snippet -------------------
+ wmake libso scotchDecomp
'/usr/local/OpenFOAM/OpenFOAM-1.6-ext/lib/linux64GccDPOpt/libscotchDecomp.so' is up to date.
+ wmake libso metisDecomp
/usr/local/OpenFOAM/ThirdParty-1.6-ext/packages/metis-5.0pre2/platforms/linux64GccDPOpt/lib/libmetis.a(kwayrefine.o): In function `__signbitf':
(.text+0x0): multiple definition of `__signbitf'
/usr/local/OpenFOAM/ThirdParty-1.6-ext/packages/metis-5.0pre2/platforms/linux64GccDPOpt/lib/libmetis.a(kmetis.o):(.text+0x0): first defined here
/usr/local/OpenFOAM/ThirdParty-1.6-ext/packages/metis-5.0pre2/platforms/linux64GccDPOpt/lib/libmetis.a(kwayrefine.o): In function `__signbit':
(.text+0x10): multiple definition of `__signbit'

... lots of similar stuff
... and later (not unexpected):

+ wmake libso parMetisDecomp
'/usr/local/OpenFOAM/OpenFOAM-1.6-ext/lib/linux64GccDPOpt/openmpi-1.4.3/libparMetisDecomp.so' is up to date.
+ wmake libso decompositionMethods
/usr/bin/ld: cannot find -lmetisDecomp
collect2: ld returned 1 exit status
make: *** [/usr/local/OpenFOAM/OpenFOAM-1.6-ext/lib/linux64GccDPOpt/libdecompositionMethods.so] Error 1
+ wmake libso lagrangian/basic
wmakeLnInclude: linking include files to ./lnInclude
...
--------------------------------------------------------

I managed to install all ThirdParty packages (as an aside: solved some trouble with the scotch...tar.gz file name, as there is a confusion of underscore and hyphen in the filename the .tar file is saved to) including Qt and ParaView. Then I started the OF compilation from the same terminal, so all environment variables should be set.
Anyway, in the course of several days trying to figure out the problem, I reinstalled everything, I sourced the bashrc files back and fourth, I did all the steps from Allwmake separately, but things hang with metisDecom resp. the linking with -ldecompositionMethods.

Some more detailed information:

Sourcing the bashrc in verbose mode gives:

-------------------------------------------------------
Sourcing: /usr/local/OpenFOAM/OpenFOAM-1.6-ext/etc/settings.sh
Using openmpi-1.4.3 from the ThirdParty package: /usr/local/OpenFOAM/ThirdParty-1.6-ext/packages/openmpi-1.4.3
Sourcing: /usr/local/OpenFOAM/ThirdParty-1.6-ext/packages/openmpi-1.4.3/platforms/linux64GccDPOpt/etc/openmpi-1.4.3.sh
Environment variables defined for OpenMPI:
OPENMPI_BIN_DIR : /usr/local/OpenFOAM/ThirdParty-1.6-ext/packages/openmpi-1.4.3/platforms/linux64GccDPOpt/bin
OPENMPI_LIB_DIR : /usr/local/OpenFOAM/ThirdParty-1.6-ext/packages/openmpi-1.4.3/platforms/linux64GccDPOpt/lib
OPENMPI_INCLUDE_DIR : /usr/local/OpenFOAM/ThirdParty-1.6-ext/packages/openmpi-1.4.3/platforms/linux64GccDPOpt/include
OPENMPI_COMPILE_FLAGS : -I/usr/local/OpenFOAM/ThirdParty-1.6-ext/packages/openmpi-1.4.3/platforms/linux64GccDPOpt/include -pthread
OPENMPI_LINK_FLAGS : -pthread -L/usr/local/OpenFOAM/ThirdParty-1.6-ext/packages/openmpi-1.4.3/platforms/linux64GccDPOpt/lib -lmpi -lopen-rte -lopen-pal -ldl -Wl,--export-dynamic -lnsl -lutil -lm -ldl
MPI_HOME : /usr/local/OpenFOAM/ThirdParty-1.6-ext/packages/openmpi-1.4.3/platforms/linux64GccDPOpt
MPI_ARCH_PATH : /usr/local/OpenFOAM/ThirdParty-1.6-ext/packages/openmpi-1.4.3/platforms/linux64GccDPOpt
OPAL_PREFIX : /usr/local/OpenFOAM/ThirdParty-1.6-ext/packages/openmpi-1.4.3/platforms/linux64GccDPOpt
PINC : -I/usr/local/OpenFOAM/ThirdParty-1.6-ext/packages/openmpi-1.4.3/platforms/linux64GccDPOpt/include -pthread
PLIBS : -pthread -L/usr/local/OpenFOAM/ThirdParty-1.6-ext/packages/openmpi-1.4.3/platforms/linux64GccDPOpt/lib -lmpi -lopen-rte -lopen-pal -ldl -Wl,--export-dynamic -lnsl -lutil -lm -ldl
Sourcing: /usr/local/OpenFOAM/ThirdParty-1.6-ext/packages/mesquite-2.1.2/platforms/linux64GccDPOpt/etc/mesquite-2.1.2.sh
MESQUITE_DIR is initialized to: /usr/local/OpenFOAM/ThirdParty-1.6-ext/packages/mesquite-2.1.2/platforms/linux64GccDPOpt
Sourcing: /usr/local/OpenFOAM/ThirdParty-1.6-ext/packages/metis-5.0pre2/platforms/linux64GccDPOpt/etc/metis-5.0pre2.sh
METIS_DIR is initialized to: /usr/local/OpenFOAM/ThirdParty-1.6-ext/packages/metis-5.0pre2/platforms/linux64GccDPOpt
Sourcing: /usr/local/OpenFOAM/ThirdParty-1.6-ext/packages/ParMetis-3.1.1/platforms/linux64GccDPOpt/etc/ParMetis-3.1.1.sh
PARMETIS_DIR is initialized to: /usr/local/OpenFOAM/ThirdParty-1.6-ext/packages/ParMetis-3.1.1/platforms/linux64GccDPOpt
Sourcing: /usr/local/OpenFOAM/ThirdParty-1.6-ext/packages/ParMGridGen-1.0/platforms/linux64GccDPOpt/etc/ParMGridGen-1.0.sh
PARMGRIDGEN_DIR is initialized to: /usr/local/OpenFOAM/ThirdParty-1.6-ext/packages/ParMGridGen-1.0/platforms/linux64GccDPOpt
Sourcing: /usr/local/OpenFOAM/ThirdParty-1.6-ext/packages/libccmio-2.6.1/platforms/linux64GccDPOpt/etc/libccmio-2.6.1.sh
LIBCCMIO_DIR is initialized to: /usr/local/OpenFOAM/ThirdParty-1.6-ext/packages/libccmio-2.6.1/platforms/linux64GccDPOpt
Sourcing: /usr/local/OpenFOAM/ThirdParty-1.6-ext/packages/scotch-5.1.10b/platforms/linux64GccDPOpt/etc/scotch-5.1.10b.sh
SCOTCH_DIR is initialized to: /usr/local/OpenFOAM/ThirdParty-1.6-ext/packages/scotch-5.1.10b/platforms/linux64GccDPOpt
Sourcing: /usr/local/OpenFOAM/ThirdParty-1.6-ext/packages/cmake-2.8.3/platforms/linux64GccDPOpt/etc/cmake-2.8.3.sh
CMAKE_DIR is initialized to: /usr/local/OpenFOAM/ThirdParty-1.6-ext/packages/cmake-2.8.3/platforms/linux64GccDPOpt
Sourcing: /usr/local/OpenFOAM/ThirdParty-1.6-ext/packages/m4-1.4.16/platforms/linux64GccDPOpt/etc/m4-1.4.16.sh
M4_DIR is initialized to: /usr/local/OpenFOAM/ThirdParty-1.6-ext/packages/m4-1.4.16/platforms/linux64GccDPOpt
Sourcing: /usr/local/OpenFOAM/ThirdParty-1.6-ext/packages/bison-2.4.3/platforms/linux64GccDPOpt/etc/bison-2.4.3.sh
BISON_DIR is initialized to: /usr/local/OpenFOAM/ThirdParty-1.6-ext/packages/bison-2.4.3/platforms/linux64GccDPOpt
Sourcing: /usr/local/OpenFOAM/ThirdParty-1.6-ext/packages/flex-2.5.35/platforms/linux64GccDPOpt/etc/flex-2.5.35.sh
FLEX_DIR is initialized to: /usr/local/OpenFOAM/ThirdParty-1.6-ext/packages/flex-2.5.35/platforms/linux64GccDPOpt
ZOLTAN_DIR is initialized to:
Sourcing: /usr/local/OpenFOAM/ThirdParty-1.6-ext/packages/Python-2.7/platforms/linux64GccDPOpt/etc/Python-2.7.sh
PYTHON_DIR is initialized to: /usr/local/OpenFOAM/ThirdParty-1.6-ext/packages/Python-2.7/platforms/linux64GccDPOpt
Sourcing: /usr/local/OpenFOAM/ThirdParty-1.6-ext/packages/qt-everywhere-opensource-src-4.7.0/platforms/linux64GccDPOpt/etc/qt-everywhere-opensource-src-4.7.0.sh
QT_DIR is initialized to: /usr/local/OpenFOAM/ThirdParty-1.6-ext/packages/qt-everywhere-opensource-src-4.7.0/platforms/linux64GccDPOpt
Sourcing: /usr/local/OpenFOAM/ThirdParty-1.6-ext/packages/ParaView-3.8.1/platforms/linux64GccDPOpt/etc/ParaView-3.8.1.sh
PARAVIEW_DIR is initialized to: /usr/local/OpenFOAM/ThirdParty-1.6-ext/packages/ParaView-3.8.1/platforms/linux64GccDPOpt
Sourcing: /usr/local/OpenFOAM/OpenFOAM-1.6-ext/etc/aliases.sh
-------------------------------------------------------

The metis stuff seems to be loaded.
I did not install zoltan in the first run, but included it in a second compilation of ThirdParty, where only zoltan was newly compiled and installed. Why does it not show up here when I source etc/bashrc?
The zoltan-3.5.sh is in $WM_THIRD_PARTY_DIR/packages/zoltan-3.5/platforms/linux64GccDPOpt/etc/.

The $PATH variable is:
/usr/local/OpenFOAM/ThirdParty-1.6-ext/packages/ParaView-3.8.1/platforms/linux64GccDPOpt/bin:/usr/local/OpenFOAM/ThirdParty-1.6-ext/packages/qt-everywhere-opensource-src-4.7.0/platforms/linux64GccDPOpt/bin:/usr/local/OpenFOAM/ThirdParty-1.6-ext/packages/Python-2.7/platforms/linux64GccDPOpt/bin:/usr/local/OpenFOAM/ThirdParty-1.6-ext/packages/flex-2.5.35/platforms/linux64GccDPOpt/bin:/usr/local/OpenFOAM/ThirdParty-1.6-ext/packages/bison-2.4.3/platforms/linux64GccDPOpt/bin:/usr/local/OpenFOAM/ThirdParty-1.6-ext/packages/m4-1.4.16/platforms/linux64GccDPOpt/bin:/usr/local/OpenFOAM/ThirdParty-1.6-ext/packages/cmake-2.8.3/platforms/linux64GccDPOpt/bin:/usr/local/OpenFOAM/ThirdParty-1.6-ext/packages/scotch-5.1.10b/platforms/linux64GccDPOpt/bin:/usr/local/OpenFOAM/ThirdParty-1.6-ext/packages/mesquite-2.1.2/platforms/linux64GccDPOpt/bin:/usr/local/OpenFOAM/ThirdParty-1.6-ext/packages/openmpi-1.4.3/platforms/linux64GccDPOpt/bin:/home/ofuser/OpenFOAM/ofuser-1.6-ext/applications/bin/linux64GccDPOpt:/usr/local/OpenFOAM/site/1.6-ext/bin/linux64GccDPOpt:/usr/local/OpenFOAM/OpenFOAM-1.6-ext/applications/bin/linux64GccDPOpt:/usr/local/OpenFOAM/OpenFOAM-1.6-ext/wmake:/usr/local/OpenFOAM/OpenFOAM-1.6-ext/bin:/usr/kerberos/bin:/usr/local/bin:/bin:/usr/bin:/opt/ofed/bin:/opt/ofed/sbin:/home/ofuser/bin

It seems as if the metis package is not in the path like all the other ThirdParty packages. Is this the source of the evil?

I use a freshly compiled system gcc 4.4.5:

gcc -v:
Configured with: ../gcc-4.4.5/configure --prefix=/usr/local --with-gmp-include=/usr/local/include --with-gmp-lib=/usr/local/lib --with-mpfr-lib=/usr/local/lib --with-mpfr-include=/usr/local/include --disable-multilib --enable-languages=c,c++,java,fortran CC=/usr/local/bin/gcc
Thread model: posix
gcc version 4.4.5 (GCC)

Our System is CentOS 5.3:

uname -a:
Linux ofmaster.cluster 2.6.18-128.4.1.el5 #1 SMP Tue Aug 4 20:19:25 EDT 2009 x86_64 x86_64 x86_64 GNU/Linux


Has anybody any idea on how I can get around this? I am getting slowly mad on this...

Thanks a lot in advance!

Cheers,

Pascal.

Attesz November 16, 2011 04:57

Hi,

did you manage to solve the problem? I have same issues on Ubuntu 11.10 with the compilation of scotch...

Regards,
Attila


All times are GMT -4. The time now is 22:36.