CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM Installation (
-   -   Error Compiling OpenFOAM-2.0.1 on Ubuntu 10.04 (

SePe December 5, 2011 17:52

Error Compiling OpenFOAM-2.0.1 on Ubuntu 10.04
Hello everybody,

since I was not satisfied with the result of the automatic ubuntu installation of openfoam, I now tried to manually install it.
But the following Problem occurs: I copied the folders "OpenFOAM-2.0.1" and "ThirdParty-2.0.1" to "/home/sebastian/OpenFOAM/" and when i run Allmake in the OpenFOAM-folder without sudo, I get many many errors. But when i execute "sudo ./Allwmake", I get the message
"/Allwmake: 10: wmakeCheckPwd: not found
Error: Current directory is not $WM_PROJECT_DIR
The environment variables are inconsistent with the installation.
Check the OpenFOAM entries in your dot-files and source them."

Does anybody know how to solve this problem?


wyldckat December 6, 2011 08:24

Greetings Sebastian,
  1. Do not use sudo to build OpenFOAM in your own home folder.
  2. Follow the official instructions to the letter:
  3. Before running Allwmake, run this:

    export WM_NCOMPPROCS=4
    Where 4 is the number of cores in your machine. This way it'll be faster building OpenFOAM.
  4. When you run Allwmake, run it like this instead:

    ./Allwmake > make.log 2>&1
    This way you'll keep a good log in "make.log" of every step taken by OpenFOAM's build process.
Good luck!

SePe December 6, 2011 19:04

Hello Bruno,

thanks alot, I now managed to compile everything. My mistake was that I did not set chmod correctly for the extracted installation files, I found out when I couldn't create the logfile you proposed.

Also the 4 processor hint was very nice :)

Thanks alot again!

Best regards,

All times are GMT -4. The time now is 23:48.