CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM Installation (
-   -   parallel running - error while loading shared libraries: (

seami December 8, 2011 11:02

parallel running - error while loading shared libraries:
I've have successfully installed OF20x from source pack.
Everything works as a single process, e.g. if I run any application or solver it works.
But the problem is in parallel. When I'm trying to run:

mpirun -np 2 simpleFoam -parallel
or any other application, that could be run in parallel. I obtain following error:

simpleFoam: error while loading shared libraries: cannot open shared object file: No such file or directory
mpirun noticed that the job aborted, but has no info as to the process
that caused that situation.

(when I run other application in parallel I obtain similar output with different library that cannot be loaded)

Does anybody have any idea where could be a problem.


seami December 9, 2011 05:39

problem SOLVED
I was checking file permission, but I haven't found anything wrong ...
anyway I recompiled OF once again in different directory and now it works fine. So I could be caused by wrong file permissions ...

Strange things happen ;-)

All times are GMT -4. The time now is 23:18.