CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM Installation (
-   -   Compiling Paraview 3.12.0 and the PV3FoamReader Module (

smpark January 9, 2012 04:35

Compiling Paraview 3.12.0 and the PV3FoamReader Module

I'm trying to install OpenFOAM-2.1.0 on our linux cluster.
Our system is running on CentOS 5.5

all libraries are built in the ThirdParty-2.1.0 directory.
ParaView is built correctly.

And I tried to compile ParaView and the PV3FoamReader Module.
For this, cmake is needed and I already installed it in the ThirdParty-2.1.0
directory, ThirdParty-2.1.0/platforms/linux64Gcc/cmake-2.8.7

And I add cmake PATH in my .bashrc file as below.

export Cmake_DIR=$WM_THIRD_PARTY_DIR/platforms/linux64Gcc/cmake-2.8.7
export PATH=$Cmake_DIR/bin:$PATH

also, I add ParaView environment variables in .bashrc

export ParaView_DIR=$WM_THIRD_PARTY_DIR/platforms/linux64Gcc/paraview-3.12.0
export PATH=$ParaView_DIR/bin:$PATH
export PV_PLUGIN_PATH=$FOAM_LIBBIN/paraview-3.12

I got correct cmake path when I commanded which cmake

until now, it looks everything's fine.

I changed directory to $FOAM_UTILITIES/postProcessing/graphics/PV3Readers
and typed command.

./Allwmake 2>&1 | tee make.log.pv3foamreader

I got Error as follows.

+ cd PV3blockMeshReader
+ mkdir -p Make/linux64GccDPOpt
+ cd Make/linux64GccDPOpt
+ cmake ../..
PV3blockMeshReader/Allwmake: line 13: cmake: command not found
+ make
make: *** No targets specified and no makefile found. Stop.
+ PV3FoamReader/Allwmake

So, I typed which cmake. Then, says
/usr/bin/which: no cmake in (~~)

I am comfused because it gave correct cmake PATH before I try to compile.

I think it seems that environment configuration is broken.

Any advice would help me to solve this problem.

Thanks in advanced.


wyldckat January 9, 2012 05:28

Greetings smpark,

Did you confirm that each variable is properly set?

echo $Cmake_DIR
And so on...

And did you start a new terminal window/tab to make sure the environment was working as intended?

Best regards,

smpark January 9, 2012 08:16

Quickly answer..
Thanks, Bruno

All environment variables are okay.

Finally, I solved this problem an hour ago.

The reason why environment configuration was broken is the wmSET command.
wmSET command written on the official OpenFOAM web page makes environment
configuration initial.

Without wmSET command, I compiled ParaView and PV3FoamReader module.

Best regards,

All times are GMT -4. The time now is 00:52.