CFD Online Discussion Forums

CFD Online Discussion Forums (https://www.cfd-online.com/Forums/)
-   OpenFOAM Installation (https://www.cfd-online.com/Forums/openfoam-installation/)
-   -   Blockmesh command not found (https://www.cfd-online.com/Forums/openfoam-installation/96395-blockmesh-command-not-found.html)

dnaneet January 21, 2012 15:30

Blockmesh command not found
 
What does the following mean?

Code:

blockMesh command not found

It worked fine until now.
Do I need to add anything else to my .bashrc file?

This is how my current .bashrc file ends



Code:


export PATH="$PATH:~$HOME/OpenFOAM/OpenFOAM-2.1.0/etc/bashrc"
export ParaView_DIR="$PATH:~/home/dnaneet/OpenFOAM/ThirdParty-2.1.0/platforms/linux64Gcc/paraview-3.12.0"
        export PATH=$ParaView_DIR/bin:$PATH
        export PV_PLUGIN_PATH=$FOAM_LIBBIN/paraview-3.12


dnaneet January 22, 2012 02:25

Partially solved...
 
I am having to source my OpenFOAM bashrc file all the time with

HTML Code:

source $HOME/OpenFOAM/OpenFOAM-2.1.0/etc/bashrc
I am unable to add it to .bashrc.
Any tips?

anon_a January 22, 2012 09:29

Quote:

Originally Posted by dnaneet (Post 340482)
I am unable to add it to .bashrc.

What is the error message?
Have you tried opening it with "sudo gedit .bashrc"?

dnaneet January 22, 2012 15:28

Heres how I solved my problem
 
Thanks for your reply.
But heres how I solved my error.

I added the following line to my .bashrc file:


Code:

source /home/dnaneet/OpenFOAM/OpenFOAM-2.1.0/etc/bashrc

I have several more questions about an example problem I am running that I'll post in the appropriate place!

Thanks! Cheers!


All times are GMT -4. The time now is 02:36.