CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM Installation (
-   -   ParaView installation problem on Suse 11.4 (

victorz February 2, 2012 13:20

ParaView installation problem on Suse 11.4
Hi all,

Problem # 1
I have installed the OpenFOAM package, and it works fine, except for ParaView. When I'm trying to install ParaView as it is suggested in the installation guide (using "./makeParaView" command in the appropriate directory), i get the following error:

************************************************** *******

./makeParaView: line 42: .: /opt/OpenFOAM/OpenFOAM-2.1.x/etc/ThirdPartyFunctions: is a directory
./makeParaView: line 43: .: /opt/OpenFOAM/OpenFOAM-2.1.x/etc/ParaViewFunctions: is a directory
./makeParaView: line 141: setVersion: command not found
./makeParaView: line 144: addCMakeVariable: command not found
./makeParaView: line 293: addVerbosity: command not found
./makeParaView: line 294: addMpiSupport: command not found
./makeParaView: line 295: addPythonSupport: command not found
./makeParaView: line 296: addMesaSupport: command not found
./makeParaView: line 297: addQtSupport: command not found
./makeParaView: line 299: setDirs: command not found
./makeParaView: line 300: echoDateStamp: command not found
./makeParaView: line 305: checkVersion: command not found

Build stages selected
-config true
-make true
-install true
Features selected
mesa false
mpi false
python false
qt true
Version information
qt none
version 3.12.0
major 3.12

./makeParaView: line 327: configParaView: command not found
./makeParaView: line 328: makeParaView: command not found
./makeParaView: line 329: installParaView: command not found

************************************************** ******

The system doesn't seem to recognize all these commands, such as installParaView, etc.

Problem # 2:

I tried to install ParaView via the Software Manager (YaST), and it works (meaning, the program starts perfectly). However, when I'm trying to run paraFoam, I'm getting the following message:

FATAL ERROR: ParaView reader module libraries do not exist

Please build the reader module before continuing:
cd $FOAM_UTILITIES/postProcessing/graphics/PV3Readers

************************************************** ***

I did what the message says, and ran paraFoam again, which resulted in the same error message.

Please, help me solve these problems and run paraFoam (and ParaView) properly.

Thanks in advance,

Irish09 February 2, 2012 15:50

Paraview Build
Hey Victor,

Based on your terminal output it looks like you do not have QT installed.


Version information
qt none
version 3.12.0
major 3.12
If you go into the ~/OpenFOAM/ThirdParty-2.0.x folder and open they give you an approximate order of execution (I have 2.0.x, so it might be slightly different, but probably not by much):


* The approximate order of execution:
+ makeGcc
+ Allwmake
+ makeQt (optional)
+ makeParaView
So I would try running makeQt and then makeParaView

wyldckat February 2, 2012 17:03

Greetings to both of you!

Victor, did you by any chance install another version of OpenFOAM before you installed 2.1.x? If so, then comment or remove the old line in the file "~/.bashrc" that pertains to the old version and start a new terminal.
The reason... well, I don't feel like repeating myself, so here is a detailed blog post of mine: Advanced tips for working with the OpenFOAM shell environment

As for installing ParaView from YaST:
  • Edit the file "$WM_PROJECT_DIR/bin/paraFoam", where "$WM_PROJECT_DIR" should have the path to your OpenFOAM installation. To see which is it, run:

    echo $WM_PROJECT_DIR
  • Go to the lines shown below and add the line in bold:

        -block | -blockMesh)

  • Save and close the file.
  • Run paraFoam like this:

    paraFoam -builtin
  • If you don't want to have to run with that additional option every time, edit the file again and look for this code:

    # reader extension

    Change "OpenFOAM" to "foam" and you are good to go!
Best regards,

victorz February 5, 2012 08:36

Thank you Bruno and Irish09,

Inserting the "requirePV=0" line solved the problem when running with the -builtin option, but it didn't help with the rest of the options. I inserted the "requirePV=0" line for the -case option as well, and for now it works fine. I am going through the tutorials, and the visualization works...
Please let me know if, for whatever reason, I shouldn't have done it :D

Have a nice week,

wyldckat February 6, 2012 18:26

Hi Victor,

With the "-builtin" option, you are using the internal reader. It's not complete, but neither is the official reader ;)
As for the other modification you've made: if it works, then it works! :D

Best regards,

All times are GMT -4. The time now is 01:02.